aboutsummaryrefslogtreecommitdiff
path: root/x11/xapp
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-01-14 06:32:27 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-01-14 06:32:27 +0000
commit89379925c45256ddb0a58fd3bb79decdd4863848 (patch)
tree42cb421cf85951caf83b9667524240a464f76586 /x11/xapp
parent5680ac4e68e89409874f3024ad6d017a10398c06 (diff)
downloadports-89379925c45256ddb0a58fd3bb79decdd4863848.tar.gz
ports-89379925c45256ddb0a58fd3bb79decdd4863848.zip
- Add missing dependency on `devel/dbus' to unbreak the build
- Restore creator attribution lost in r559718 during the repomove - Drop unused dependencies: `gettext-tools:build', `x11/libxklavier' - Reorder USE_* knobs and remove excessive vertical whitespace
Notes
Notes: svn path=/head/; revision=561536
Diffstat (limited to 'x11/xapp')
-rw-r--r--x11/xapp/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/x11/xapp/Makefile b/x11/xapp/Makefile
index 8096b0ff6a38..625d015778b3 100644
--- a/x11/xapp/Makefile
+++ b/x11/xapp/Makefile
@@ -1,3 +1,4 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
PORTNAME= xapp
@@ -12,34 +13,26 @@ LICENSE= LGPL3
LICENSE_FILE?= ${WRKSRC}/COPYING.LESSER
BUILD_DEPENDS= vapigen:lang/vala
-LIB_DEPENDS= libxklavier.so:x11/libxklavier \
+LIB_DEPENDS= libdbus-1.so:devel/dbus \
libdbusmenu-gtk3.so:devel/libdbusmenu
RUN_DEPENDS= bash:shells/bash
-USES= gettext-tools:build gnome meson pkgconfig python:3.5+ \
- shebangfix xorg
-
+USES= gnome meson pkgconfig python:3.5+ shebangfix xorg
USE_GITHUB= yes
GH_ACCOUNT= linuxmint
-
-SHEBANG_FILES= data libxapp meson-scripts schemas scripts status-applets \
- test-scripts
-BINARY_ALIAS= python3=${PYTHON_CMD}
-
-USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 introspection intltool \
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 introspection:build intltool \
libgnomekbd pygobject3
-
+USE_LDCONFIG= yes
+USE_XORG= x11
GLIB_SCHEMAS= org.x.apps.gschema.xml
INSTALLS_ICONS= yes
+SHEBANG_FILES= data libxapp meson-scripts schemas scripts status-applets \
+ test-scripts
-USE_XORG= x11
-
-USE_LDCONFIG= yes
+PLIST_SUB+= LIBVERSION=${PORTVERSION}
PORTSCOUT= limit:^[0-9.]+$$ # ignore master.mint* tags
-PLIST_SUB+= LIBVERSION=${PORTVERSION}
-
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc