aboutsummaryrefslogtreecommitdiff
path: root/x11/xascii
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2012-04-10 20:26:24 +0000
committerCy Schubert <cy@FreeBSD.org>2012-04-10 20:26:24 +0000
commit3b32f055c4de89f0396e494a355a62290f5a0925 (patch)
treeb5f147cb7391bd98ce8ef4c0ece4bfdbf98de29c /x11/xascii
parente556a5c513f2690c19cf2e59d9ef752f9eb36343 (diff)
downloadports-3b32f055c4de89f0396e494a355a62290f5a0925.tar.gz
ports-3b32f055c4de89f0396e494a355a62290f5a0925.zip
Notes
Diffstat (limited to 'x11/xascii')
-rw-r--r--x11/xascii/Makefile25
-rw-r--r--x11/xascii/distinfo2
-rw-r--r--x11/xascii/files/patch-Imakefile11
-rw-r--r--x11/xascii/files/patch-xascii.c12
-rw-r--r--x11/xascii/pkg-descr2
5 files changed, 52 insertions, 0 deletions
diff --git a/x11/xascii/Makefile b/x11/xascii/Makefile
new file mode 100644
index 000000000000..a607ab43db4b
--- /dev/null
+++ b/x11/xascii/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xascii
+# Date created: 10 April 2012
+# Whom: Cy Schubert <cy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xascii
+PORTVERSION= 1.0
+CATEGORIES= x11
+MASTER_SITES= http://komquats.com/distfiles/ \
+ http://people.freebsd.org/~cy/distfiles/
+
+WRKSRC= ${WRKDIR}
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Manipulate X cut buffers from the commandline
+
+MAKE_ARGS+= PREFIX=${PREFIX}
+USE_IMAKE= YES
+USE_XORG= x11
+MAN1= xascii.1
+PLIST_FILES= bin/xascii
+
+.include <bsd.port.mk>
diff --git a/x11/xascii/distinfo b/x11/xascii/distinfo
new file mode 100644
index 000000000000..f384d2121b76
--- /dev/null
+++ b/x11/xascii/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xascii-1.0.tar.gz) = ff0c48a251f84dc186e123849dacd151d47aff7bd4bb4bfd955b6f67dd9b0de5
+SIZE (xascii-1.0.tar.gz) = 7090
diff --git a/x11/xascii/files/patch-Imakefile b/x11/xascii/files/patch-Imakefile
new file mode 100644
index 000000000000..0fa99debeb9f
--- /dev/null
+++ b/x11/xascii/files/patch-Imakefile
@@ -0,0 +1,11 @@
+--- Imakefile.orig 1991-08-05 12:32:29.000000000 -0700
++++ Imakefile 2012-04-10 12:55:45.138341509 -0700
+@@ -1,5 +1,8 @@
+ LOCAL_LIBRARIES = XawClientLibs
+
++BINDIR = ${PREFIX}/bin
++MANPATH = ${PREFIX}${MAN1PREFIX}/man
++
+ SRCS = xascii.c
+ OBJS = xascii.o
+
diff --git a/x11/xascii/files/patch-xascii.c b/x11/xascii/files/patch-xascii.c
new file mode 100644
index 000000000000..f7dc6796fad8
--- /dev/null
+++ b/x11/xascii/files/patch-xascii.c
@@ -0,0 +1,12 @@
+--- xascii.c.orig 1991-08-05 13:57:57.000000000 -0700
++++ xascii.c 2010-10-13 16:14:45.388101391 -0700
+@@ -454,8 +454,7 @@
+ XtTranslateCoords (toplevel,
+ (Position) 0,
+ (Position) height/2,
+- &x, &y,
+- NULL);
++ &x, &y);
+
+ XtVaSetValues (pshell,
+ XtNx, x,
diff --git a/x11/xascii/pkg-descr b/x11/xascii/pkg-descr
new file mode 100644
index 000000000000..9626613de16b
--- /dev/null
+++ b/x11/xascii/pkg-descr
@@ -0,0 +1,2 @@
+Xascii displays the complete ascii character set along with each character's
+value in either decimal, hexidecimal, or octal notation.