aboutsummaryrefslogtreecommitdiff
path: root/x11/xcb-util-cursor
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-08-28 12:19:55 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-08-28 12:19:55 +0000
commitc30daf201262d2fd9438f062252e4b214c026b25 (patch)
tree1c21470556753f8f2e58320f4105e1b7941b8cbd /x11/xcb-util-cursor
parent2b6fecc52cad736dadbe4172237383f52853c91f (diff)
downloadports-c30daf201262d2fd9438f062252e4b214c026b25.tar.gz
ports-c30daf201262d2fd9438f062252e4b214c026b25.zip
Update to 0.1.0
Add dependency on gperf. Fix build with out ancient gcc.
Notes
Notes: svn path=/head/; revision=325522
Diffstat (limited to 'x11/xcb-util-cursor')
-rw-r--r--x11/xcb-util-cursor/Makefile6
-rw-r--r--x11/xcb-util-cursor/distinfo4
-rw-r--r--x11/xcb-util-cursor/files/patch-cursor__cursor.h31
-rw-r--r--x11/xcb-util-cursor/files/patch-cursor__parse_cursor_file.c10
-rw-r--r--x11/xcb-util-cursor/files/patch-cursor__shape_to_id.gperf18
-rw-r--r--x11/xcb-util-cursor/files/patch-cursor_cursor.h11
6 files changed, 35 insertions, 45 deletions
diff --git a/x11/xcb-util-cursor/Makefile b/x11/xcb-util-cursor/Makefile
index 9e74c7a9d9be..04c03c2a062d 100644
--- a/x11/xcb-util-cursor/Makefile
+++ b/x11/xcb-util-cursor/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xcb-util-cursor
-PORTVERSION= 0.0.99
+PORTVERSION= 0.1.0
CATEGORIES= x11
MASTER_SITES= http://xcb.freedesktop.org/dist/
@@ -10,7 +10,8 @@ COMMENT= XCB cursor library
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-util.pc:${PORTSDIR}/x11/xcb-util \
${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util-renderutil \
- ${LOCALBASE}/libdata/pkgconfig/xcb-image.pc:${PORTSDIR}/x11/xcb-util-image
+ ${LOCALBASE}/libdata/pkgconfig/xcb-image.pc:${PORTSDIR}/x11/xcb-util-image \
+ ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-util.pc:${PORTSDIR}/x11/xcb-util \
${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util-renderutil \
@@ -22,6 +23,7 @@ USE_XORG= xcb xorg-macros
USES= gmake
GNU_CONFIGURE= yes
+CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf"
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/x11/xcb-util-cursor/distinfo b/x11/xcb-util-cursor/distinfo
index e2d52e1fca94..58680e9753b3 100644
--- a/x11/xcb-util-cursor/distinfo
+++ b/x11/xcb-util-cursor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xcb-util-cursor-0.0.99.tar.bz2) = 14fa5bfe639d26e950047ab904c559e935bad0ffac7bc7dc0362066d0a4e55b3
-SIZE (xcb-util-cursor-0.0.99.tar.bz2) = 276739
+SHA256 (xcb-util-cursor-0.1.0.tar.bz2) = bb7bc11a977a7eca9c0b79dbe1c47ec813db98fbed6bcaf613118487a60131e5
+SIZE (xcb-util-cursor-0.1.0.tar.bz2) = 289086
diff --git a/x11/xcb-util-cursor/files/patch-cursor__cursor.h b/x11/xcb-util-cursor/files/patch-cursor__cursor.h
deleted file mode 100644
index 1e868455ea23..000000000000
--- a/x11/xcb-util-cursor/files/patch-cursor__cursor.h
+++ /dev/null
@@ -1,31 +0,0 @@
-From c7eff39a5fb3552de57e52f737ea7ae59b1ef895 Mon Sep 17 00:00:00 2001
-From: Michael Stapelberg <michael@stapelberg.de>
-Date: Fri, 12 Jul 2013 17:57:44 +0000
-Subject: don’t define xcb_cursor_context_t twice (Thanks Thomas)
-
-This fixes a compilation problem on NetBSD
----
-diff --git a/cursor/cursor.h b/cursor/cursor.h
-index a69f025..7d8c76b 100644
---- cursor/cursor.h
-+++ cursor/cursor.h
-@@ -32,6 +32,8 @@
- #include <stdbool.h>
- #include <xcb/render.h>
-
-+#include "xcb_cursor.h"
-+
- enum {
- RM_XCURSOR_THEME = 0,
- RM_XCURSOR_SIZE,
-@@ -61,7 +63,7 @@ typedef struct xcb_cursor_context_t {
- const char *path;
-
- bool render_present;
--} xcb_cursor_context_t;
-+};
-
- /*
- * Cursor files start with a header. The header
---
-cgit v0.9.0.2-2-gbebe
diff --git a/x11/xcb-util-cursor/files/patch-cursor__parse_cursor_file.c b/x11/xcb-util-cursor/files/patch-cursor__parse_cursor_file.c
deleted file mode 100644
index 3c0af278fa4f..000000000000
--- a/x11/xcb-util-cursor/files/patch-cursor__parse_cursor_file.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- cursor/parse_cursor_file.c.orig 2013-08-07 21:57:33.658269610 +0200
-+++ cursor/parse_cursor_file.c 2013-08-07 22:00:01.294253704 +0200
-@@ -33,6 +33,7 @@
- #include <errno.h>
- #include <sys/types.h>
- #include <sys/stat.h>
-+#include <sys/endian.h>
- #include <fcntl.h>
- #include <unistd.h>
-
diff --git a/x11/xcb-util-cursor/files/patch-cursor__shape_to_id.gperf b/x11/xcb-util-cursor/files/patch-cursor__shape_to_id.gperf
new file mode 100644
index 000000000000..e48d154448e4
--- /dev/null
+++ b/x11/xcb-util-cursor/files/patch-cursor__shape_to_id.gperf
@@ -0,0 +1,18 @@
+--- cursor/shape_to_id.gperf.orig 2013-08-28 14:00:29.539200308 +0200
++++ cursor/shape_to_id.gperf 2013-08-28 14:01:02.866194795 +0200
+@@ -1,5 +1,5 @@
+ struct shape_mapping { const char *name; int number; };
+-const int cursor_shape_to_id(const char *name);
++int cursor_shape_to_id(const char *name);
+ %%
+ X_cursor,0
+ arrow,1
+@@ -79,7 +79,7 @@
+ watch,75
+ xterm,76
+ %%
+-const int cursor_shape_to_id(const char *name) {
++int cursor_shape_to_id(const char *name) {
+ struct shape_mapping *mapping = in_word_set(name, strlen(name));
+ return (mapping ? (mapping->number * 2) : -1);
+ }
diff --git a/x11/xcb-util-cursor/files/patch-cursor_cursor.h b/x11/xcb-util-cursor/files/patch-cursor_cursor.h
new file mode 100644
index 000000000000..cef7e985d680
--- /dev/null
+++ b/x11/xcb-util-cursor/files/patch-cursor_cursor.h
@@ -0,0 +1,11 @@
+--- cursor/cursor.h.orig 2013-08-28 13:57:29.231213533 +0200
++++ cursor/cursor.h 2013-08-28 13:57:38.222207468 +0200
+@@ -154,7 +154,7 @@
+ } __attribute__((packed)) xcint_image_t;
+
+ /* shape_to_id.c */
+-const int cursor_shape_to_id(const char *name);
++int cursor_shape_to_id(const char *name);
+
+ /* parse_cursor_file.c */
+ int parse_cursor_file(xcb_cursor_context_t *c, const int fd, xcint_image_t **images, int *nimg);