aboutsummaryrefslogtreecommitdiff
path: root/x11/xcb-util-wm/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-01-15 12:46:11 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-01-15 12:46:11 +0000
commit26782807ea43e2c206b1913146bae222638a7a25 (patch)
tree907d65f8a6a2956c487c9ebe0b8208501790549a /x11/xcb-util-wm/Makefile
parent17a205e830c33ab5786168a8bcbc8ec7312e6e41 (diff)
downloadports-26782807ea43e2c206b1913146bae222638a7a25.tar.gz
ports-26782807ea43e2c206b1913146bae222638a7a25.zip
Notes
Diffstat (limited to 'x11/xcb-util-wm/Makefile')
-rw-r--r--x11/xcb-util-wm/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11/xcb-util-wm/Makefile b/x11/xcb-util-wm/Makefile
new file mode 100644
index 000000000000..ba13757e8785
--- /dev/null
+++ b/x11/xcb-util-wm/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xcb-util-wm
+# Date created: 2011-12-16
+# Whom: garga
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcb-util-wm
+PORTVERSION= 0.3.8
+CATEGORIES= x11
+MASTER_SITES= http://xcb.freedesktop.org/dist/
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= Framework for window manager implementation
+
+LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb \
+ xcb-util.0:${PORTSDIR}/x11/xcb-util
+#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+#USE_XORG= xau xdmcp
+#USE_AUTOTOOLS= libtool
+
+GNU_CONFIGURE= yes
+#CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf"
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>