aboutsummaryrefslogtreecommitdiff
path: root/x11/xcb-util
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-02-27 01:48:58 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-02-27 01:48:58 +0000
commit5d299f3bcb16874fd6d7d7ce6d654587728694d8 (patch)
tree828d61b6758fbba5b864cc3b9163d15898b35469 /x11/xcb-util
parent00957296aac1a4a22609af1a2f6b434c2563c1c7 (diff)
downloadports-5d299f3bcb16874fd6d7d7ce6d654587728694d8.tar.gz
ports-5d299f3bcb16874fd6d7d7ce6d654587728694d8.zip
- Add patch to fix building in 5.x [1].
- Use ${LOCALBASE}/bin/gperf in dependency as that's the one passed to configure, and it won't be installed if the base system one is found. Reported by: pointyhat (pav, erwin) [1]
Notes
Notes: svn path=/head/; revision=207969
Diffstat (limited to 'x11/xcb-util')
-rw-r--r--x11/xcb-util/Makefile2
-rw-r--r--x11/xcb-util/files/patch-image__test_xcb_image_shm.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/x11/xcb-util/Makefile b/x11/xcb-util/Makefile
index 281e74cbd79c..e6a1e195c5ff 100644
--- a/x11/xcb-util/Makefile
+++ b/x11/xcb-util/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ntarmos@ceid.upatras.gr
COMMENT= A module with libxcb/libX11 extension/replacement libraries
LIB_DEPENDS= xcb.1:${PORTSDIR}/x11/libxcb
-BUILD_DEPENDS= gperf:${PORTSDIR}/devel/gperf
+BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/x11/xcb-util/files/patch-image__test_xcb_image_shm.c b/x11/xcb-util/files/patch-image__test_xcb_image_shm.c
new file mode 100644
index 000000000000..257e8b284a14
--- /dev/null
+++ b/x11/xcb-util/files/patch-image__test_xcb_image_shm.c
@@ -0,0 +1,10 @@
+--- ./image/test_xcb_image_shm.c.orig 2006-10-07 16:41:22.000000000 -0300
++++ ./image/test_xcb_image_shm.c 2008-02-26 23:14:44.000000000 -0300
+@@ -1,6 +1,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+
++#include <sys/types.h>
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
+