aboutsummaryrefslogtreecommitdiff
path: root/x11/xclip
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-01-05 13:42:12 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-01-05 13:42:12 +0000
commit6e24ab00d3eae1657b2bee98f69d87156af676cd (patch)
tree5cc1fe2650666eb60e0092674bc71b5a3d8bdbea /x11/xclip
parent960c702eb01cfc9a4dca8765e54cc983585116ac (diff)
downloadports-6e24ab00d3eae1657b2bee98f69d87156af676cd.tar.gz
ports-6e24ab00d3eae1657b2bee98f69d87156af676cd.zip
x11/xclip: set MAINTAINER and do cleanup
Prepare por for upcoming update. Submitter already maintains several ports. PR: 251072 Submitted by: ed.arrakis@gmail.com
Notes
Notes: svn path=/head/; revision=560395
Diffstat (limited to 'x11/xclip')
-rw-r--r--x11/xclip/Makefile14
-rw-r--r--x11/xclip/files/patch-xclip-copyfile11
-rw-r--r--x11/xclip/files/patch-xclip-pastefile8
3 files changed, 29 insertions, 4 deletions
diff --git a/x11/xclip/Makefile b/x11/xclip/Makefile
index 014d174816ea..d68b2ac18c14 100644
--- a/x11/xclip/Makefile
+++ b/x11/xclip/Makefile
@@ -5,15 +5,17 @@ PORTNAME= xclip
PORTVERSION= 0.13
CATEGORIES= x11
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ed.arrakis@gmail.com
COMMENT= Interface to X selections ("the clipboard") from the command line
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf gmake iconv xorg
USE_GITHUB= yes
GH_ACCOUNT= astrand
-USES= autoreconf gmake iconv xorg
USE_XORG= x11 xmu
GNU_CONFIGURE= yes
@@ -25,8 +27,12 @@ PLIST_FILES= bin/xclip bin/xclip-copyfile bin/xclip-cutfile \
bin/xclip-pastefile \
man/man1/xclip.1.gz man/man1/xclip-copyfile.1.gz
-post-patch:
- ${REINPLACE_CMD} 's,mktemp,mktemp -t xclip,' ${WRKSRC}/xclip-copyfile
+PORTDOCS= README
+OPTIONS_DEFINE= DOCS
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xclip
diff --git a/x11/xclip/files/patch-xclip-copyfile b/x11/xclip/files/patch-xclip-copyfile
new file mode 100644
index 000000000000..68ce96052733
--- /dev/null
+++ b/x11/xclip/files/patch-xclip-copyfile
@@ -0,0 +1,11 @@
+--- xclip-copyfile.orig 2016-09-13 07:09:12 UTC
++++ xclip-copyfile
+@@ -5,7 +5,7 @@ if [ "x$1" = "x" ]; then
+ echo "-p Copy path information; preserve tree structure"
+ exit 1
+ fi
+-archive=`mktemp` || exit 1
++archive=`mktemp -t xclip` || exit 1
+ trap 'rm -f "${archive}"' 1 2 3 15
+ if [ "x$1" = "x-p" ]; then
+ tar cf "${archive}" "$@"
diff --git a/x11/xclip/files/patch-xclip-pastefile b/x11/xclip/files/patch-xclip-pastefile
new file mode 100644
index 000000000000..8c3ec4c9d078
--- /dev/null
+++ b/x11/xclip/files/patch-xclip-pastefile
@@ -0,0 +1,8 @@
+--- xclip-pastefile.orig 2020-11-05 09:03:17 UTC
++++ xclip-pastefile
+@@ -4,4 +4,4 @@ if [ "x$1" != "x" ]; then
+ echo "Usage: $0" >&2
+ exit 1
+ fi
+-xclip -selection secondary -o | gunzip -c | tar xv
++xclip -selection secondary -o | gunzip -c | tar xv -f -