aboutsummaryrefslogtreecommitdiff
path: root/x11/xdotool
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-03 05:10:00 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-03 05:10:00 +0000
commitfbc058fc5b6d012c265ef6a6fd76615e9a02bfc9 (patch)
tree04a2fa9f0046fa57cdb2e493e37f0c6b31333490 /x11/xdotool
parent8de302471723ce2d564403b8ac8f4381fdc3f283 (diff)
downloadports-fbc058fc5b6d012c265ef6a6fd76615e9a02bfc9.tar.gz
ports-fbc058fc5b6d012c265ef6a6fd76615e9a02bfc9.zip
Programatically (or manually) simulate keyboard input or mouse activity
using X11's XTEST extension. WWW: http://www.semicomplete.com/projects/xdotool/ PR: ports/114217 Submitted by: Wesley Shields <wxs at atarininja.org>
Notes
Notes: svn path=/head/; revision=194744
Diffstat (limited to 'x11/xdotool')
-rw-r--r--x11/xdotool/Makefile26
-rw-r--r--x11/xdotool/distinfo3
-rw-r--r--x11/xdotool/pkg-descr4
3 files changed, 33 insertions, 0 deletions
diff --git a/x11/xdotool/Makefile b/x11/xdotool/Makefile
new file mode 100644
index 000000000000..c7ed15a0a889
--- /dev/null
+++ b/x11/xdotool/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: xdotool
+# Date created: 29 June 2007
+# Whom: Wesley Shields <wxs@atarininja.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xdotool
+PORTVERSION= 20070625
+CATEGORIES= x11
+MASTER_SITES= http://www.semicomplete.com/files/xdotool/ \
+ http://www.atarininja.org/~wxs/distfiles/
+
+MAINTAINER= wxs@atarininja.org
+COMMENT= Programatically simulate keyboard input or mouse activity
+
+USE_GNOME= pkgconfig
+USE_XLIB= yes
+ALL_TARGET= ${PORTNAME}
+
+PLIST_FILES= bin/xdotool
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xdotool ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/xdotool/distinfo b/x11/xdotool/distinfo
new file mode 100644
index 000000000000..0d920c85071a
--- /dev/null
+++ b/x11/xdotool/distinfo
@@ -0,0 +1,3 @@
+MD5 (xdotool-20070625.tar.gz) = 78b693d1684825082cdc24450c61a9ac
+SHA256 (xdotool-20070625.tar.gz) = f90116afb9042a679329e0e9f92a47a6e7af69dc7a664c0d9c805b26611ab33c
+SIZE (xdotool-20070625.tar.gz) = 5991
diff --git a/x11/xdotool/pkg-descr b/x11/xdotool/pkg-descr
new file mode 100644
index 000000000000..0f4f601316a2
--- /dev/null
+++ b/x11/xdotool/pkg-descr
@@ -0,0 +1,4 @@
+Programatically (or manually) simulate keyboard input or mouse activity
+using X11's XTEST extension.
+
+WWW: http://www.semicomplete.com/projects/xdotool/