aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-clipman-plugin
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2011-11-05 00:12:39 +0000
committerRene Ladan <rene@FreeBSD.org>2011-11-05 00:12:39 +0000
commit1a5125ce565590bcb6fa0d0c4f4d2fc9994b6e4a (patch)
tree7552d735edd66b919ae028d6a4c392d04c77aef3 /x11/xfce4-clipman-plugin
parent7bd53bb5b7ea734f26155e3f333c6a283eecba68 (diff)
downloadports-1a5125ce565590bcb6fa0d0c4f4d2fc9994b6e4a.tar.gz
ports-1a5125ce565590bcb6fa0d0c4f4d2fc9994b6e4a.zip
- Fix build on FreeBSD 10
- Fix build with Clang
Notes
Notes: svn path=/head/; revision=285058
Diffstat (limited to 'x11/xfce4-clipman-plugin')
-rw-r--r--x11/xfce4-clipman-plugin/Makefile2
-rw-r--r--x11/xfce4-clipman-plugin/files/patch-panel-plugin__collector.c11
2 files changed, 13 insertions, 0 deletions
diff --git a/x11/xfce4-clipman-plugin/Makefile b/x11/xfce4-clipman-plugin/Makefile
index 4df0e6e57d76..85ac576ff8a2 100644
--- a/x11/xfce4-clipman-plugin/Makefile
+++ b/x11/xfce4-clipman-plugin/Makefile
@@ -30,6 +30,8 @@ USE_XORG= xtst
INSTALLS_ICONS= yes
+WITH_FBSD10_FIX= yes
+
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_UNIQUE)
diff --git a/x11/xfce4-clipman-plugin/files/patch-panel-plugin__collector.c b/x11/xfce4-clipman-plugin/files/patch-panel-plugin__collector.c
new file mode 100644
index 000000000000..d085f25b139b
--- /dev/null
+++ b/x11/xfce4-clipman-plugin/files/patch-panel-plugin__collector.c
@@ -0,0 +1,11 @@
+--- panel-plugin/collector.c.orig 2011-10-20 14:42:39.000000000 +0200
++++ panel-plugin/collector.c 2011-11-05 00:16:40.000000000 +0100
+@@ -154,7 +154,7 @@
+ gchar *text;
+ static gchar *prev_text = NULL;
+
+- g_return_if_fail (GTK_IS_CLIPBOARD (collector->priv->default_clipboard) && GTK_IS_CLIPBOARD (collector->priv->primary_clipboard));
++ g_return_val_if_fail (GTK_IS_CLIPBOARD (collector->priv->default_clipboard) && GTK_IS_CLIPBOARD (collector->priv->primary_clipboard), FALSE);
+
+ /* Postpone until the selection is done */
+ gdk_window_get_pointer (NULL, NULL, NULL, &state);