aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-clipman-plugin
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-09-15 15:13:15 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-09-15 15:13:15 +0000
commit5bebf6d215f96218dd19655ff52550b953419c1c (patch)
tree44d5d3a6ff94e87eed6b6688c7a51d19d14ec567 /x11/xfce4-clipman-plugin
parent70d698c2c5c44780149f6b7233a47fdbded786ca (diff)
downloadports-5bebf6d215f96218dd19655ff52550b953419c1c.tar.gz
ports-5bebf6d215f96218dd19655ff52550b953419c1c.zip
- Update to 1.4.0
- Remove UNIQUE option - Adjust dependencies (reported by QA script)
Notes
Notes: svn path=/head/; revision=422204
Diffstat (limited to 'x11/xfce4-clipman-plugin')
-rw-r--r--x11/xfce4-clipman-plugin/Makefile18
-rw-r--r--x11/xfce4-clipman-plugin/distinfo5
-rw-r--r--x11/xfce4-clipman-plugin/files/patch-panel-plugin_Makefile.in12
-rw-r--r--x11/xfce4-clipman-plugin/pkg-plist1
4 files changed, 24 insertions, 12 deletions
diff --git a/x11/xfce4-clipman-plugin/Makefile b/x11/xfce4-clipman-plugin/Makefile
index 3d8e278e6207..03efe92fb6e5 100644
--- a/x11/xfce4-clipman-plugin/Makefile
+++ b/x11/xfce4-clipman-plugin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-clipman-plugin
-PORTVERSION= 1.2.6
-PORTREVISION= 2
+PORTVERSION= 1.4.0
CATEGORIES= x11 xfce
MASTER_SITES= XFCE/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -13,20 +12,19 @@ COMMENT= Clipboard manager for the Xfce panel
LICENSE= GPLv2
-OPTIONS_DEFINE= QRCODE UNIQUE
-OPTIONS_DEFAULT= UNIQUE
+LIB_DEPENDS= libdbus-1.so:devel/dbus \
+ libdbus-glib-1.so:devel/dbus-glib
+
+OPTIONS_DEFINE= QRCODE
QRCODE_DESC= QR Code support
-UNIQUE_DESC= Unique (single instance) support
QRCODE_LIB_DEPENDS= libqrencode.so:graphics/libqrencode
QRCODE_CONFIGURE_ENABLE= libqrencode
-UNIQUE_LIB_DEPENDS= libunique-1.0.so:x11-toolkits/unique
-UNIQUE_CONFIGURE_ENABLE= unique
GNU_CONFIGURE= yes
-USE_GNOME= gtk20 intltool intlhack glib20
+USE_GNOME= gtk30 intltool intlhack glib20 cairo
USE_XFCE= panel
-USE_XORG= xtst xproto
-USES= gettext gmake libtool pkgconfig xfce tar:bzip2
+USE_XORG= ice sm x11 xtst xproto
+USES= gettext gmake libtool pkgconfig tar:bzip2 xfce:gtk3
INSTALLS_ICONS= yes
.include <bsd.port.mk>
diff --git a/x11/xfce4-clipman-plugin/distinfo b/x11/xfce4-clipman-plugin/distinfo
index c0787ca783a6..534370ae5c74 100644
--- a/x11/xfce4-clipman-plugin/distinfo
+++ b/x11/xfce4-clipman-plugin/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xfce4/xfce4-clipman-plugin-1.2.6.tar.bz2) = 23043f99c3e5257d1f3d68b5ee5125e3469c15620d098e22c6250386197f48a5
-SIZE (xfce4/xfce4-clipman-plugin-1.2.6.tar.bz2) = 438346
+TIMESTAMP = 1473932421
+SHA256 (xfce4/xfce4-clipman-plugin-1.4.0.tar.bz2) = a97671540663df1d90503f73695ac36e16fa2c832be8845ad9402529b8148294
+SIZE (xfce4/xfce4-clipman-plugin-1.4.0.tar.bz2) = 471045
diff --git a/x11/xfce4-clipman-plugin/files/patch-panel-plugin_Makefile.in b/x11/xfce4-clipman-plugin/files/patch-panel-plugin_Makefile.in
new file mode 100644
index 000000000000..485f46e8c8a5
--- /dev/null
+++ b/x11/xfce4-clipman-plugin/files/patch-panel-plugin_Makefile.in
@@ -0,0 +1,12 @@
+--- panel-plugin/Makefile.in.orig 2016-09-15 08:18:26 UTC
++++ panel-plugin/Makefile.in
+@@ -1326,7 +1326,8 @@ uninstall-am: uninstall-actionsDATA unin
+ @INTLTOOL_DESKTOP_RULE@
+
+ install-exec-hook:
+- $(LN_S) -f $(exec_prefix)/bin/xfce4-popup-clipman $(DESTDIR)$(exec_prefix)/bin/xfce4-popup-clipman-actions
++ cd $(DESTDIR)$(exec_prefix)/bin && \
++ $(LN_S) xfce4-popup-clipman xfce4-popup-clipman-actions
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/x11/xfce4-clipman-plugin/pkg-plist b/x11/xfce4-clipman-plugin/pkg-plist
index eb4db6c9ee45..e0e18c6e482e 100644
--- a/x11/xfce4-clipman-plugin/pkg-plist
+++ b/x11/xfce4-clipman-plugin/pkg-plist
@@ -1,6 +1,7 @@
bin/xfce4-clipman
bin/xfce4-clipman-settings
bin/xfce4-popup-clipman
+bin/xfce4-popup-clipman-actions
etc/xdg/autostart/xfce4-clipman-plugin-autostart.desktop
etc/xdg/xfce4/panel/xfce4-clipman-actions.xml
lib/xfce4/panel/plugins/libclipman.so