aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-verve-plugin/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-01-27 04:40:30 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-01-27 04:40:30 +0000
commit80349fd810b48f6b6b9e3498d61bc682af7452ee (patch)
treebb9fa2400a29b18666735095ddb467e041c1d103 /x11/xfce4-verve-plugin/Makefile
parent2d2f4b45f024d16032a0740a9be75df5b7ea2c61 (diff)
downloadports-80349fd810b48f6b6b9e3498d61bc682af7452ee.tar.gz
ports-80349fd810b48f6b6b9e3498d61bc682af7452ee.zip
Notes
Diffstat (limited to 'x11/xfce4-verve-plugin/Makefile')
-rw-r--r--x11/xfce4-verve-plugin/Makefile42
1 files changed, 13 insertions, 29 deletions
diff --git a/x11/xfce4-verve-plugin/Makefile b/x11/xfce4-verve-plugin/Makefile
index e17d8ea738f8..2abd3ab56906 100644
--- a/x11/xfce4-verve-plugin/Makefile
+++ b/x11/xfce4-verve-plugin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= verve-plugin
-PORTVERSION= 1.0.0
-PORTREVISION= 10
+PORTVERSION= 1.0.1
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/panel-plugins/${PKGNAMEPREFIX}${PORTNAME}/${PORTVERSION:R}
@@ -12,38 +11,23 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= Command line plugin for Xfce4
+COMMENT= Command line plugin for the Xfce Desktop
LICENSE= GPLv2
-LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake libtool pkgconfig tar:bzip2
USE_GNOME= glib20 intltool intlhack
-USE_XFCE= configenv panel libexo libgui libutil
-
-OPTIONS_DEFINE= NLS DBUS
-OPTIONS_DEFAULT= NLS DBUS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-CONFIGURE_ARGS+=--enable-dbus
-PLIST_SUB+= DBUS=""
-.else
-CONFIGURE_ARGS+=--disable-dbus
-PLIST_SUB+= DBUS="@comment "
-.endif
+USE_XFCE= configenv libexo libmenu libutil panel
+
+CONFIGURE_ARGS=--enable-dbus
+
+OPTIONS_DEFINE= NLS
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+OPTIONS_SUB= yes
.include <bsd.port.mk>