aboutsummaryrefslogtreecommitdiff
path: root/x11/xinit
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-29 21:51:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-29 21:51:53 +0000
commitec953dbd2cf46ff2554ba0548707b5c3af0635f2 (patch)
treeffd0e482fc994fd4edeb32004c6dc5b365efb9bb /x11/xinit
parentd802dbf113d67d50c49cadf16c99b6538c226df6 (diff)
downloadports-ec953dbd2cf46ff2554ba0548707b5c3af0635f2.tar.gz
ports-ec953dbd2cf46ff2554ba0548707b5c3af0635f2.zip
x11/xinit: Update 1.3.4 -> 1.4.0
Also add LICENSE_FILE. PR: 227075 Submitted by: Dmitri Goutnik <dg@syrec.org> Approved by: maintainer's timeout (x11@FreeBSD.org; 31 days)
Notes
Notes: svn path=/head/; revision=468661
Diffstat (limited to 'x11/xinit')
-rw-r--r--x11/xinit/Makefile4
-rw-r--r--x11/xinit/distinfo5
-rw-r--r--x11/xinit/files/patch-startx.cpp25
3 files changed, 12 insertions, 22 deletions
diff --git a/x11/xinit/Makefile b/x11/xinit/Makefile
index 97c700729cba..2e792e6947a5 100644
--- a/x11/xinit/Makefile
+++ b/x11/xinit/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xinit
-PORTVERSION= 1.3.4
-PORTREVISION= 1
+PORTVERSION= 1.4.0
PORTEPOCH= 1
CATEGORIES= x11
@@ -10,6 +9,7 @@ MAINTAINER= x11@FreeBSD.org
COMMENT= X Window System initializer
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
XORG_CAT= app
USE_XORG= x11
diff --git a/x11/xinit/distinfo b/x11/xinit/distinfo
index da6a6f5c39e9..2dab71720369 100644
--- a/x11/xinit/distinfo
+++ b/x11/xinit/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xorg/app/xinit-1.3.4.tar.bz2) = 75d88d7397a07e01db253163b7c7a00b249b3d30e99489f2734cac9a0c7902b3
-SIZE (xorg/app/xinit-1.3.4.tar.bz2) = 165881
+TIMESTAMP = 1522340675
+SHA256 (xorg/app/xinit-1.4.0.tar.bz2) = 230835eef2f5978a1e1344928168119373f6df1d0a32c09515e545721ee582ef
+SIZE (xorg/app/xinit-1.4.0.tar.bz2) = 174491
diff --git a/x11/xinit/files/patch-startx.cpp b/x11/xinit/files/patch-startx.cpp
index e3b3c01e9deb..eccc0214aa67 100644
--- a/x11/xinit/files/patch-startx.cpp
+++ b/x11/xinit/files/patch-startx.cpp
@@ -4,42 +4,31 @@
#
# generate displayname as dictated in the xauth manpage
#
---- startx.cpp.orig 2014-09-11 17:31:42 UTC
+--- startx.cpp.orig 2018-03-10 01:46:03 UTC
+++ startx.cpp
-@@ -154,7 +154,7 @@ while [ x"$1" != x ]; do
+@@ -166,7 +166,7 @@ while [ x"$1" != x ]; do
else
XCOMM display must be the FIRST server argument
if [ x"$serverargs" = x ] && @@
- expr "$1" : ':[0-9][0-9]*$' > /dev/null 2>&1; then
-+ expr \( "$1" \) : ':[0-9][0-9]*$' > /dev/null 2>&1; then
++ expr \( "$1" \) : ':[0-9][0-9]*$' > /dev/null 2>&1; then
display="$1"
else
serverargs="$serverargs $1"
-@@ -193,7 +193,7 @@ if [ x"$server" = x ]; then
- XCOMM the startx session being seen as inactive:
- XCOMM "https://bugzilla.redhat.com/show_bug.cgi?id=806491"
- tty=$(tty)
-- if expr match "$tty" '^/dev/tty[0-9]\+$' > /dev/null; then
-+ if expr "$tty" : '/dev/tty[0-9][0-9]*$' > /dev/null; then
- tty_num=$(echo "$tty" | grep -oE '[0-9]+$')
- vtarg="vt$tty_num"
- fi
-@@ -217,7 +217,7 @@ fi
+@@ -229,7 +229,7 @@ fi
XCOMM if no vt is specified add vtarg (which may be empty)
have_vtarg="no"
for i in $serverargs; do
-- if expr match "$i" '^vt[0-9]\+$' > /dev/null; then
+- if expr "$i" : 'vt[0-9][0-9]*$' > /dev/null; then
+ if expr \( "$i" \) : 'vt[0-9][0-9]*$' > /dev/null; then
have_vtarg="yes"
fi
done
-@@ -283,10 +283,10 @@ EOF
-
+@@ -296,9 +296,9 @@ EOF
XCOMM now add the same credentials to the client authority file
XCOMM if '$displayname' already exists do not overwrite it as another
-- XCOMM server man need it. Add them to the '$xserverauthfile' instead.
+ XCOMM server may need it. Add them to the '$xserverauthfile' instead.
- for displayname in $authdisplay $hostname$authdisplay; do
-+ XCOMM server may need it. Add them to the '$xserverauthfile' instead.
+ for displayname in $authdisplay $hostname/unix$authdisplay; do
authcookie=`XAUTH list "$displayname" @@
- | sed -n "s/.*$displayname[[:space:]*].*[[:space:]*]//p"` 2>/dev/null;