aboutsummaryrefslogtreecommitdiff
path: root/x11/xlockmore
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-10-18 17:56:01 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-10-18 17:56:01 +0000
commit033331fc7db836228a5d9412bf1e5e6efdb229fc (patch)
treed01c54003545a9dd46a95fa4101846b6f97fa7ff /x11/xlockmore
parent2e25939099ee4ab8051bfc6d9f0cdb52029c3d59 (diff)
downloadports-033331fc7db836228a5d9412bf1e5e6efdb229fc.tar.gz
ports-033331fc7db836228a5d9412bf1e5e6efdb229fc.zip
Notes
Diffstat (limited to 'x11/xlockmore')
-rw-r--r--x11/xlockmore/Makefile1
-rw-r--r--x11/xlockmore/files/patch-modes__dclock.c52
2 files changed, 53 insertions, 0 deletions
diff --git a/x11/xlockmore/Makefile b/x11/xlockmore/Makefile
index 71651eaee5e5..3ce49b9e629d 100644
--- a/x11/xlockmore/Makefile
+++ b/x11/xlockmore/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xlockmore
PORTVERSION= 5.40
+PORTREVISION= 1
CATEGORIES?= x11
MASTER_SITES= ftp://ibiblio.org/pub/Linux/X11/screensavers/ \
http://www.tux.org/~bagleyd/xlock/${PORTNAME}-${PORTVERSION}/ \
diff --git a/x11/xlockmore/files/patch-modes__dclock.c b/x11/xlockmore/files/patch-modes__dclock.c
new file mode 100644
index 000000000000..7af126dd8365
--- /dev/null
+++ b/x11/xlockmore/files/patch-modes__dclock.c
@@ -0,0 +1,52 @@
+--- ./modes/dclock.c.orig 2012-01-23 05:19:21.000000000 -0800
++++ ./modes/dclock.c 2012-10-17 15:20:26.000000000 -0700
+@@ -376,11 +376,11 @@
+ extern char *message;
+
+ static unsigned long
+-timeAtLastNewYear(long timeNow)
++timeAtLastNewYear(time_t timeNow)
+ {
+ struct tm *t;
+
+- t = localtime((const time_t *) &timeNow);
++ t = localtime(&timeNow);
+ return (unsigned long)(t->tm_year);
+ }
+
+@@ -420,7 +420,7 @@
+ }
+
+ static void
+-dayhrminsec(long timeCount, int tzoffset, char *string)
++dayhrminsec(time_t timeCount, int tzoffset, char *string)
+ {
+ int days, hours, minutes, secs;
+ int bufsize, i;
+@@ -675,7 +675,7 @@
+ "%a %b %d %Y", localtime(&(dp->timeold)));
+ }
+ } else {
+- long timeNow, timeLocal;
++ time_t timeNow, timeLocal;
+ timeNow = seconds();
+ timeLocal = timeNow + dp->tzoffset;
+
+@@ -950,7 +950,7 @@
+ {
+ Display *display = MI_DISPLAY(mi);
+ dclockstruct *dp;
+- long timeNow, timeLocal;
++ time_t timeNow, timeLocal;
+ int i, j;
+
+ if (dclocks == NULL) {
+@@ -1252,7 +1252,7 @@
+ dayhrminsec(MAYAN_TIME_START - timeLocal, dp->tzoffset, dp->strnew[1]);
+ dp->strpta[1] = dp->strnew[1];
+ } else {
+- struct tm *t = localtime((const time_t *) &timeLocal);
++ struct tm *t = localtime(&timeLocal);
+
+ if (dp->time24)
+ (void) strftime(dp->strnew[0], STRSIZE, "%H:%M:%S", t);