aboutsummaryrefslogtreecommitdiff
path: root/x11/xnee
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-17 10:19:31 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-17 10:19:31 +0000
commit40769eaef7e4ed473093bf271e2ced22cde7bec9 (patch)
tree34723fb453b6bca066daca6162c738d28f275e06 /x11/xnee
parent20d7801170b52d40b4607fc58c51e8bf5f461463 (diff)
downloadports-40769eaef7e4ed473093bf271e2ced22cde7bec9.tar.gz
ports-40769eaef7e4ed473093bf271e2ced22cde7bec9.zip
Update to 2.05
PR: 99049 Submitted by: Ports fury
Notes
Notes: svn path=/head/; revision=165631
Diffstat (limited to 'x11/xnee')
-rw-r--r--x11/xnee/Makefile17
-rw-r--r--x11/xnee/distinfo6
-rw-r--r--x11/xnee/files/patch-gnee__src__callbacks.c12
3 files changed, 14 insertions, 21 deletions
diff --git a/x11/xnee/Makefile b/x11/xnee/Makefile
index 1a4dca0c216b..1d252d1bb96a 100644
--- a/x11/xnee/Makefile
+++ b/x11/xnee/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xnee
-PORTVERSION= 2.03
+PORTVERSION= 2.05
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,15 +15,18 @@ DISTNAME= Xnee-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= X events recorder and player
+BUILD_DEPENDS= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
+
USE_X_PREFIX= yes
WANT_GNOME= yes
USE_GNOME= gnomehack gnometarget
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-doc
+CONFIGURE_ARGS= --mandir=${PREFIX}/man --enable-cli --disable-doc
+MAN1= cnee.1
INFO= xnee
PLIST_FILES= bin/cnee \
- lib/libxnee.a \
share/Xnee/example1.xns \
share/Xnee/simple_bash.sh \
share/Xnee/xnee.sh
@@ -40,11 +43,13 @@ CONFIGURE_ARGS+= --disable-gui
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|^#!/bin|!#!${LOCALBASE}/bin|g' \
- ${WRKSRC}/examples/simple_bash.sh
+ @${REINPLACE_CMD} -e \
+ 's|make man|$$(MAKE) man|g' ${WRKSRC}/cnee/Makefile.in
+
+post-build:
+ cd ${WRKSRC}/doc && ${LOCALBASE}/bin/makeinfo --no-split xnee.texi
post-install:
- cd ${WRKSRC}/doc && makeinfo --no-split xnee.texi
${INSTALL_DATA} ${WRKSRC}/doc/xnee.info ${PREFIX}/${INFO_PATH}
.include <bsd.port.post.mk>
diff --git a/x11/xnee/distinfo b/x11/xnee/distinfo
index 3f8f655c01c0..34365a099a5b 100644
--- a/x11/xnee/distinfo
+++ b/x11/xnee/distinfo
@@ -1,3 +1,3 @@
-MD5 (Xnee-2.03.tar.gz) = 8bab29246610d556a9a9429a270ba3b1
-SHA256 (Xnee-2.03.tar.gz) = c20373aa214400818b7bd56786ed3b787a0ae75979023d7c771e38346acb0a62
-SIZE (Xnee-2.03.tar.gz) = 511284
+MD5 (Xnee-2.05.tar.gz) = cffd6240d1b362ba2b805d115f362020
+SHA256 (Xnee-2.05.tar.gz) = 4e4a0a49bd5c5f0d89339ce360bfeb062b4302b61671c755993b4f80bbdd241f
+SIZE (Xnee-2.05.tar.gz) = 598222
diff --git a/x11/xnee/files/patch-gnee__src__callbacks.c b/x11/xnee/files/patch-gnee__src__callbacks.c
deleted file mode 100644
index 3e5f60cac177..000000000000
--- a/x11/xnee/files/patch-gnee__src__callbacks.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- gnee/src/callbacks.c.orig Thu Dec 8 08:43:13 2005
-+++ gnee/src/callbacks.c Wed Dec 21 23:02:55 2005
-@@ -467,8 +467,8 @@
- {
- GtkWidget *about_box;
- GtkWidget *about_label_1;
-- GNEE_DEBUG(("on_about1_activate\n"));
- char buf[256];
-+ GNEE_DEBUG(("on_about1_activate\n"));
-
- about_box = lookup_widget(GTK_WIDGET(user_data),
- "about_window");