aboutsummaryrefslogtreecommitdiff
path: root/x11/xnee
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-10-17 09:43:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-10-17 09:43:23 +0000
commitc5164b830ca136e159235751910a74640c560a5d (patch)
treeff051827cffd99bc3a5f10fd70d5d315f6dd9f15 /x11/xnee
parent9eae3a5720821ae19a2c61d588ff1cb6918f7e81 (diff)
downloadports-c5164b830ca136e159235751910a74640c560a5d.tar.gz
ports-c5164b830ca136e159235751910a74640c560a5d.zip
Update to version 3.07
Add LICENSE Mark MAKE_JOBS_SAFE Update projects homepage address Pass maintainership to submitter PR: ports/151498 Submitted by: Pawel Pekala <c0rn at o2.pl>
Notes
Notes: svn path=/head/; revision=263129
Diffstat (limited to 'x11/xnee')
-rw-r--r--x11/xnee/Makefile31
-rw-r--r--x11/xnee/distinfo6
-rw-r--r--x11/xnee/pkg-descr2
-rw-r--r--x11/xnee/pkg-plist15
4 files changed, 32 insertions, 22 deletions
diff --git a/x11/xnee/Makefile b/x11/xnee/Makefile
index 09cd4c13a16c..31456113cb60 100644
--- a/x11/xnee/Makefile
+++ b/x11/xnee/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= xnee
-PORTVERSION= 3.06
+PORTVERSION= 3.07
CATEGORIES= x11
MASTER_SITES= GNU
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= c0rn@o2.pl
COMMENT= X events recorder and player
+LICENSE= GPLv3
+
OPTIONS= GNEE "Build the GUI frontend" off \
PNEE "Build the Gnome Panel frontend" off
@@ -20,42 +22,35 @@ USE_XORG= xtst
USE_GNOME= gnomehack
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-cli --disable-doc
+MAKE_JOBS_SAFE= yes
+
+CONFIGURE_ARGS= --enable-cli --disable-doc --disable-xinput2
MAN1= cnee.1 xnee.1
INFO= xnee
-PLIST_FILES= bin/cnee \
- share/pixmaps/xnee.png \
- share/pixmaps/xnee.xpm \
- %%DATADIR%%/example1.xns \
- %%DATADIR%%/simple_bash.sh \
- %%DATADIR%%/xnee.sh
-PLIST_DIRS= ${PNEE_DIR} %%DATADIR%%
.include <bsd.port.pre.mk>
.if defined(WITH_GNEE)
USE_GNOME+= gtk20
MAN1+= gnee.1
-PLIST_FILES+= bin/gnee
+PLIST_SUB+= GNEE=""
+DESKTOP_ENTRIES= "Gnee" "${COMMENT}" "${PREFIX}/share/pixmaps/xnee.png" \
+ "gnee" "Development;" true
.else
CONFIGURE_ARGS+= --disable-gui
+PLIST_SUB+= GNEE="@comment "
.endif
.if defined(WITH_PNEE)
USE_GNOME+= gnomepanel
MAN1+= pnee.1
-PLIST_FILES+= libdata/bonobo/servers/pnee.server \
- libexec/pnee \
- %%DATADIR%%/pixmaps/pnee-record.png \
- %%DATADIR%%/pixmaps/pnee-replay.png \
- %%DATADIR%%/pixmaps/pnee-stop-mini.png \
- %%DATADIR%%/pixmaps/pnee-stop.png
-PNEE_DIR= %%DATADIR%%/pixmaps
+PLIST_SUB+= PNEE=""
.else
CONFIGURE_ARGS+= --disable-gnome-applet
CONFIGURE_ENV+= libgnomeui_CFLAGS="${TRUE}" \
libgnomeui_LIBS="${TRUE}"
+PLIST_SUB+= PNEE="@comment "
.endif
post-patch:
diff --git a/x11/xnee/distinfo b/x11/xnee/distinfo
index 3c1976bbc7f7..3881bb0ea6e1 100644
--- a/x11/xnee/distinfo
+++ b/x11/xnee/distinfo
@@ -1,3 +1,3 @@
-MD5 (xnee-3.06.tar.gz) = 1e68436f4be1ccb896f6db5e38957d1e
-SHA256 (xnee-3.06.tar.gz) = 3214f72f9e5f970b6e22339aacbf5793faf0b5b37c58e022942fc71d3d84186e
-SIZE (xnee-3.06.tar.gz) = 1598910
+MD5 (xnee-3.07.tar.gz) = f9fca0c7475a90487c86eca2027d0fcd
+SHA256 (xnee-3.07.tar.gz) = 305721362e1d861635996da387cc80e540a6e5e66de5992372b709fe9c2eb544
+SIZE (xnee-3.07.tar.gz) = 1779830
diff --git a/x11/xnee/pkg-descr b/x11/xnee/pkg-descr
index 0717e2b663e7..6bebce046bca 100644
--- a/x11/xnee/pkg-descr
+++ b/x11/xnee/pkg-descr
@@ -6,4 +6,4 @@ a window before it's ready to "receive" events. By recording events and
requests synchronization can be implemented. Xnee can also distribute
events (both when recording and replaying) to other displays.
-WWW: http://www.gnu.org/software/xnee/
+WWW: http://www.sandklef.com/xnee/
diff --git a/x11/xnee/pkg-plist b/x11/xnee/pkg-plist
new file mode 100644
index 000000000000..235da00c9aa0
--- /dev/null
+++ b/x11/xnee/pkg-plist
@@ -0,0 +1,15 @@
+bin/cnee
+%%GNEE%%bin/gnee
+%%PNEE%%libdata/bonobo/servers/pnee.server
+%%PNEE%%libexec/pnee
+share/pixmaps/xnee.png
+share/pixmaps/xnee.xpm
+%%DATADIR%%/example1.xns
+%%DATADIR%%/simple_bash.sh
+%%DATADIR%%/xnee.sh
+%%PNEE%%%%DATADIR%%/pixmaps/pnee-record.png
+%%PNEE%%%%DATADIR%%/pixmaps/pnee-replay.png
+%%PNEE%%%%DATADIR%%/pixmaps/pnee-stop-mini.png
+%%PNEE%%%%DATADIR%%/pixmaps/pnee-stop.png
+%%PNEE%%@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%