aboutsummaryrefslogtreecommitdiff
path: root/x11/xnotify
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-11-06 21:30:25 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-11-06 21:30:25 +0000
commit38f40beb6c1cd67fcca6885245a90538e4dbdd88 (patch)
treed6445c7f90b57cf6d5930748f2e6690c8786077d /x11/xnotify
parent663aca734615d8dbbe7a739992b8e3411f40eb5a (diff)
downloadports-38f40beb6c1cd67fcca6885245a90538e4dbdd88.tar.gz
ports-38f40beb6c1cd67fcca6885245a90538e4dbdd88.zip
x11/xnotify: respect LDFLAGS
$ CFLAGS=-fsanitize=address LDFLAGS=-fsanitize=address make [...] cc -o xnotify xnotify.o -L/usr/local/lib -L/usr/local/lib -lfontconfig -lXft -lX11 -lXinerama -lImlib2 ld: error: undefined symbol: __asan_report_load8 >>> referenced by xnotify.c:51 >>> xnotify.o:(usage) >>> referenced by xnotify.c:1082 >>> xnotify.o:(main) >>> referenced by xnotify.c:1082 >>> xnotify.o:(main) >>> referenced 172 more times
Notes
Notes: svn path=/head/; revision=554323
Diffstat (limited to 'x11/xnotify')
-rw-r--r--x11/xnotify/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/x11/xnotify/Makefile b/x11/xnotify/Makefile
index b439568d3dc7..7a6259e07283 100644
--- a/x11/xnotify/Makefile
+++ b/x11/xnotify/Makefile
@@ -18,6 +18,7 @@ USE_GITHUB= yes
USE_XORG= x11 xft xinerama
GH_ACCOUNT= phillbush
MAKE_ARGS= CC="${CC}" CPPFLAGS="${CPPFLAGS} ${CFLAGS}" \
+ LDFLAGS="${LDFLAGS} \$${LIBS}" \
PREFIX="${PREFIX}" \
LOCALINC="${LOCALBASE}/include" \
LOCALLIB="${LOCALBASE}/lib" \