aboutsummaryrefslogtreecommitdiff
path: root/x11/xnotify
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-11-05 11:50:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-11-05 11:50:32 +0000
commita9d331e0bcae9bba35bfc9da41be6c944bb1a370 (patch)
treea333da8d1a1957059cfd26bb25862f3dd2eeec79 /x11/xnotify
parent0d5ba7690e9169d7fb6e31ad9d98edbb92245b60 (diff)
downloadports-a9d331e0bcae9bba35bfc9da41be6c944bb1a370.tar.gz
ports-a9d331e0bcae9bba35bfc9da41be6c944bb1a370.zip
x11/xnotify: add new port
XNotify displays a notification on the screen. XNotify receives a notification specification in stdin and shows a notification for the user on the screen. https://github.com/phillbush/xnotify
Notes
Notes: svn path=/head/; revision=554127
Diffstat (limited to 'x11/xnotify')
-rw-r--r--x11/xnotify/Makefile47
-rw-r--r--x11/xnotify/distinfo3
-rw-r--r--x11/xnotify/pkg-descr5
3 files changed, 55 insertions, 0 deletions
diff --git a/x11/xnotify/Makefile b/x11/xnotify/Makefile
new file mode 100644
index 000000000000..b439568d3dc7
--- /dev/null
+++ b/x11/xnotify/Makefile
@@ -0,0 +1,47 @@
+# $FreeBSD$
+
+PORTNAME= xnotify
+DISTVERSION= 0.7.3
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Read notifications from stdin and display them on the screen
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libImlib2.so:graphics/imlib2 \
+ libfontconfig.so:x11-fonts/fontconfig
+
+USES= xorg
+USE_GITHUB= yes
+USE_XORG= x11 xft xinerama
+GH_ACCOUNT= phillbush
+MAKE_ARGS= CC="${CC}" CPPFLAGS="${CPPFLAGS} ${CFLAGS}" \
+ PREFIX="${PREFIX}" \
+ LOCALINC="${LOCALBASE}/include" \
+ LOCALLIB="${LOCALBASE}/lib" \
+ X11INC="${LOCALBASE}/include" \
+ X11LIB="${LOCALBASE}/lib" \
+ FREETYPEINC="${LOCALBASE}/include/freetype2" \
+ ${NULL}
+PLIST_FILES= bin/${PORTNAME} \
+ share/man/man1/${PORTNAME}.1.gz \
+ ${NULL}
+
+pre-everything::
+ @${ECHO_MSG} "To build ${PORTNAME} with your own config.h set ${PORTNAME:tu}_CONF variable"
+ @${ECHO_MSG} "either in ${.CURDIR:T}/Makefile.local, make.conf(5), environ(7) or command line e.g.,"
+ @${ECHO_MSG} "\$$ make install clean ${PORTNAME:tu}_CONF=/path/to/${PORTNAME}/config.h"
+
+post-extract:
+# .if exists(...) before bsd.port.mk ignores *_CONF in make.conf(5) and Makefile.local
+ @if [ -e "${${PORTNAME:tu}_CONF}" ]; then \
+ ${ECHO_MSG} "Creating symlink: config.h -> ${${PORTNAME:tu}_CONF}"; \
+ ${LN} -fs "${${PORTNAME:tu}_CONF}" ${WRKSRC}/config.h; \
+ fi
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/x11/xnotify/distinfo b/x11/xnotify/distinfo
new file mode 100644
index 000000000000..4d55df3a47de
--- /dev/null
+++ b/x11/xnotify/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1603946626
+SHA256 (phillbush-xnotify-0.7.3_GH0.tar.gz) = 3def3354835edaa1802f4814a6127ce3e37c12d9744acaad549c2c8ecc46d65d
+SIZE (phillbush-xnotify-0.7.3_GH0.tar.gz) = 14549
diff --git a/x11/xnotify/pkg-descr b/x11/xnotify/pkg-descr
new file mode 100644
index 000000000000..b90bac6702ce
--- /dev/null
+++ b/x11/xnotify/pkg-descr
@@ -0,0 +1,5 @@
+XNotify displays a notification on the screen. XNotify receives a
+notification specification in stdin and shows a notification for the
+user on the screen.
+
+WWW: https://github.com/phillbush/xnotify