aboutsummaryrefslogtreecommitdiff
path: root/x11/xorg-apps
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-01-05 22:57:40 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-01-05 22:57:40 +0000
commitc3c2e7cbffdd95c50e4e51af6ed725f080579b27 (patch)
tree4a30b690095b7c3b36754f571aeca80a710febd6 /x11/xorg-apps
parentb3b45538b98420f9d8207e45ca713cd7aafafc23 (diff)
downloadports-c3c2e7cbffdd95c50e4e51af6ed725f080579b27.tar.gz
ports-c3c2e7cbffdd95c50e4e51af6ed725f080579b27.zip
Convert x11@ owned ports to OptionsNG. Thanks go to bapt@ for review and help
rendered with deciphering the monster that is xorg-drivers. With hat: x11@
Notes
Notes: svn path=/head/; revision=309972
Diffstat (limited to 'x11/xorg-apps')
-rw-r--r--x11/xorg-apps/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/x11/xorg-apps/Makefile b/x11/xorg-apps/Makefile
index c9443e1a8aa7..8a65207e42e3 100644
--- a/x11/xorg-apps/Makefile
+++ b/x11/xorg-apps/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: xorg-apps
-# Date created: Jun 22 2006
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= xorg-apps
PORTVERSION= 7.5.2
@@ -35,13 +30,15 @@ do-install:
${TOUCH} ${PREFIX}/libdata/xorg/apps
.for comp in ${COMPONENTS}
-OPTIONS+= ${comp:C/:.*//:C/.*\///:U} "Install ${comp:C/:.*//:C/.*\///} application" on
+OPTIONS_DEFINE+= ${comp:C/:.*//:C/.*\///:U}
+OPTIONS_DEFAULT+= ${comp:C/:.*//:C/.*\///:U}
+${comp:C/:.*//:C/.*\///:U}_DESC= Install ${comp:C/:.*//:C/.*\///} application
.endfor
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.for comp in ${COMPONENTS}
-. if !defined(WITHOUT_${comp:C/:.*//:C/.*\///:U})
+. if ! ${PORT_OPTIONS:M${comp:C/:.*//:C/.*\///:U}}
. if ${comp:M:}==""
port=${comp}
check=${comp:C/.*\///} # doesn't work
@@ -56,4 +53,4 @@ RUN_DEPENDS:= ${RUN_DEPENDS} ${check}:${PORTSDIR}/${port}
. endif
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>