aboutsummaryrefslogtreecommitdiff
path: root/x11/xorg/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-03-28 14:36:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-03-28 14:36:16 +0000
commit76a2a3af787d030b3048384fa4d462e864ca23b5 (patch)
treef56c9f73c2cb9d172ac989769a2e216b75037a46 /x11/xorg/Makefile
parente0d234b6d6f95b95910ac17a1db94b68eac1081d (diff)
Notes
Diffstat (limited to 'x11/xorg/Makefile')
-rw-r--r--x11/xorg/Makefile31
1 files changed, 5 insertions, 26 deletions
diff --git a/x11/xorg/Makefile b/x11/xorg/Makefile
index 27b7b561ef3f..8e43237b4dca 100644
--- a/x11/xorg/Makefile
+++ b/x11/xorg/Makefile
@@ -14,6 +14,7 @@ COMMENT= X.Org complete distribution metaport
NO_BUILD= yes
NO_MTREE= yes
+NO_INSTALL= yes
RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dri.pc:${PORTSDIR}/graphics/dri
@@ -23,18 +24,13 @@ RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/xbitmaps.pc:${PORTSDIR}/x11/xbitmap
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-# doc
-.if ${PORT_OPTIONS:MDOCS}
-RUN_DEPENDS+= ${LOCALBASE}/share/doc/xorg-docs/README.xml:${PORTSDIR}/x11/xorg-docs
-.endif
+DOCS_RUN_DEPENDS+= ${LOCALBASE}/share/doc/xorg-docs/README.xml:${PORTSDIR}/x11/xorg-docs
# app, lib, font, driver
RUN_DEPENDS+= xorg-apps>0:${PORTSDIR}/x11/xorg-apps \
xorg-libraries>0:${PORTSDIR}/x11/xorg-libraries \
- ${LOCALBASE}/libdata/xorg/fonts:${PORTSDIR}/x11-fonts/xorg-fonts \
- ${LOCALBASE}/libdata/xorg/drivers:${PORTSDIR}/x11-drivers/xorg-drivers
+ xorg-fonts>0:${PORTSDIR}/x11-fonts/xorg-fonts \
+ xorg-drivers>0:${PORTSDIR}/x11-drivers/xorg-drivers
.if defined(XORG_COMPLETE)
RUN_DEPENDS+= Xnest:${PORTSDIR}/x11-servers/xorg-nestserver \
@@ -42,21 +38,4 @@ RUN_DEPENDS+= Xnest:${PORTSDIR}/x11-servers/xorg-nestserver \
Xvfb:${PORTSDIR}/x11-servers/xorg-vfbserver
.endif
-do-install: # empty
-
-pre-everything::
- @${ECHO_MSG} "This is a meta-port, meaning that it just depends on its subparts of the port."
- @${ECHO_MSG} "It won't build and install all the parts until you have typed make install"
- @${ECHO_MSG} "This port does not ensure things are upgraded; use portupgrade if you want to"
- @${ECHO_MSG} "upgrade X.Org. If you simply type 'make install' it may use over 2GB to build"
- @${ECHO_MSG} "all of the subports. You can install the ports singly if you are low on space."
-
-.include <bsd.port.pre.mk>
-
-.if make(package)
-.if !defined(DEPENDS_TARGET:Mpackage) || empty(DEPENDS_TARGET:Mpackage)
-DEPENDS_TARGET="package"
-.endif
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>