aboutsummaryrefslogtreecommitdiff
path: root/x11/xpra-html5
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-02-10 12:01:33 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-02-10 12:16:33 +0000
commit600442ff6837e1395f319e5f5b15968438ca0723 (patch)
tree33a886439b1e109888622412748177c9c6f0a996 /x11/xpra-html5
parentbe962746bf7276a32abf9c8c441c57dd3e1e31cd (diff)
downloadports-600442ff6837e1395f319e5f5b15968438ca0723.tar.gz
ports-600442ff6837e1395f319e5f5b15968438ca0723.zip
x11/xpra-html5: Update to 11.0
Reported by: portscout!
Diffstat (limited to 'x11/xpra-html5')
-rw-r--r--x11/xpra-html5/Makefile2
-rw-r--r--x11/xpra-html5/distinfo6
-rw-r--r--x11/xpra-html5/files/patch-setup.py20
3 files changed, 24 insertions, 4 deletions
diff --git a/x11/xpra-html5/Makefile b/x11/xpra-html5/Makefile
index 14aaeb0dcdec..0d44042de739 100644
--- a/x11/xpra-html5/Makefile
+++ b/x11/xpra-html5/Makefile
@@ -1,5 +1,5 @@
PORTNAME= xpra-html5
-PORTVERSION= 10.1
+PORTVERSION= 11.0
DISTVERSIONPREFIX= v
CATEGORIES= x11
diff --git a/x11/xpra-html5/distinfo b/x11/xpra-html5/distinfo
index b55d9af525ec..894a9a5d97a1 100644
--- a/x11/xpra-html5/distinfo
+++ b/x11/xpra-html5/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1702808196
-SHA256 (Xpra-org-xpra-html5-v10.1_GH0.tar.gz) = cea097b38ad57d5119be729f1378c5bad7b99e99c035e792241d383975154368
-SIZE (Xpra-org-xpra-html5-v10.1_GH0.tar.gz) = 2354055
+TIMESTAMP = 1707565309
+SHA256 (Xpra-org-xpra-html5-v11.0_GH0.tar.gz) = f306707377702f47898fec308f6c0dd18b1b7f96f8ef19d35e2ad44c08c3c215
+SIZE (Xpra-org-xpra-html5-v11.0_GH0.tar.gz) = 2354981
diff --git a/x11/xpra-html5/files/patch-setup.py b/x11/xpra-html5/files/patch-setup.py
new file mode 100644
index 000000000000..d2284ad56905
--- /dev/null
+++ b/x11/xpra-html5/files/patch-setup.py
@@ -0,0 +1,20 @@
+--- setup.py.orig 2024-01-31 12:10:11 UTC
++++ setup.py
+@@ -50,7 +50,7 @@ def get_output_line(cmd: str) -> str:
+ out, _ = proc.communicate()
+ if proc.returncode != 0:
+ print(f"Error: {cmd} returned {proc.returncode}")
+- return None
++ return ""
+ return out.splitlines()[0]
+
+
+@@ -316,7 +316,7 @@ def install_html5(root="/", install_dir="/usr/share/xp
+ jar = yuicompressor.get_jar_filename()
+ java_cmd = os.environ.get("JAVA", "java")
+ minify_cmd = [java_cmd, "-jar", jar]
+- except OSError:
++ except:
+ minify_cmd = ["yuicompressor"]
+ minify_cmd += [
+ fsrc,