aboutsummaryrefslogtreecommitdiff
path: root/x11/xpra
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2020-12-17 17:27:19 +0000
committerGleb Popov <arrowd@FreeBSD.org>2020-12-17 17:27:19 +0000
commite4d769a0ff480b80dedef2198b8656b5f2a70b87 (patch)
treef588125cd0874933d7c00772e08528e809cccca0 /x11/xpra
parent9a22324f7afb7b70128334fcd50c9899d3917356 (diff)
downloadports-e4d769a0ff480b80dedef2198b8656b5f2a70b87.tar.gz
ports-e4d769a0ff480b80dedef2198b8656b5f2a70b87.zip
x11/xpra: Restore AVAHI option, now that Avahi port got updated with Python 3 support.
Notes
Notes: svn path=/head/; revision=558307
Diffstat (limited to 'x11/xpra')
-rw-r--r--x11/xpra/Makefile11
-rw-r--r--x11/xpra/pkg-plist15
2 files changed, 22 insertions, 4 deletions
diff --git a/x11/xpra/Makefile b/x11/xpra/Makefile
index 0f244f9376ca..8ed855d973a1 100644
--- a/x11/xpra/Makefile
+++ b/x11/xpra/Makefile
@@ -2,6 +2,7 @@
PORTNAME= xpra
PORTVERSION= 4.0.5
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://xpra.org/src/
@@ -47,9 +48,9 @@ sh_OLD_CMD= /usr/bin/sh
sh_CMD= /bin/sh
MAKE_ENV= XPRA_USE_PROCESS_POLLING=1
-OPTIONS_DEFINE= AVCODEC CUPS FFMPEG GSTREAMER HTML5 LIBYUV SWSCALE VPX \
+OPTIONS_DEFINE= AVAHI AVCODEC CUPS FFMPEG GSTREAMER HTML5 LIBYUV SWSCALE VPX \
WEBCAM X264 X265
-OPTIONS_DEFAULT= AVCODEC CUPS FFMPEG GSTREAMER HTML5 LIBYUV SWSCALE VPX \
+OPTIONS_DEFAULT= AVAHI AVCODEC CUPS FFMPEG GSTREAMER HTML5 LIBYUV SWSCALE VPX \
X264 X265
OPTIONS_SUB= yes
@@ -65,6 +66,8 @@ WEBCAM_DESC= Enable webcam forwarding (client only)
X264_DESC= Enable X264 encoder
X265_DESC= Enable X265 encoder
+AVAHI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}avahi>0:net/py-avahi@${PY_FLAVOR}
+AVAHI_VARS= XPRA_OPTIONS+=mdns
AVCODEC_VARS= XPRA_OPTIONS+=dec_avcodec2
CUPS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycups>1:print/py-pycups@${PY_FLAVOR}
CUPS_VARS= XPRA_OPTIONS+=printing
@@ -91,8 +94,8 @@ X265_VARS= XPRA_OPTIONS+=enc_x265
PYDISTUTILS_PKGNAME= xpra_all
XPRA_OPTIONS_ALL+= ${XPRA_OPTIONS_DISABLED} csc_libyuv csc_swscale \
dec_avcodec2 enc_ffmpeg enc_x264 enc_x265 html5 \
- printing sound vpx webcam
-XPRA_OPTIONS_DISABLED= mdns minify netdev uinput Xdummy Xdummy_wrapper
+ mdns printing sound vpx webcam
+XPRA_OPTIONS_DISABLED= minify netdev uinput Xdummy Xdummy_wrapper
.include <bsd.port.options.mk>
diff --git a/x11/xpra/pkg-plist b/x11/xpra/pkg-plist
index 2ea961e06af2..a045d9271b35 100644
--- a/x11/xpra/pkg-plist
+++ b/x11/xpra/pkg-plist
@@ -604,6 +604,21 @@ libexec/xpra/xdg-open
%%PYTHON_SITELIBDIR%%/xpra/net/fake_jitter.py
%%PYTHON_SITELIBDIR%%/xpra/net/file_transfer.py
%%PYTHON_SITELIBDIR%%/xpra/net/header.py
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__init__.py
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__pycache__/__init__.cpython-37.opt-1.pyc
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__pycache__/__init__.cpython-37.pyc
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__pycache__/avahi_listener.cpython-37.opt-1.pyc
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__pycache__/avahi_listener.cpython-37.pyc
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__pycache__/avahi_publisher.cpython-37.opt-1.pyc
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__pycache__/avahi_publisher.cpython-37.pyc
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__pycache__/zeroconf_listener.cpython-37.opt-1.pyc
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__pycache__/zeroconf_listener.cpython-37.pyc
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__pycache__/zeroconf_publisher.cpython-37.opt-1.pyc
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/__pycache__/zeroconf_publisher.cpython-37.pyc
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/avahi_listener.py
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/avahi_publisher.py
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/zeroconf_listener.py
+%%AVAHI%%%%PYTHON_SITELIBDIR%%/xpra/net/mdns/zeroconf_publisher.py
%%PYTHON_SITELIBDIR%%/xpra/net/mmap_pipe.py
%%PYTHON_SITELIBDIR%%/xpra/net/net_util.py
%%PYTHON_SITELIBDIR%%/xpra/net/packet_encoding.py