aboutsummaryrefslogtreecommitdiff
path: root/x11/xscreensaver/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2014-06-13 18:25:07 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2014-06-13 18:25:07 +0000
commit1dc89334497f6ea3fb53d91f64fab85b64203cbf (patch)
tree3b49636e5f9c13d6d31a5de00de540ee5df8019f /x11/xscreensaver/Makefile
parent7ff7f690e6be658f7649cd4619a6b28fb2f42ae9 (diff)
downloadports-1dc89334497f6ea3fb53d91f64fab85b64203cbf.tar.gz
ports-1dc89334497f6ea3fb53d91f64fab85b64203cbf.zip
Notes
Diffstat (limited to 'x11/xscreensaver/Makefile')
-rw-r--r--x11/xscreensaver/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index a0e849dc6370..ba0724ea9aba 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xscreensaver
-PORTVERSION= 5.26
+PORTVERSION= 5.29
PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/
@@ -28,6 +28,7 @@ USE_XORG= xpm xext xxf86misc
USE_GL= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
+USE_GNOME= intltool
CONFIGURE_ENV+= "CPPFLAGS= -I ${LOCALBASE}/include" "LDFLAGS= -L ${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-gtk --with-gl --with-gle --with-pixbuf --with-xpm \
--with-jpeg=${LOCALBASE} --with-xshm-ext --with-xdbe-ext \
@@ -36,8 +37,9 @@ CONFIGURE_ARGS= --with-gtk --with-gl --with-gle --with-pixbuf --with-xpm \
--with-dpms-ext --with-xinerama-ext --with-xf86vmode-ext \
--with-xf86gamma-ext --with-randr-ext --enable-locking
-OPTIONS_DEFINE= KERBEROS PAM SETUID_HACKS FIREF XAOS1 XDALI XURTH XMOUN XPLAN \
- XSNOW
+OPTIONS_DEFINE= KERBEROS PAM PTHREADS SETUID_HACKS FIREF XAOS1 XDALI XURTH \
+ XMOUN XPLAN XSNOW
+PTHREADS_DESC= Use pthreads for SMP support
SETUID_HACKS_DESC= Install sonar hack suid so it can ping
FIREF_DESC= Add extra port x11/fireflies
XAOS1_DESC= Add extra port graphics/xaos
@@ -64,6 +66,9 @@ PLIST_SUB+= PAM="@comment not installed: "
.if ${PORT_OPTIONS:MSETUID_HACKS}
CONFIGURE_ARGS+= --with-setuid-hacks
.endif
+.if ${PORT_OPTIONS:MPTHREADS}
+CONFIGURE_ARGS+= --with-pthreads
+.endif
.if ${PORT_OPTIONS:MFIREF}
RUN_DEPENDS+= ${LOCALBASE}/bin/xscreensaver-hacks/fireflies:${PORTSDIR}/x11/fireflies