aboutsummaryrefslogtreecommitdiff
path: root/x11/xsettingsd
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-26 08:03:06 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-26 08:03:06 +0000
commit48767912268fb9d9c47bc8efea3a4e6d4cb71763 (patch)
tree58bb2411287466e1d669b3de4eb1c090e8031497 /x11/xsettingsd
parenta31cd20709ce4d57e13e18c2eeba34079bbaff1f (diff)
downloadports-48767912268fb9d9c47bc8efea3a4e6d4cb71763.tar.gz
ports-48767912268fb9d9c47bc8efea3a4e6d4cb71763.zip
Notes
Diffstat (limited to 'x11/xsettingsd')
-rw-r--r--x11/xsettingsd/Makefile31
-rw-r--r--x11/xsettingsd/distinfo3
-rw-r--r--x11/xsettingsd/pkg-descr9
3 files changed, 43 insertions, 0 deletions
diff --git a/x11/xsettingsd/Makefile b/x11/xsettingsd/Makefile
new file mode 100644
index 000000000000..1e917c1ffe2b
--- /dev/null
+++ b/x11/xsettingsd/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= xsettingsd
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0-2
+DISTVERSIONSUFFIX= -g1b2bcca
+CATEGORIES= x11
+
+MAINTAINER= aou@eecs.berkeley.edu
+COMMENT= Daemon that implements the XSETTINGS specification
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= compiler:c++11-lang pkgconfig scons
+USE_GITHUB= yes
+GH_ACCOUNT= derat
+USE_XORG= x11
+
+PLIST_FILES= bin/dump_xsettings \
+ bin/xsettingsd \
+ man/man1/dump_xsettings.1.gz \
+ man/man1/xsettingsd.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dump_xsettings ${WRKSRC}/xsettingsd \
+ ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/dump_xsettings.1 ${WRKSRC}/xsettingsd.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/x11/xsettingsd/distinfo b/x11/xsettingsd/distinfo
new file mode 100644
index 000000000000..503795f29b0e
--- /dev/null
+++ b/x11/xsettingsd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1548461504
+SHA256 (derat-xsettingsd-v1.0.0-2-g1b2bcca_GH0.tar.gz) = 49b63f4c278794c5818cfce1dc24d42ce60d114e1fc84a1cc5f256d2c390d437
+SIZE (derat-xsettingsd-v1.0.0-2-g1b2bcca_GH0.tar.gz) = 23639
diff --git a/x11/xsettingsd/pkg-descr b/x11/xsettingsd/pkg-descr
new file mode 100644
index 000000000000..f55e6d66438a
--- /dev/null
+++ b/x11/xsettingsd/pkg-descr
@@ -0,0 +1,9 @@
+xsettingsd is a daemon that implements the XSETTINGS specification.
+
+It is intended to be small, fast, and minimally dependent on other
+libraries. It can serve as an alternative to gnome-settings-daemon
+for users who are not using the GNOME desktop environment but who
+still run GTK+ applications and want to configure things such as
+themes, font antialiasing/hinting, and UI sound effects.
+
+WWW: https://github.com/derat/xsettingsd