aboutsummaryrefslogtreecommitdiff
path: root/x11/xstroke
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-05-12 21:52:49 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-05-12 21:52:49 +0000
commit17163561d2c17292580ab6e46fa17b977c58b050 (patch)
treeb0225565589325c6cde65e151979ac6f6cc3595d /x11/xstroke
parent4c0d467ead3f76a66d8ace942dc73322beff6df4 (diff)
downloadports-17163561d2c17292580ab6e46fa17b977c58b050.tar.gz
ports-17163561d2c17292580ab6e46fa17b977c58b050.zip
Un-break after Xft and XFree86 4.3 changes.
Notes
Notes: svn path=/head/; revision=80853
Diffstat (limited to 'x11/xstroke')
-rw-r--r--x11/xstroke/Makefile15
-rw-r--r--x11/xstroke/files/patch-Imakefile8
-rw-r--r--x11/xstroke/files/patch-action_item.h11
3 files changed, 21 insertions, 13 deletions
diff --git a/x11/xstroke/Makefile b/x11/xstroke/Makefile
index 3351f4c34890..b75d3bcdd2e6 100644
--- a/x11/xstroke/Makefile
+++ b/x11/xstroke/Makefile
@@ -1,4 +1,3 @@
-# ex:ts=8
# Ports collection makefile for: xstroke
# Date created: May 14, 2002
# Whom: ijliao
@@ -15,22 +14,20 @@ MASTER_SITES= ftp://ftp.handhelds.org/pub/projects/xstroke/release-${PORTVERSION
MAINTAINER= ports@FreeBSD.org
COMMENT= Fullscreen gesture recognition
-BROKEN= Needs updates for Xft and XFree86 4.3
-
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt \
+ Xft.2:${PORTSDIR}/x11-fonts/Xft
USE_REINPLACE= yes
USE_BISON= yes
USE_IMAKE= yes
-CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lgnugetopt
+CFLAGS+= ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt ${PTHREAD_LIBS}
+MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= xstroke.1
post-patch:
- @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g ; \
- s,%%CFLAGS%%,${CFLAGS},g ; \
- s,%%LDFLAGS%%,${LDFLAGS},g" ${WRKSRC}/Imakefile
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/etc/Imakefile
@${REINPLACE_CMD} -e "s,etc/,${PREFIX}/etc/,g" ${WRKSRC}/args.h
diff --git a/x11/xstroke/files/patch-Imakefile b/x11/xstroke/files/patch-Imakefile
index 7d6a7e68e121..8beae80ccf58 100644
--- a/x11/xstroke/files/patch-Imakefile
+++ b/x11/xstroke/files/patch-Imakefile
@@ -1,13 +1,13 @@
---- Imakefile.orig Tue Dec 11 06:17:11 2001
-+++ Imakefile Tue May 14 16:06:49 2002
+--- Imakefile.orig Mon Dec 10 14:17:11 2001
++++ Imakefile Mon May 12 14:55:25 2003
@@ -1,9 +1,10 @@
#define IHaveSubdirs
SUBDIRS=etc
-CDEBUGFLAGS=-g -ansi -ansi-error -Wall -pedantic
-+CDEBUGFLAGS=%%CFLAGS%%
++EXTRA_DEFINES=$(CPPFLAGS) $(XFTINCLUDES)
YFLAGS=-d
-LOCAL_LIBRARIES=$(XTESTLIB) $(XLIB) $(XRENDERLIB) $(XFTLIB) -lm -ldl -lpthread
-+LOCAL_LIBRARIES=$(XTESTLIB) $(XLIB) $(XRENDERLIB) $(XFTLIB) -lm -lpthread %%LDFLAGS%%
++LOCAL_LIBRARIES=$(XTESTLIB) $(XLIB) $(XRENDERLIB) $(XFTLIB) -lm $(LDFLAGS)
FLEX=flex
+YACC=bison -y
OBJS=xstroke.o args.o backing.o bresenham.o brush.o control_win.o stroke.o matrix.o \
diff --git a/x11/xstroke/files/patch-action_item.h b/x11/xstroke/files/patch-action_item.h
new file mode 100644
index 000000000000..949ad55e2b23
--- /dev/null
+++ b/x11/xstroke/files/patch-action_item.h
@@ -0,0 +1,11 @@
+--- action_item.h.orig Mon May 12 14:36:48 2003
++++ action_item.h Mon May 12 14:36:59 2003
+@@ -18,7 +18,7 @@
+
+ #include <X11/X.h>
+ #define XK_MISCELLANY
+-#include <X11/keysymdef.h>
++#include <X11/keysym.h>
+ #include <X11/Xutil.h>
+
+ enum action_type