aboutsummaryrefslogtreecommitdiff
path: root/x11/xterm
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-02-08 08:51:10 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-02-08 08:51:10 +0000
commitb823107c1c5aeaecf513e5a458524dc0ff7407fa (patch)
tree0db0939a4ff1ffa3c392c88cb0d1a2aa06216571 /x11/xterm
parent59f3261db8d2f43ff09206ae1288b51aee63ebc0 (diff)
downloadports-b823107c1c5aeaecf513e5a458524dc0ff7407fa.tar.gz
ports-b823107c1c5aeaecf513e5a458524dc0ff7407fa.zip
Fix build with XAW3DXFT enabled
Notified by: olgeni (via mail)
Notes
Notes: svn path=/head/; revision=564682
Diffstat (limited to 'x11/xterm')
-rw-r--r--x11/xterm/Makefile2
-rw-r--r--x11/xterm/files/extrapatch-main.c25
2 files changed, 27 insertions, 0 deletions
diff --git a/x11/xterm/Makefile b/x11/xterm/Makefile
index 9711a4f737c0..40e4050ca922 100644
--- a/x11/xterm/Makefile
+++ b/x11/xterm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xterm
PORTVERSION= 365
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ftp://ftp.invisible-island.net/xterm/:src1 \
https://invisible-mirror.net/archives/xterm/:src1 \
@@ -72,6 +73,7 @@ WCHAR_CONFIGURE_ENABLE= wide-chars
WCHAR_VARS= PKGMESSAGE="${PKGDIR}/pkg-message.wchar"
XAW3DXFT_LIB_DEPENDS= libXaw3dxft.so:x11-toolkits/libxaw3dxft
XAW3DXFT_CONFIGURE_WITH= Xaw3dxft
+XAW3DXFT_EXTRA_PATCHES= ${FILESDIR}/extrapatch-main.c
XAW3D_LIB_DEPENDS= libXaw3d.so:x11-toolkits/Xaw3d
XAW3D_CONFIGURE_WITH= Xaw3d
XINERAMA_USE= XORG=xinerama,xorgproto
diff --git a/x11/xterm/files/extrapatch-main.c b/x11/xterm/files/extrapatch-main.c
new file mode 100644
index 000000000000..eae64d9bebeb
--- /dev/null
+++ b/x11/xterm/files/extrapatch-main.c
@@ -0,0 +1,25 @@
+--- main.c.orig 2021-02-02 00:20:59 UTC
++++ main.c
+@@ -2210,9 +2210,6 @@ main(int argc, char *argv[]ENVP_ARG)
+ char *my_class = x_strdup(DEFCLASS);
+ unsigned line_speed = VAL_LINE_SPEED;
+ Window winToEmbedInto = None;
+-#if defined(HAVE_LIB_XAW3DXFT)
+- Xaw3dXftData *xaw3dxft_data;
+-#endif
+
+ ProgramName = argv[0];
+
+@@ -2330,12 +2327,6 @@ main(int argc, char *argv[]ENVP_ARG)
+ /* This dumped core on HP-UX 9.05 with X11R5 */
+ #if OPT_I18N_SUPPORT
+ XtSetLanguageProc(NULL, NULL, NULL);
+-#endif
+-
+- /* enable Xft support in Xaw3DXft */
+-#if defined(HAVE_LIB_XAW3DXFT)
+- GET_XAW3DXFT_DATA(xaw3dxft_data);
+- xaw3dxft_data->encoding = -1;
+ #endif
+
+ #ifdef TERMIO_STRUCT /* { */