aboutsummaryrefslogtreecommitdiff
path: root/x11/xtrlock
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-23 11:40:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-23 11:40:52 +0000
commit206b294339cb6961c5e8156f564eff4503905b04 (patch)
treec219e3d03630a2c6d5a414e676951f45d4c5fac9 /x11/xtrlock
parent9296daba21de0ea0c5ea24d2613902652cb40bae (diff)
downloadports-206b294339cb6961c5e8156f564eff4503905b04.tar.gz
ports-206b294339cb6961c5e8156f564eff4503905b04.zip
Add xtrlock, a minimal transparent X lock. Transparent means that all windows
are still visible and updated on the locked session. PR: ports/66964 Submitted by: Alexey Y. Mikhailov <karma@ez.pereslavl.ru>
Notes
Notes: svn path=/head/; revision=109778
Diffstat (limited to 'x11/xtrlock')
-rw-r--r--x11/xtrlock/Makefile25
-rw-r--r--x11/xtrlock/distinfo2
-rw-r--r--x11/xtrlock/files/Makefile39
-rw-r--r--x11/xtrlock/files/patch-xtrlock.c16
-rw-r--r--x11/xtrlock/pkg-descr1
5 files changed, 83 insertions, 0 deletions
diff --git a/x11/xtrlock/Makefile b/x11/xtrlock/Makefile
new file mode 100644
index 000000000000..5c6bc2a5aac4
--- /dev/null
+++ b/x11/xtrlock/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xtrlock
+# Date created: 18 May 2004
+# Whom: Alexey Mikhailov <karma@ez.pereslavl.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xtrlock
+PORTVERSION= 2.0.8
+CATEGORIES= x11
+MASTER_SITES= http://ftp.debian.org/debian/pool/main/x/xtrlock/
+DISTNAME= ${PORTNAME}_2.0-8
+
+MAINTAINER= karma@ez.pereslavl.ru
+COMMENT= X Transparent Lock
+
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.0
+MAKEFILE= ${FILESDIR}/Makefile
+
+MAN1= xtrlock.1
+PLIST_FILES= bin/xtrlock
+
+.include <bsd.port.mk>
diff --git a/x11/xtrlock/distinfo b/x11/xtrlock/distinfo
new file mode 100644
index 000000000000..415dba149c17
--- /dev/null
+++ b/x11/xtrlock/distinfo
@@ -0,0 +1,2 @@
+MD5 (xtrlock_2.0-8.tar.gz) = db68dc8f1e4b5b55183cc3c33a5bd799
+SIZE (xtrlock_2.0-8.tar.gz) = 7310
diff --git a/x11/xtrlock/files/Makefile b/x11/xtrlock/files/Makefile
new file mode 100644
index 000000000000..ea8886dd492d
--- /dev/null
+++ b/x11/xtrlock/files/Makefile
@@ -0,0 +1,39 @@
+# Makefile for xtrlock - X Transparent Lock
+# This Makefile provided for those of you who lack a functioning xmkmf.
+#
+# Copyright (C)1993,1994 Ian Jackson
+#
+# This is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# $FreeBSD$
+#
+
+LDLIBS=-lX11 -lcrypt
+CC=gcc
+CFLAGS=-I${X11BASE}/include -L${X11BASE}/lib
+INSTALL=install -c
+INSTALL_PROGRAM = ${INSTALL}
+INSTPGMFLAGS = -s -o root -m4111
+OBJS=xtrlock.o
+
+xtrlock: xtrlock.o
+ ${CC} ${CFLAGS} ${LDLIBS} -o xtrlock ${OBJS}
+
+xtrlock.o: xtrlock.c lock.bitmap mask.bitmap patchlevel.h
+ ${CC} -c ${CFLAGS} xtrlock.c
+
+install: xtrlock install.man
+ $(INSTALL_PROGRAM) $(INSTPGMFLAGS) xtrlock ${PREFIX}/bin
+
+install.man:
+ $(INSTALL) -m 644 xtrlock.man ${PREFIX}/man/man1/xtrlock.1
+
+all: xtrlock
diff --git a/x11/xtrlock/files/patch-xtrlock.c b/x11/xtrlock/files/patch-xtrlock.c
new file mode 100644
index 000000000000..41feb0ef7974
--- /dev/null
+++ b/x11/xtrlock/files/patch-xtrlock.c
@@ -0,0 +1,16 @@
+*** xtrlock.c.orig Sun Sep 1 08:46:29 2002
+--- xtrlock.c Tue May 18 17:45:48 2004
+***************
+*** 31,41 ****
+ #include <grp.h>
+ #include <limits.h>
+ #include <string.h>
+- #include <crypt.h>
+ #include <unistd.h>
+ #include <math.h>
+ #include <ctype.h>
+- #include <values.h>
+
+ #ifdef SHADOW_PWD
+ #include <shadow.h>
+--- 31,39 ----
diff --git a/x11/xtrlock/pkg-descr b/x11/xtrlock/pkg-descr
new file mode 100644
index 000000000000..8ed106bed913
--- /dev/null
+++ b/x11/xtrlock/pkg-descr
@@ -0,0 +1 @@
+A minimal xlock with minimum usage of resources.