aboutsummaryrefslogtreecommitdiff
path: root/x11/xtset
diff options
context:
space:
mode:
authorGreg Lehey <grog@FreeBSD.org>2020-08-31 05:49:41 +0000
committerGreg Lehey <grog@FreeBSD.org>2020-08-31 05:49:41 +0000
commit7d816e61851af455695085185200121a73deea7f (patch)
treed2ee56cb25794200e46af874d62c81f6a4242b45 /x11/xtset
parentb2eb1dc48c531869814ec626088744b133ef746b (diff)
downloadports-7d816e61851af455695085185200121a73deea7f.tar.gz
ports-7d816e61851af455695085185200121a73deea7f.zip
Add patches for politically correct syntax, silencing warnings.
PR: 249017 Submitted by: freebsd@dreamchaser.org Reported by: freebsd@dreamchaser.org
Notes
Notes: svn path=/head/; revision=547150
Diffstat (limited to 'x11/xtset')
-rw-r--r--x11/xtset/Makefile4
-rw-r--r--x11/xtset/distinfo1
-rw-r--r--x11/xtset/files/patch-xtset.c44
3 files changed, 47 insertions, 2 deletions
diff --git a/x11/xtset/Makefile b/x11/xtset/Makefile
index 10fe650fc4f1..50bffcd88652 100644
--- a/x11/xtset/Makefile
+++ b/x11/xtset/Makefile
@@ -4,12 +4,12 @@
PORTNAME= xtset
PORTVERSION= 1.1
CATEGORIES= x11
-MASTER_SITES= ftp://ftp.lemis.com/pub/
+MASTER_SITES= http://www.lemis.com/pub/
MAINTAINER= grog@FreeBSD.org
COMMENT= Utility to set title on an xterm
-LICENSE= NONE
+# LICENSE= NONE
NO_WRKSUBDIR= yes
diff --git a/x11/xtset/distinfo b/x11/xtset/distinfo
index 28d9e806b2cf..c8af20740126 100644
--- a/x11/xtset/distinfo
+++ b/x11/xtset/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1598851253
SHA256 (xtset-1.1.tar.gz) = e507a3e31a693419fd0a760b392f6370299cdaba37c419b09f165771ae73ba5d
SIZE (xtset-1.1.tar.gz) = 4310
diff --git a/x11/xtset/files/patch-xtset.c b/x11/xtset/files/patch-xtset.c
new file mode 100644
index 000000000000..ff201f500b12
--- /dev/null
+++ b/x11/xtset/files/patch-xtset.c
@@ -0,0 +1,44 @@
+--- xtset.c.orig 2002-03-29 22:15:00.000000000 +1100
++++ xtset.c 2020-08-31 15:29:45.583899000 +1000
+@@ -49,6 +49,7 @@
+ #include <pwd.h>
+ #include <grp.h>
+ #include <sys/param.h>
++#include <sys/stat.h>
+
+ /* SVR3 header files frequently don't define MAXPATHLEN. They probably can't
+ * stomach a 1K path name, either, but this constant can err on the generous
+@@ -135,21 +136,21 @@
+
+ /* then the effective username */
+
+- if (pwent = getpwuid (geteuid ()))
++ if ((pwent = getpwuid (geteuid ())) != 0)
+ eff_userid = strdup (pwent->pw_name);
+ else
+ eff_userid = "*no euid*";
+
+ /* then the real groupname */
+
+- if (grent = getgrgid (getgid ()))
++ if ((grent = getgrgid (getgid ())) != 0)
+ real_groupid = strdup (grent->gr_name);
+ else
+ real_groupid = "*no gid*"; /* yes, this can be valid */
+
+ /* then the effective groupname */
+
+- if (grent = getgrgid (getegid ()))
++ if ((grent = getgrgid (getegid ())) != 0)
+ eff_groupid = strdup (grent->gr_name);
+ else
+ eff_groupid = "*no egid*"; /* yes, this can be valid */
+@@ -163,7 +164,7 @@
+ {
+ char *point;
+ strcpy (short_host, our_host);
+- if (point = strchr (short_host, '.')) /* got a point, */
++ if ((point = strchr (short_host, '.')) != 0) /* got a point, */
+ *point = '\0'; /* chop it off there */
+ }
+ if ( !getcwd (our_dir, MAXPATHLEN)) /* or can't get wd */