aboutsummaryrefslogtreecommitdiff
path: root/x11/yelp
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
commitae52bc80895a23ddbe33b86e75a9cf331ae32ba9 (patch)
tree5538a7d3541f6d56e4bbab9c6329f5b9db64dafb /x11/yelp
parent7934df773e0cc2a9924de75dd7cad9cc3d79d4ee (diff)
downloadports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.tar.gz
ports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.zip
Presenting GNOME 2.26 for FreeBSD. See
http://library.gnome.org/misc/release-notes/2.26/ for a list of what's new. On the FreeBSD front, we introduced a port of libxul 1.9 as an alternative for Firefox 2.0 as a Gecko provider. Almost all of the Gecko consumers can make use of this provider by setting: WITH_GECKO=libxul The GNOME 2.26 port was done by ahze, kwm, marcus, and mezz with contributions by Joseph S. Atkinson, Peter Wemm, Eric L. Chen, Martin Matuska, Craig Butler, and Pawel Worach.
Notes
Notes: svn path=/head/; revision=231972
Diffstat (limited to 'x11/yelp')
-rw-r--r--x11/yelp/Makefile9
-rw-r--r--x11/yelp/distinfo6
-rw-r--r--x11/yelp/files/patch-data_man.xml.in12
-rw-r--r--x11/yelp/files/patch-src_yelp-gecko-utils.cpp13
-rw-r--r--x11/yelp/pkg-plist16
5 files changed, 37 insertions, 19 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index 504dc0087f3d..caf527020b72 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -3,11 +3,11 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/yelp/Makefile,v 1.129 2008/09/23 04:41:44 mezz Exp $
+# $MCom: ports/x11/yelp/Makefile,v 1.133 2009/03/30 03:32:43 marcus Exp $
#
PORTNAME= yelp
-PORTVERSION= 2.24.0
+PORTVERSION= 2.26.0
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -18,7 +18,7 @@ COMMENT= A help browser for the GNOME 2 desktop
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
rarian.0:${PORTSDIR}/textproc/rarian
-USE_GECKO= firefox xulrunner
+USE_GECKO= firefox libxul
USE_GETTEXT= yes
USE_BZIP2= yes
USE_XORG= ice
@@ -28,7 +28,8 @@ GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-gecko=${GECKO}
+CONFIGURE_ARGS= --with-gecko=${GECKO} \
+ --with-gecko-home=${LOCALBASE}/lib/${GECKO}
MAKE_ENV= G_CHARSET_ALIAS="${LOCALBASE}/libdata/charset.alias"
GCONF_SCHEMAS= yelp.schemas
diff --git a/x11/yelp/distinfo b/x11/yelp/distinfo
index 95bed6317d13..adc47cac83fc 100644
--- a/x11/yelp/distinfo
+++ b/x11/yelp/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/yelp-2.24.0.tar.bz2) = 15eb2f538d970600c1e0a461f7d88b55
-SHA256 (gnome2/yelp-2.24.0.tar.bz2) = 7566177d23c3cac7725981f2d04de22923499318a067044158cff17f43957a0a
-SIZE (gnome2/yelp-2.24.0.tar.bz2) = 1023876
+MD5 (gnome2/yelp-2.26.0.tar.bz2) = 3413fd051c5ecbfe98819a8fb4ac83dd
+SHA256 (gnome2/yelp-2.26.0.tar.bz2) = 0c5a91a206b26ef714e9929404f1711caadcee481299566011b4ae4232d151d0
+SIZE (gnome2/yelp-2.26.0.tar.bz2) = 1021362
diff --git a/x11/yelp/files/patch-data_man.xml.in b/x11/yelp/files/patch-data_man.xml.in
deleted file mode 100644
index 06670069c9e2..000000000000
--- a/x11/yelp/files/patch-data_man.xml.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- data/man.xml.in.orig Tue Dec 6 17:03:27 2005
-+++ data/man.xml.in Tue Dec 6 17:05:52 2005
-@@ -39,6 +39,9 @@
- <toc id="Man-man9" sect="9">
- <_title>Kernel Routines</_title>
- </toc>
-+ <toc id="Man-mann" sect="n">
-+ <_title>Tcl/Tk Functions</_title>
-+ </toc>
- </toc>
-
- <toc id="Man-man4" sect="4">
diff --git a/x11/yelp/files/patch-src_yelp-gecko-utils.cpp b/x11/yelp/files/patch-src_yelp-gecko-utils.cpp
new file mode 100644
index 000000000000..2c4d781ee470
--- /dev/null
+++ b/x11/yelp/files/patch-src_yelp-gecko-utils.cpp
@@ -0,0 +1,13 @@
+--- src/yelp-gecko-utils.cpp.orig 2009-03-29 23:21:59.000000000 -0400
++++ src/yelp-gecko-utils.cpp 2009-03-29 23:25:48.000000000 -0400
+@@ -28,8 +28,10 @@
+ #include <nsStringAPI.h>
+
+ #ifdef HAVE_GECKO_1_9
++#ifdef XPCOM_GLUE
+ #include <gtkmozembed_glue.cpp>
+ #endif
++#endif
+
+ #include <gtkmozembed.h>
+ #include <gtkmozembed_internal.h>
diff --git a/x11/yelp/pkg-plist b/x11/yelp/pkg-plist
index f3a82cdf8807..23e7fa35e807 100644
--- a/x11/yelp/pkg-plist
+++ b/x11/yelp/pkg-plist
@@ -6,6 +6,7 @@ share/locale/af/LC_MESSAGES/yelp.mo
share/locale/am/LC_MESSAGES/yelp.mo
share/locale/ar/LC_MESSAGES/yelp.mo
share/locale/as/LC_MESSAGES/yelp.mo
+share/locale/ast/LC_MESSAGES/yelp.mo
share/locale/az/LC_MESSAGES/yelp.mo
share/locale/be/LC_MESSAGES/yelp.mo
share/locale/be@latin/LC_MESSAGES/yelp.mo
@@ -48,9 +49,11 @@ share/locale/ko/LC_MESSAGES/yelp.mo
share/locale/ks/LC_MESSAGES/yelp.mo
share/locale/ku/LC_MESSAGES/yelp.mo
share/locale/ky/LC_MESSAGES/yelp.mo
+share/locale/la/LC_MESSAGES/yelp.mo
share/locale/li/LC_MESSAGES/yelp.mo
share/locale/lt/LC_MESSAGES/yelp.mo
share/locale/lv/LC_MESSAGES/yelp.mo
+share/locale/mai/LC_MESSAGES/yelp.mo
share/locale/mg/LC_MESSAGES/yelp.mo
share/locale/mk/LC_MESSAGES/yelp.mo
share/locale/ml/LC_MESSAGES/yelp.mo
@@ -67,6 +70,7 @@ share/locale/oc/LC_MESSAGES/yelp.mo
share/locale/or/LC_MESSAGES/yelp.mo
share/locale/pa/LC_MESSAGES/yelp.mo
share/locale/pl/LC_MESSAGES/yelp.mo
+share/locale/ps/LC_MESSAGES/yelp.mo
share/locale/pt/LC_MESSAGES/yelp.mo
share/locale/pt_BR/LC_MESSAGES/yelp.mo
share/locale/ro/LC_MESSAGES/yelp.mo
@@ -86,6 +90,8 @@ share/locale/th/LC_MESSAGES/yelp.mo
share/locale/tr/LC_MESSAGES/yelp.mo
share/locale/ug/LC_MESSAGES/yelp.mo
share/locale/uk/LC_MESSAGES/yelp.mo
+share/locale/uz/LC_MESSAGES/yelp.mo
+share/locale/uz@cyrillic/LC_MESSAGES/yelp.mo
share/locale/vi/LC_MESSAGES/yelp.mo
share/locale/wa/LC_MESSAGES/yelp.mo
share/locale/xh/LC_MESSAGES/yelp.mo
@@ -131,6 +137,8 @@ share/locale/zu/LC_MESSAGES/yelp.mo
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
+@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
+@dirrmtry share/locale/uz@cyrillic
@dirrmtry share/locale/ug/LC_MESSAGES
@dirrmtry share/locale/ug
@dirrmtry share/locale/te/LC_MESSAGES
@@ -141,6 +149,8 @@ share/locale/zu/LC_MESSAGES/yelp.mo
@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
@dirrmtry share/locale/nso/LC_MESSAGES
@@ -151,6 +161,10 @@ share/locale/zu/LC_MESSAGES/yelp.mo
@dirrmtry share/locale/mr
@dirrmtry share/locale/mg/LC_MESSAGES
@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/la/LC_MESSAGES
+@dirrmtry share/locale/la
@dirrmtry share/locale/ky/LC_MESSAGES
@dirrmtry share/locale/ky
@dirrmtry share/locale/ku/LC_MESSAGES
@@ -165,5 +179,7 @@ share/locale/zu/LC_MESSAGES/yelp.mo
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as