aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-03-04 05:42:15 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-03-04 05:42:15 +0000
commit0b12ad65dc58b142cbd1dd03c06ef2b42b78597b (patch)
treebf49c7951f2afc03661970d381aa6f4715f95b9e /x11
parent9d9c8fe2e802b9809b74c9468afd0f15679f7eb2 (diff)
downloadports-0b12ad65dc58b142cbd1dd03c06ef2b42b78597b.tar.gz
ports-0b12ad65dc58b142cbd1dd03c06ef2b42b78597b.zip
Ulauncher is graphical application launcher written in Python and GTK.
It offers fuzzy search, custom color themes, shortcuts and extensions, and fast directory browser. WWW: https://ulauncher.io/
Notes
Notes: svn path=/head/; revision=567290
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/ulauncher/Makefile39
-rw-r--r--x11/ulauncher/distinfo3
-rw-r--r--x11/ulauncher/files/patch-ulauncher_utils_display.py9
-rw-r--r--x11/ulauncher/pkg-descr5
5 files changed, 57 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index fbf5c4da7d60..b752ac551823 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -343,6 +343,7 @@
SUBDIR += tint
SUBDIR += trayer
SUBDIR += tycoon
+ SUBDIR += ulauncher
SUBDIR += urxvt-font-size
SUBDIR += urxvt-perls
SUBDIR += vdesk
diff --git a/x11/ulauncher/Makefile b/x11/ulauncher/Makefile
new file mode 100644
index 000000000000..788cc25a1087
--- /dev/null
+++ b/x11/ulauncher/Makefile
@@ -0,0 +1,39 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ulauncher
+PORTVERSION= 5.10.0
+CATEGORIES= x11
+MASTER_SITES= https://github.com/Ulauncher/Ulauncher/releases/download/${PORTVERSION}/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Advanced graphical application launcher
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-distutils-extra>=2.10:devel/py-python-distutils-extra@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyinotify>=0:devel/py-pyinotify@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-Levenshtein>=0:devel/py-python-Levenshtein@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}websocket-client>=0:www/py-websocket-client@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>=0:devel/py-xdg@${PY_FLAVOR} \
+ ${LOCALBASE}/share/gir-1.0/AppIndicator3-0.1.gir:devel/libappindicator \
+ ${LOCALBASE}/share/gir-1.0/Keybinder-3.0.gir:x11/keybinder-gtk3 \
+ ${LOCALBASE}/share/gir-1.0/Notify-0.7.gir:devel/libnotify \
+ ${LOCALBASE}/share/gir-1.0/WebKit2-4.0.gir:www/webkit2-gtk3 \
+ wmctrl:x11/wmctrl
+
+USES= gettext-tools gnome python:3.6+
+USE_GNOME= gtk30 intltool pygobject3
+USE_PYTHON= autoplist distutils noflavors
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^#!/s,usr/,,' ${WRKSRC}/bin/ulauncher-toggle
+ @${RM} ${WRKSRC}/bin/ulauncher-toggle.bak
+
+.include <bsd.port.mk>
+
+PYDISTUTILS_INSTALLARGS:= ${PYDISTUTILS_INSTALLARGS:N--single-version-externally-managed}
diff --git a/x11/ulauncher/distinfo b/x11/ulauncher/distinfo
new file mode 100644
index 000000000000..cb63d292b4c3
--- /dev/null
+++ b/x11/ulauncher/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1612712674
+SHA256 (ulauncher_5.10.0.tar.gz) = f4211fa8e53b013f93caf871f9e8aa528ea0def9c567a3f7b2139365c4c1342a
+SIZE (ulauncher_5.10.0.tar.gz) = 1880477
diff --git a/x11/ulauncher/files/patch-ulauncher_utils_display.py b/x11/ulauncher/files/patch-ulauncher_utils_display.py
new file mode 100644
index 000000000000..36e21f1c1333
--- /dev/null
+++ b/x11/ulauncher/files/patch-ulauncher_utils_display.py
@@ -0,0 +1,9 @@
+--- ulauncher/utils/display.py.orig 2021-02-07 15:10:13 UTC
++++ ulauncher/utils/display.py
+@@ -1,4 +1,5 @@
+-import logging
++import gi, logging
++gi.require_version('Gdk', '3.0')
+ from gi.repository import Gdk, GdkX11
+
+ logger = logging.getLogger(__name__)
diff --git a/x11/ulauncher/pkg-descr b/x11/ulauncher/pkg-descr
new file mode 100644
index 000000000000..e2bd876478c2
--- /dev/null
+++ b/x11/ulauncher/pkg-descr
@@ -0,0 +1,5 @@
+Ulauncher is graphical application launcher written in Python and GTK.
+It offers fuzzy search, custom color themes, shortcuts and extensions,
+and fast directory browser.
+
+WWW: https://ulauncher.io/