aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-06 07:24:25 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 04:20:01 +0000
commit1699e4b153cd862122d547ced63795f97e178853 (patch)
tree2480cbb9ca2f233f7ecef179893cae8f404a6f69 /x11
parent7b1d905b03cc85d834d5cba7df8ab22f9f51e0ca (diff)
downloadports-1699e4b153cd862122d547ced63795f97e178853.tar.gz
ports-1699e4b153cd862122d547ced63795f97e178853.zip
x11/cinnamon: Attempt to fix build order bug (D29353)
Uncovered while building with devel/samurai but can probably also happen with ninja eventually. In file included from ../src/main.c:25: In file included from ../src/cinnamon-global-private.h:28: In file included from src/st/st.h:7: ../src/st/st-box-layout-child.h:24:10: fatal error: 'st-enum-types.h' file not found #include "st-enum-types.h" ^~~~~~~~~~~~~~~~~ 1 error generated. samu: subcommands failed http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-04-05_21h03m50s/logs/errors/cinnamon-4.8.6.log PR: 254678
Diffstat (limited to 'x11')
-rw-r--r--x11/cinnamon/files/patch-src_st_meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/x11/cinnamon/files/patch-src_st_meson.build b/x11/cinnamon/files/patch-src_st_meson.build
new file mode 100644
index 000000000000..bae6fb1c5d63
--- /dev/null
+++ b/x11/cinnamon/files/patch-src_st_meson.build
@@ -0,0 +1,19 @@
+Attempt to fix parallel build
+
+In file included from ../src/main.c:25:
+In file included from ../src/cinnamon-global-private.h:28:
+In file included from src/st/st.h:7:
+../src/st/st-box-layout-child.h:24:10: fatal error: 'st-enum-types.h' file not found
+#include "st-enum-types.h"
+ ^~~~~~~~~~~~~~~~~
+
+--- src/st/meson.build.orig 2021-04-06 04:24:56 UTC
++++ src/st/meson.build
+@@ -189,6 +189,7 @@ libst = library(
+ st_dep = declare_dependency(
+ include_directories: include_directories('.', 'croco'),
+ dependencies: libst_deps,
++ sources: st_enum_types[1],
+ link_with: libst,
+ link_args: ['-Wl,-Bsymbolic', '-Wl,-z,relro', '-Wl,-z,now'],
+ )