aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-11-19 00:36:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-11-19 00:36:13 +0000
commit3d67ecfaf2a6b6e0ee442443af69275f913aa637 (patch)
treee076c242f281d6c7536c4c1c0dbca5a36c860ab2 /x11
parent4ef455dd323329c33f5048de07cd4fb5d8ec7d3f (diff)
downloadports-3d67ecfaf2a6b6e0ee442443af69275f913aa637.tar.gz
ports-3d67ecfaf2a6b6e0ee442443af69275f913aa637.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/remontoire/Makefile26
-rw-r--r--x11/remontoire/distinfo3
-rw-r--r--x11/remontoire/pkg-descr11
4 files changed, 41 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 6f5d215a8220..ff9ef0d45cd2 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -279,6 +279,7 @@
SUBDIR += qt5-x11extras
SUBDIR += qterminal
SUBDIR += radare-cutter
+ SUBDIR += remontoire
SUBDIR += rendercheck
SUBDIR += rgb
SUBDIR += rofi
diff --git a/x11/remontoire/Makefile b/x11/remontoire/Makefile
new file mode 100644
index 000000000000..01b577c8ced7
--- /dev/null
+++ b/x11/remontoire/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= remontoire
+DISTVERSION= 1.4.0
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Keybinding viewer for i3 and other programs
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= valac:lang/vala
+LIB_DEPENDS= libgee-0.8.so:devel/libgee \
+ libjson-glib-1.0.so:devel/json-glib
+
+USES= gettext-tools gnome meson pkgconfig python:build shebangfix
+USE_GITHUB= yes
+USE_GNOME= gtk30
+GH_ACCOUNT= regolith-linux
+SHEBANG_FILES= build-aux/meson/postinstall.py
+PLIST_FILES= bin/${PORTNAME} \
+ share/appdata/org.regolith-linux.remontoire.appdata.xml \
+ share/applications/org.regolith-linux.remontoire.desktop
+GLIB_SCHEMAS= org.regolith-linux.remontoire.gschema.xml
+
+.include <bsd.port.mk>
diff --git a/x11/remontoire/distinfo b/x11/remontoire/distinfo
new file mode 100644
index 000000000000..0d2db9199787
--- /dev/null
+++ b/x11/remontoire/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1602948600
+SHA256 (regolith-linux-remontoire-1.4.0_GH0.tar.gz) = 35777a10a753b15debe64867deca2332733f6bee6b85936e75e0e0514aa900da
+SIZE (regolith-linux-remontoire-1.4.0_GH0.tar.gz) = 25130
diff --git a/x11/remontoire/pkg-descr b/x11/remontoire/pkg-descr
new file mode 100644
index 000000000000..3355f2f31558
--- /dev/null
+++ b/x11/remontoire/pkg-descr
@@ -0,0 +1,11 @@
+Remontoire is a small (~71Kb) GTK app for presenting keybinding hints
+in a compact form suitable for tiling window environments. It is
+intended for use with the i3 window manager but it's also able to
+display keybindings from any suitably formatted config file.
+
+The program functions by scanning and parsing comments in a specific
+format (described directly below), then displaying them in a one-layer
+categorized list view. The program stores the state of which sections
+are expanded, allowing for use on screens with limited resolution.
+
+WWW: https://github.com/regolith-linux/remontoire