aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-04-22 23:06:28 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-04-22 23:10:44 +0000
commit5e009d27fd0991164dcffc0d764556e58b550869 (patch)
tree1e327e0ac8089769967dbf5d80aa79d4d67bf2ad /x11
parent4fc31fe4f66c82f1608396e76f8ecaeb5284cfb3 (diff)
downloadports-5e009d27fd0991164dcffc0d764556e58b550869.tar.gz
ports-5e009d27fd0991164dcffc0d764556e58b550869.zip
Diffstat (limited to 'x11')
-rw-r--r--x11/foot/Makefile3
-rw-r--r--x11/foot/distinfo2
-rw-r--r--x11/foot/files/patch-pgo30
3 files changed, 5 insertions, 30 deletions
diff --git a/x11/foot/Makefile b/x11/foot/Makefile
index a65befb1390e..c317792eec99 100644
--- a/x11/foot/Makefile
+++ b/x11/foot/Makefile
@@ -3,6 +3,9 @@ DISTVERSION= 1.12.0
CATEGORIES= x11
MASTER_SITES= https://codeberg.org/dnkl/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
+PATCH_SITES= https://codeberg.org/dnkl/${PORTNAME}/commit/
+PATCHFILES+= 8ceb6e45a49e.patch:-p1 # unbreak PGO
+
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Fast, lightweight and minimalistic Wayland terminal emulator
diff --git a/x11/foot/distinfo b/x11/foot/distinfo
index d88b0d386c86..a4d9a122e311 100644
--- a/x11/foot/distinfo
+++ b/x11/foot/distinfo
@@ -1,3 +1,5 @@
TIMESTAMP = 1650640481
SHA256 (foot-1.12.0.tar.gz) = d8c27f735d2f361ee627cce282bee2462545f4df9532ee6ac28fd86a193404fa
SIZE (foot-1.12.0.tar.gz) = 482717
+SHA256 (8ceb6e45a49e.patch) = 822c0ea023751a5bf2a14f81e51c8e4529f54702d11b83651c22ccf4b8970249
+SIZE (8ceb6e45a49e.patch) = 1047
diff --git a/x11/foot/files/patch-pgo b/x11/foot/files/patch-pgo
deleted file mode 100644
index 5db3774cb486..000000000000
--- a/x11/foot/files/patch-pgo
+++ /dev/null
@@ -1,30 +0,0 @@
-FAILED: pgo
-ld: error: undefined symbol: key_binding_unref_term
->>> referenced by ld-temp.o
->>> lto.tmp:(term_destroy)
-
-ld: error: undefined symbol: key_binding_new_for_term
->>> referenced by ld-temp.o
->>> lto.tmp:(term_init)
-cc: error: linker command failed with exit code 1 (use -v to see invocation)
-
---- pgo/pgo.c.orig 2022-04-22 15:14:41 UTC
-+++ pgo/pgo.c
-@@ -193,6 +193,17 @@ key_binding_for(
- return &kbd;
- }
-
-+void
-+key_binding_new_for_term(struct key_binding_manager *mgr,
-+ const struct terminal *term)
-+{
-+}
-+void
-+key_binding_unref_term(struct key_binding_manager *mgr,
-+ const struct terminal *term)
-+{
-+}
-+
- int
- main(int argc, const char *const *argv)
- {