aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-02-25 11:30:22 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-02-25 11:30:22 +0000
commit60107aa3252697d373648c906201a1890fef1ee4 (patch)
tree290db7b656e80259b654df2012cf647f0dd04fb5 /x11
parent5343f263a09a571519e765f3739e88a21776a64c (diff)
downloadports-60107aa3252697d373648c906201a1890fef1ee4.tar.gz
ports-60107aa3252697d373648c906201a1890fef1ee4.zip
x11/foot: expose terminfo support on -CURRENT
Makes foot default to TERM=foot instead of TERM=xterm-256color. Proper 24-bit color support without relying on COLORTERM=truecolor and hardcoded xterm escape sequences requires TERM=foot-direct e.g., $ foot -t foot-direct $ tput Co 16777216
Notes
Notes: svn path=/head/; revision=566529
Diffstat (limited to 'x11')
-rw-r--r--x11/foot/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/x11/foot/Makefile b/x11/foot/Makefile
index 854dd878ce1a..4e6c50de92dd 100644
--- a/x11/foot/Makefile
+++ b/x11/foot/Makefile
@@ -24,6 +24,16 @@ LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
USES= compiler:c11 meson pkgconfig xorg
USE_XORG= pixman
WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.if exists(/usr/bin/tic)
+PKGMESSAGE= ${NONEXISTENT}
+PLIST_FILES= share/site-terminfo/f/${PORTNAME} \
+ share/site-terminfo/f/${PORTNAME}-direct
+post-patch: terminfo-patch
+terminfo-patch:
+ @${REINPLACE_CMD} '/datadir/s/terminfo/site-&/' ${WRKSRC}/meson.build
+.else
MESON_ARGS= -Dterminfo=disabled
+.endif
.include <bsd.port.mk>