aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 03:48:51 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 04:20:00 +0000
commit6428be4064828417c59ea99b98fa5ef404f70e25 (patch)
tree428f033e8f4f9b88f43e1f6db38617527cbba52e /x11
parent157731dfea5228f4da2ab9188dad3351ee3eeec8 (diff)
downloadports-6428be4064828417c59ea99b98fa5ef404f70e25.tar.gz
ports-6428be4064828417c59ea99b98fa5ef404f70e25.zip
x11/brisk-menu: Attempt to fix build order bug (D29353)
Uncovered while building with devel/samurai but can probably also happen with ninja eventually. In file included from ../src/mate-applet/applet.c:19: In file included from ../src/frontend/classic/classic-window.h:14: ../src/frontend/classic/../menu-private.h:18:10: fatal error: 'libsaver-glue.h' file not found #include "libsaver-glue.h" ^~~~~~~~~~~~~~~~~ 1 error generated. samu: subcommands failed http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-04-04_07h37m38s/logs/errors/brisk-menu-0.6.2.log PR: 254678
Diffstat (limited to 'x11')
-rw-r--r--x11/brisk-menu/files/patch-src_meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/x11/brisk-menu/files/patch-src_meson.build b/x11/brisk-menu/files/patch-src_meson.build
new file mode 100644
index 000000000000..5b311b77f43b
--- /dev/null
+++ b/x11/brisk-menu/files/patch-src_meson.build
@@ -0,0 +1,20 @@
+Attempt to unbreak parallel build
+
+--- src/meson.build.orig 2021-04-05 04:30:02 UTC
++++ src/meson.build
+@@ -13,6 +13,7 @@ libresources = static_library(
+
+ link_libresources = declare_dependency(
+ link_with: libresources,
++ sources: brisk_resources,
+ include_directories: [
+ data_include,
+ ],
+@@ -38,6 +39,7 @@ libsession_stub = static_library(
+ # Allow linking to the stub
+ link_libsession_stub = declare_dependency(
+ link_with: libsession_stub,
++ sources: [libsaver_glue, libsession_glue],
+ dependencies: [
+ dep_gio_unix,
+ ],