aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-01-23 11:32:28 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-01-23 11:32:28 +0000
commit9a81a60255cf823a5092605fe5032b0e0ab4e671 (patch)
tree5cff603a9e68bdf62b30acbd5c100a7a432ca426 /x11
parent88e112a3e4c86c62ef8b6a37e692782147bfb092 (diff)
Diffstat (limited to 'x11')
-rw-r--r--x11/gxkb/Makefile1
-rw-r--r--x11/gxkb/pkg-plist2
-rw-r--r--x11/lxpanel/Makefile1
-rw-r--r--x11/lxpanel/pkg-plist4
-rw-r--r--x11/xkbind/Makefile5
5 files changed, 8 insertions, 5 deletions
diff --git a/x11/gxkb/Makefile b/x11/gxkb/Makefile
index 7d41509d44aa..700d05b487f0 100644
--- a/x11/gxkb/Makefile
+++ b/x11/gxkb/Makefile
@@ -14,6 +14,7 @@ LIB_DEPENDS= libxklavier.so:x11/libxklavier
USES= gnome pkgconfig
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
USE_GNOME= gdkpixbuf2 glib20
PORTDOCS= AUTHORS NEWS
diff --git a/x11/gxkb/pkg-plist b/x11/gxkb/pkg-plist
index d5bd853c43e2..fd8ac420c216 100644
--- a/x11/gxkb/pkg-plist
+++ b/x11/gxkb/pkg-plist
@@ -1,5 +1,4 @@
bin/gxkb
-man/man1/gxkb.1.gz
share/applications/gxkb.desktop
%%DATADIR%%/flags/am.png
%%DATADIR%%/flags/bg.png
@@ -36,4 +35,5 @@ share/applications/gxkb.desktop
%%DATADIR%%/flags/uz.png
%%DATADIR%%/flags/zz.png
%%DATADIR%%/logo.png
+share/man/man1/gxkb.1.gz
share/pixmaps/gxkb.xpm
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index 6cbd2edc416c..f7a4e62d35f6 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -24,6 +24,7 @@ USES= gmake gnome libtool localbase pathfix pkgconfig tar:xz xorg
USE_GNOME= glib20 gtk20 cairo gdkpixbuf2 gdkpixbuf2xlib intltool
USE_XORG= x11
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-plugins="${LXPANEL_PLUGINS}"
INSTALL_TARGET= install-strip
diff --git a/x11/lxpanel/pkg-plist b/x11/lxpanel/pkg-plist
index d6f0ec7552a9..df0356613753 100644
--- a/x11/lxpanel/pkg-plist
+++ b/x11/lxpanel/pkg-plist
@@ -22,8 +22,6 @@ lib/lxpanel/plugins/volume.so
%%WEATHER%%lib/lxpanel/plugins/weather.so
lib/lxpanel/plugins/xkb.so
libdata/pkgconfig/lxpanel.pc
-man/man1/lxpanel.1.gz
-man/man1/lxpanelctl.1.gz
%%NLS%%share/locale/af/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/ar/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/be/LC_MESSAGES/lxpanel.mo
@@ -255,3 +253,5 @@ man/man1/lxpanelctl.1.gz
%%DATADIR%%/xkeyboardconfig/layouts.cfg
%%DATADIR%%/xkeyboardconfig/models.cfg
%%DATADIR%%/xkeyboardconfig/toggle.cfg
+share/man/man1/lxpanel.1.gz
+share/man/man1/lxpanelctl.1.gz
diff --git a/x11/xkbind/Makefile b/x11/xkbind/Makefile
index df13428c916b..0d41f0105a09 100644
--- a/x11/xkbind/Makefile
+++ b/x11/xkbind/Makefile
@@ -9,12 +9,13 @@ WWW= https://xkbind.sourceforge.net/
LICENSE= GPLv2
-GNU_CONFIGURE= yes
USES= xorg
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
USE_XORG= x11
PLIST_FILES= bin/${PORTNAME} lib/${PORTNAME}/app-defaults/Xkbind \
- man/man1/${PORTNAME}.1.gz
+ share/man/man1/${PORTNAME}.1.gz
PORTDOCS= AUTHORS ChangeLog README README.utf8.ru THANKS
OPTIONS_DEFINE= DOCS