aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-05-20 14:13:31 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-05-20 14:15:15 +0000
commita3e5c55aca7255352d800b56ffea1ab897227944 (patch)
treeb47dd78a6ab0119c9b11ca73dd8dff2978016064 /x11
parent8790f67654a91e1befe878678329b207587c424d (diff)
downloadports-a3e5c55aca7255352d800b56ffea1ab897227944.tar.gz
ports-a3e5c55aca7255352d800b56ffea1ab897227944.zip
x11/srandrd: Add a new port: a simple randr daemon
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/srandrd/Makefile27
-rw-r--r--x11/srandrd/distinfo3
-rw-r--r--x11/srandrd/files/patch-Makefile17
-rw-r--r--x11/srandrd/pkg-descr5
5 files changed, 53 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index d3b838cdf36c..9b550d810144 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -318,6 +318,7 @@
SUBDIR += slurp
SUBDIR += smproxy
SUBDIR += sprop
+ SUBDIR += srandrd
SUBDIR += squeekboard
SUBDIR += sselp
SUBDIR += stalonetray
diff --git a/x11/srandrd/Makefile b/x11/srandrd/Makefile
new file mode 100644
index 000000000000..486d6a63a752
--- /dev/null
+++ b/x11/srandrd/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= srandrd
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.6.0-10
+DISTVERSIONSUFFIX= -g4e4b754
+CATEGORIES= x11
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Simple randr daemon
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= a2x:textproc/asciidoc
+
+USES= localbase:ldflags xorg
+USE_GITHUB= yes
+GH_ACCOUNT= jceb
+USE_XORG= x11 xinerama xrandr
+
+MAKE_ARGS= DISTDIR=${STAGEDIR} \
+ MANPREFIX=${STAGEDIR}${MAN1PREFIX}/share/man \
+ PREFIX=${PREFIX}
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/man/man1/${PORTNAME}.1.gz
+
+.include <bsd.port.mk>
diff --git a/x11/srandrd/distinfo b/x11/srandrd/distinfo
new file mode 100644
index 000000000000..eed1f57de598
--- /dev/null
+++ b/x11/srandrd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1621518028
+SHA256 (jceb-srandrd-v0.6.0-10-g4e4b754_GH0.tar.gz) = fce094bec1076e185640e8fd4aed21e8affeab7cff37f59f4729981d87944db7
+SIZE (jceb-srandrd-v0.6.0-10-g4e4b754_GH0.tar.gz) = 7054
diff --git a/x11/srandrd/files/patch-Makefile b/x11/srandrd/files/patch-Makefile
new file mode 100644
index 000000000000..482309253d37
--- /dev/null
+++ b/x11/srandrd/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig 2021-05-20 13:42:52 UTC
++++ Makefile
+@@ -14,12 +14,12 @@ INSTALLDIR := $(DESTDIR)$(PREFIX)
+ MANPREFIX ?= $(PREFIX)/share/man
+ MANPREFIX := $(DESTDIR)$(MANPREFIX)
+
+-CFLAGS := -Wall -g -Os -pedantic -std=c99 #-Werror -Wextra
++CFLAGS := -Wall -g -Os -pedantic -std=c99 $(CFLAGS) #-Werror -Wextra
+ CPPFLAGS += -D_DEFAULT_SOURCE
+ CPPFLAGS += -DNAME=\"$(TARGET)\" -DVERSION=\"$(VERSION)\"
+ CPPFLAGS += -DCOPYRIGHT=\"$(COPYRIGHT)\" -DLICENSE=\"$(LICENSE)\"
+
+-LDFLAGS := -lX11 -lXrandr -lXinerama
++LDFLAGS := -lX11 -lXrandr -lXinerama $(LDFLAGS)
+
+ all: $(TARGET)
+
diff --git a/x11/srandrd/pkg-descr b/x11/srandrd/pkg-descr
new file mode 100644
index 000000000000..410504ebf9dd
--- /dev/null
+++ b/x11/srandrd/pkg-descr
@@ -0,0 +1,5 @@
+srandrd(1) is a tool that executes a command on xrandr output change events,
+i.e., if a monitor is plugged or unplugged. By default srandrd forks to
+background and exits if the xserver exits.
+
+WWW: https://github.com/jceb/srandrd