aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2014-12-27 00:09:02 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2014-12-27 00:09:02 +0000
commita781a6e13c48cdb077c68680f30716b878435448 (patch)
tree7061b4ba6bf92419cfcbfbdf988b02a781dbdcbb /x11
parentceac9c5f821f4de7ba12309c13065316089a513f (diff)
downloadports-a781a6e13c48cdb077c68680f30716b878435448.tar.gz
ports-a781a6e13c48cdb077c68680f30716b878435448.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/3ddesktop/Makefile5
-rw-r--r--x11/bgs/Makefile5
-rw-r--r--x11/erun/Makefile6
-rw-r--r--x11/eterm/Makefile6
-rw-r--r--x11/fbdesk/Makefile3
-rw-r--r--x11/idesk/Makefile6
-rw-r--r--x11/ipager/Makefile5
-rw-r--r--x11/metalock/Makefile4
-rw-r--r--x11/tint/Makefile6
-rw-r--r--x11/wbar/Makefile6
-rw-r--r--x11/wmappl/Makefile4
11 files changed, 30 insertions, 26 deletions
diff --git a/x11/3ddesktop/Makefile b/x11/3ddesktop/Makefile
index c39c8b12dcb9..28d4e5d601c3 100644
--- a/x11/3ddesktop/Makefile
+++ b/x11/3ddesktop/Makefile
@@ -3,16 +3,17 @@
PORTNAME= 3ddesktop
PORTVERSION= 0.2.9
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= x11
MASTER_SITES= SF/desk3d/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= 3D Virtual Desktop Switcher
+LIB_DEPENDS= libImlib2.so:${PORTSDIR}/graphics/imlib2
+
USE_XORG= xmu
USE_GL= glut
-USE_EFL= imlib2
GNU_CONFIGURE= yes
PORTDOCS= README README.windowmanagers
diff --git a/x11/bgs/Makefile b/x11/bgs/Makefile
index edbc7febab3f..c7f7012b5091 100644
--- a/x11/bgs/Makefile
+++ b/x11/bgs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bgs
PORTVERSION= 0.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11
MASTER_SITES= http://s01.de/~gottox/files/bgs/ \
http://laffaye.free.fr/distfiles/
@@ -11,8 +11,9 @@ MASTER_SITES= http://s01.de/~gottox/files/bgs/ \
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= Simple X11 BackGround Setter using Imlib2
+LIB_DEPENDS= libImlib2.so:${PORTSDIR}/graphics/imlib2
+
USE_XORG= x11 xinerama
-USE_EFL= imlib2
PLIST_FILES= bin/bgs \
man/man1/bgs.1.gz
diff --git a/x11/erun/Makefile b/x11/erun/Makefile
index f9c1a9ace104..efa89c20eae0 100644
--- a/x11/erun/Makefile
+++ b/x11/erun/Makefile
@@ -3,7 +3,7 @@
PORTNAME= E-Run
PORTVERSION= 1.2
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= kbyanc
@@ -11,14 +11,14 @@ MASTER_SITE_SUBDIR= kbyanc
MAINTAINER= gblach@FreeBSD.org
COMMENT= Simple epplet for launching arbitrary programs
-LIB_DEPENDS= libepplet.so:${PORTSDIR}/x11-wm/epplets
+LIB_DEPENDS= libepplet.so:${PORTSDIR}/x11-wm/epplets \
+ libImlib2.so:${PORTSDIR}/graphics/imlib2
PLIST_FILES= bin/E-Run.epplet
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GL= gl
-USE_EFL= imlib2
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib -lepplet -lImlib2 -lGL ${PTHREAD_LIBS}
diff --git a/x11/eterm/Makefile b/x11/eterm/Makefile
index ffd59040e852..8a9afb91a57f 100644
--- a/x11/eterm/Makefile
+++ b/x11/eterm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= eterm
PORTVERSION= 0.9.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES+= x11
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Eterm-${PORTVERSION}
DISTNAME= Eterm-${PORTVERSION}
@@ -12,7 +12,8 @@ MAINTAINER?= olgeni@FreeBSD.org
COMMENT?= X11 terminal emulator based on rxvt/xterm
BUILD_DEPENDS= man2html:${PORTSDIR}/textproc/man2html
-LIB_DEPENDS= libast.so:${PORTSDIR}/devel/libast
+LIB_DEPENDS= libast.so:${PORTSDIR}/devel/libast \
+ libImlib2.so:${PORTSDIR}/graphics/imlib2
GNU_CONFIGURE= yes
CONFIGURE_ARGS?=--enable-trans --enable-utmp \
@@ -25,7 +26,6 @@ USES= iconv libtool shebangfix
SHEBANG_FILES= ${WRKSRC}/utils/kEsetroot.in
perl_OLD_CMD= @PERL@
USE_CSTD= gnu89
-USE_EFL= imlib2
USE_LDCONFIG= yes
USE_XORG= x11 xt
diff --git a/x11/fbdesk/Makefile b/x11/fbdesk/Makefile
index f4da137c9ae2..1ff4a237ef81 100644
--- a/x11/fbdesk/Makefile
+++ b/x11/fbdesk/Makefile
@@ -20,7 +20,6 @@ OPTIONS_DEFAULT= IMLIB2
USE_XORG= xext xft xpm xrender
USES= pkgconfig
-WANT_EFL= yes
GNU_CONFIGURE= yes
PORTDOCS= ChangeLog INSTALL README
@@ -29,7 +28,7 @@ PLIST_FILES= bin/fbdesk
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIMLIB2}
-USE_EFL+= imlib2
+LIB_DEPENDS+= libImlib2.so:${PORTSDIR}/graphics/imlib2
.else
CONFIGURE_ARGS+= --disable-imlib2
.endif
diff --git a/x11/idesk/Makefile b/x11/idesk/Makefile
index 069cd9d02f97..561fb269f8e4 100644
--- a/x11/idesk/Makefile
+++ b/x11/idesk/Makefile
@@ -3,16 +3,16 @@
PORTNAME= idesk
PORTVERSION= 0.7.5
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
COMMENT= Place launch icons and background directly on your desktop
-LIB_DEPENDS= libXft.so:${PORTSDIR}/x11-fonts/libXft
+LIB_DEPENDS= libXft.so:${PORTSDIR}/x11-fonts/libXft \
+ libImlib2.so:${PORTSDIR}/graphics/imlib2
-USE_EFL= imlib2
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
USES= gmake pkgconfig tar:bzip2
diff --git a/x11/ipager/Makefile b/x11/ipager/Makefile
index 0cd05ee28562..ad62b8a2d0a0 100644
--- a/x11/ipager/Makefile
+++ b/x11/ipager/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ipager
PORTVERSION= 1.1.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= x11
MASTER_SITES= http://useperl.ru/ipager/src/
@@ -12,8 +12,9 @@ COMMENT= X11 pager program
LICENSE= MIT
+LIB_DEPENDS= libImlib2.so:${PORTSDIR}/graphics/imlib2
+
USES= scons
-USE_EFL= imlib2
SUB_FILES= pkg-message
diff --git a/x11/metalock/Makefile b/x11/metalock/Makefile
index 9458f981b327..d165372736a1 100644
--- a/x11/metalock/Makefile
+++ b/x11/metalock/Makefile
@@ -3,7 +3,7 @@
PORTNAME= metalock
PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= BERLIOS GOOGLE_CODE
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -36,7 +36,7 @@ MAKE_ARGS+= USE_ULTRAGETOPT=no
.endif
.if ${PORT_OPTIONS:MIMLIB2}
-USE_EFL= imlib2
+LIB_DEPENDS+= libImlib2.so:${PORTSDIR}/graphics/imlib2
MAKE_ARGS+= USE_IMLIB2=yes
.else
MAKE_ARGS+= USE_IMLIB2=no
diff --git a/x11/tint/Makefile b/x11/tint/Makefile
index e1b6dac44f8d..991b98ed9d72 100644
--- a/x11/tint/Makefile
+++ b/x11/tint/Makefile
@@ -2,20 +2,20 @@
PORTNAME= tint2
PORTVERSION= 0.11
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= yamagi@yamagi.org
COMMENT= Lightweight freedesktop-compliant panel/taskbar/systray/clock
-LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
+ libImlib2.so:${PORTSDIR}/graphics/imlib2
PROJECTHOST= tint2
USES= cmake pkgconfig tar:bzip2
USE_GNOME= pango glib20
USE_XORG= xinerama xrandr xdamage xcomposite
-USE_EFL= imlib2
CMAKE_ARGS= -DENABLE_BATTERY:BOOL=ON -DMANDIR:PATH=man
diff --git a/x11/wbar/Makefile b/x11/wbar/Makefile
index b248480eeaa9..f4fc222d83fd 100644
--- a/x11/wbar/Makefile
+++ b/x11/wbar/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wbar
PORTVERSION= 2.3.4
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -12,12 +12,14 @@ COMMENT= quick launch bar for fluxbox, WindowMaker, Xfce, etc
LICENSE= GPLv3
+LIB_DEPENDS= libImlib2.so:${PORTSDIR}/graphics/imlib2
+
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
USES= pkgconfig gettext gmake tar:tgz
-USE_EFL= imlib2
GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= NLS WBARCONFIG
OPTIONS_DEFAULT= NLS WBARCONFIG
diff --git a/x11/wmappl/Makefile b/x11/wmappl/Makefile
index 57f4d6377043..8987768889c5 100644
--- a/x11/wmappl/Makefile
+++ b/x11/wmappl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wmappl
PORTVERSION= 0.71
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 windowmaker
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -17,7 +17,7 @@ GNU_CONFIGURE= yes
OPTIONS_DEFINE= DOCS IMLIB2
-IMLIB2_USE= EFL=imlib2
+IMLIB2_LIB_DEPENDS= libImlib2.so:${PORTSDIR}/graphics/imlib2
IMLIB2_CONFIGURE_ENABLE=Imlib2
post-extract: