aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-04-29 04:52:18 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-04-30 08:03:20 +0000
commitca3f925d6eb53ff27e2a49775f6d33f52a587ae4 (patch)
tree8330d02f36a17f334c0d38f6741d0d042f6d6f38 /x11
parentdc8bd44c128467d5b76d40478fa87da62d56d35d (diff)
downloadports-ca3f925d6eb53ff27e2a49775f6d33f52a587ae4.tar.gz
ports-ca3f925d6eb53ff27e2a49775f6d33f52a587ae4.zip
framework: convert bsd.gstreamer.mk to Uses/gstreamer.mk
- convert bsd.gstreamer.mk to Uses/gstreamer.mk - convert ports tree to make use of USES=gstreamer - remove duplicate dependency lines from the tree Differential Revision: https://reviews.freebsd.org/D35097
Diffstat (limited to 'x11')
-rw-r--r--x11/cinnamon/Makefile3
-rw-r--r--x11/florence/Makefile3
-rw-r--r--x11/gnome-shell/Makefile3
-rw-r--r--x11/lumina-core/Makefile3
-rw-r--r--x11/workrave/Makefile3
-rw-r--r--x11/xpra/Makefile6
6 files changed, 10 insertions, 11 deletions
diff --git a/x11/cinnamon/Makefile b/x11/cinnamon/Makefile
index 9a1b1480839f..7c9e6c1332cd 100644
--- a/x11/cinnamon/Makefile
+++ b/x11/cinnamon/Makefile
@@ -45,12 +45,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
metacity:x11-wm/metacity \
tint2:x11/tint
-USES= compiler:c11 cpe gettext gl gnome meson pkgconfig python:3.5+ shebangfix xorg
+USES= compiler:c11 cpe gettext gl gnome gstreamer meson pkgconfig python:3.5+ shebangfix xorg
CPE_VENDOR= linuxmint
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 intltool introspection libxml2 pygobject3
USE_XORG= x11 xfixes
USE_GL= gl
-USE_GSTREAMER1= yes
USE_GITHUB= yes
GH_ACCOUNT= linuxmint
diff --git a/x11/florence/Makefile b/x11/florence/Makefile
index 3316ae63b528..d1e728b62989 100644
--- a/x11/florence/Makefile
+++ b/x11/florence/Makefile
@@ -14,10 +14,9 @@ LICENSE_COMB= multi
LIB_DEPENDS= libnotify.so:devel/libnotify
-USES= gmake gnome iconv libtool pathfix pkgconfig tar:bzip2 xorg
+USES= gmake gnome gstreamer iconv libtool pathfix pkgconfig tar:bzip2 xorg
USE_XORG= xtst xext
USE_GNOME= gtk30 cairo intlhack librsvg2
-USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --without-docs
USE_LDCONFIG= yes
diff --git a/x11/gnome-shell/Makefile b/x11/gnome-shell/Makefile
index 502df3d5dd69..62cbbd36ebc4 100644
--- a/x11/gnome-shell/Makefile
+++ b/x11/gnome-shell/Makefile
@@ -42,14 +42,13 @@ RUN_DEPENDS= gdm:x11/gdm \
PORTSCOUT= limitw:1,even
-USES= compiler:c11 cpe gettext gl gnome libtool localbase meson \
+USES= compiler:c11 cpe gettext gl gnome gstreamer libtool localbase meson \
pathfix perl5 pkgconfig python:3.4+ shebangfix tar:xz \
webplugin:native xorg
USE_GNOME= cairo evolutiondataserver3 gdkpixbuf2 gnomedesktop3 gtk40 \
introspection libxml2 libxslt:build
USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr xtst
USE_GL= egl gbm
-USE_GSTREAMER1= yes
USE_PERL5= build
USE_LDCONFIG= yes
SHEBANG_FILES= src/gnome-shell-extension-tool.in src/gnome-shell-perf-tool.in
diff --git a/x11/lumina-core/Makefile b/x11/lumina-core/Makefile
index a9f77d06a1e8..1ae8654b3d57 100644
--- a/x11/lumina-core/Makefile
+++ b/x11/lumina-core/Makefile
@@ -44,7 +44,8 @@ TRUEOS_DESC= Use the TrueOS system interface settings.
TRUEOS_QMAKE_ON= DEFAULT_SETTINGS=TrueOS
-MULTIMEDIA_RUN_DEPENDS= gstreamer1-plugins-core>=0:multimedia/gstreamer1-plugins-core
+MULTIMEDIA_USES= gstreamer
+MULTIMEDIA_USE= GSTREAMER=core
NLS_USE= QT=linguist_build
NLS_QMAKE_ON= CONFIG+=WITH_I18N
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 8e48f9d71732..b3550d7e6be0 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -43,7 +43,8 @@ DBUS_CONFIGURE_ENABLE= dbus
DISTRIBUTION_CONFIGURE_ENABLE= distribution
-GSTREAMER_USE= GSTREAMER1=good
+GSTREAMER_USES= gstreamer
+GSTREAMER_USE= GSTREAMER=good
GSTREAMER_CONFIGURE_ENABLE= gstreamer
.include <bsd.port.mk>
diff --git a/x11/xpra/Makefile b/x11/xpra/Makefile
index 8892c9192d19..af93a539cd80 100644
--- a/x11/xpra/Makefile
+++ b/x11/xpra/Makefile
@@ -71,10 +71,10 @@ CUPS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycups>1:print/py-pycups@${PY_FLAVOR}
CUPS_VARS= XPRA_OPTIONS+=printing
FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
FFMPEG_VARS= XPRA_OPTIONS+=enc_ffmpeg
+GSTREAMER_USES= gstreamer
GSTREAMER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gstreamer1>1:multimedia/py-gstreamer1@${PY_FLAVOR}
-GSTREAMER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gstreamer1>1:multimedia/py-gstreamer1@${PY_FLAVOR} \
- gstreamer1-plugins-pulse>1:audio/gstreamer1-plugins-pulse
-GSTREAMER_USE= GSTREAMER1=flac,lame,mpg123,ogg,opus,vorbis,wavpack
+GSTREAMER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gstreamer1>1:multimedia/py-gstreamer1@${PY_FLAVOR}
+GSTREAMER_USE= GSTREAMER=flac,lame,mpg123,ogg,opus,pulse,vorbis,wavpack
GSTREAMER_VARS= XPRA_OPTIONS+=sound
LIBYUV_LIB_DEPENDS= libyuv.so:graphics/libyuv
LIBYUV_VARS= XPRA_OPTIONS+=csc_libyuv