aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2024-05-07 10:52:45 +0000
committerMikael Urankar <mikael@FreeBSD.org>2024-05-13 11:03:22 +0000
commitde786df83a233c5cf67528fe46736ebc20f48cb9 (patch)
tree6bd43ea656e07ba9e1bbeea674428933c3bbd801 /x11
parent75cbd67d71793ebe3755a834af22afa244552d76 (diff)
downloadports-de786df83a233c5cf67528fe46736ebc20f48cb9.tar.gz
ports-de786df83a233c5cf67528fe46736ebc20f48cb9.zip
x11/clipcat: Fix build with rust 1.78.0
PR: 278834 Approved by: portmgr (build fix blanket)
Diffstat (limited to 'x11')
-rw-r--r--x11/clipcat/files/patch-rust-1.78.035
1 files changed, 35 insertions, 0 deletions
diff --git a/x11/clipcat/files/patch-rust-1.78.0 b/x11/clipcat/files/patch-rust-1.78.0
new file mode 100644
index 000000000000..ac5ddecae19a
--- /dev/null
+++ b/x11/clipcat/files/patch-rust-1.78.0
@@ -0,0 +1,35 @@
+--- Cargo.toml.orig 2024-05-07 10:35:27.246548000 +0200
++++ Cargo.toml 2024-05-07 10:38:56.213212000 +0200
+@@ -62,7 +62,6 @@ unused_macro_rules = "deny"
+ unused_import_braces = "deny"
+ unused_lifetimes = "deny"
+ unused_macro_rules = "deny"
+-unused_qualifications = "deny"
+ unused_results = "deny"
+ variant_size_differences = "deny"
+
+@@ -80,8 +79,6 @@ const_item_mutation = "deny"
+ confusable_idents = "deny"
+ const_evaluatable_unchecked = "deny"
+ const_item_mutation = "deny"
+-const_patterns_without_partial_eq = "deny"
+-dead_code = "deny"
+ deprecated = "deny"
+ deprecated_where_clause_location = "deny"
+ deref_into_dyn_supertrait = "deny"
+@@ -100,7 +97,6 @@ hidden_glob_reexports = "deny"
+ for_loops_over_fallibles = "deny"
+ function_item_references = "deny"
+ hidden_glob_reexports = "deny"
+-illegal_floating_point_literal_pattern = "deny"
+ improper_ctypes = "deny"
+ improper_ctypes_definitions = "deny"
+ incomplete_features = "deny"
+@@ -119,7 +115,6 @@ named_arguments_used_positionally = "deny"
+ map_unit_fn = "deny"
+ mixed_script_confusables = "deny"
+ named_arguments_used_positionally = "deny"
+-nontrivial_structural_match = "deny"
+ non_camel_case_types = "deny"
+ non_fmt_panics = "deny"
+ non_shorthand_field_patterns = "deny"