aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2021-04-15 09:42:58 +0000
committerGleb Popov <arrowd@FreeBSD.org>2021-04-15 09:44:49 +0000
commite0c16587db9f64d435c65091fe8dc60e6c2b9862 (patch)
tree937bf7e3203c99a4b3d5aa21ec0fab5ba0a53a0f /x11
parent52d6b11899945ccf5269c8e7dc3f61cb497135ac (diff)
downloadports-e0c16587db9f64d435c65091fe8dc60e6c2b9862.tar.gz
ports-e0c16587db9f64d435c65091fe8dc60e6c2b9862.zip
Create x11/xpra-html port - a HTML5 client for x11/xpra
Previosly it was a part of x11/xpra. PR: 254313
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xpra-html5/Makefile35
-rw-r--r--x11/xpra-html5/distinfo3
-rw-r--r--x11/xpra-html5/pkg-descr6
-rw-r--r--x11/xpra-html5/pkg-plist178
5 files changed, 223 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index ed0d6df29e34..2ed9f9b0660a 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -493,6 +493,7 @@
SUBDIR += xorgproto
SUBDIR += xpr
SUBDIR += xpra
+ SUBDIR += xpra-html5
SUBDIR += xprintidle
SUBDIR += xprompt
SUBDIR += xprop
diff --git a/x11/xpra-html5/Makefile b/x11/xpra-html5/Makefile
new file mode 100644
index 000000000000..637aef07d329
--- /dev/null
+++ b/x11/xpra-html5/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= xpra-html5
+PORTVERSION= 4.1.2
+DISTVERSIONPREFIX= v
+CATEGORIES= x11
+
+MAINTAINER= arrowd@FreeBSD.org
+COMMENT= Browser-based client for x11/xpra
+
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= brotli:archivers/brotli
+
+USES= python:3.6+
+
+OPTIONS_DEFINE= MINIFY
+OPTIONS_DEFAULT= MINIFY
+
+MINIFY_DESC= Minify JavaScript source files
+MINIFY_BUILD_DEPENDS= yuicompressor:www/yuicompressor
+MINIFY_VARS= minifier=yuicompressor
+MINIFY_VARS_OFF= minifier=copy
+
+USE_PYTHON= noflavors
+
+USE_GITHUB= yes
+GH_ACCOUNT= Xpra-org
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+do-install:
+ cd ${WRKSRC} && ${PYTHON_CMD} setup.py install ${STAGEDIR}${PREFIX}/share/xpra/www ${MINIFIER}
+
+.include <bsd.port.mk>
diff --git a/x11/xpra-html5/distinfo b/x11/xpra-html5/distinfo
new file mode 100644
index 000000000000..8ede3adef38b
--- /dev/null
+++ b/x11/xpra-html5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1618478356
+SHA256 (Xpra-org-xpra-html5-v4.1.2_GH0.tar.gz) = 6356140e43a264dd430252aa27e5b720656e354677426e436fce153486b63a4b
+SIZE (Xpra-org-xpra-html5-v4.1.2_GH0.tar.gz) = 1521506
diff --git a/x11/xpra-html5/pkg-descr b/x11/xpra-html5/pkg-descr
new file mode 100644
index 000000000000..bc105cd49653
--- /dev/null
+++ b/x11/xpra-html5/pkg-descr
@@ -0,0 +1,6 @@
+Xpra gives you persistent remote applications for X. So basically it is a
+screen for remote X apps.
+
+This package contains Xpra HTML5 client that runs in the browser window.
+
+WWW: https://xpra.org/
diff --git a/x11/xpra-html5/pkg-plist b/x11/xpra-html5/pkg-plist
new file mode 100644
index 000000000000..a814ccf87b89
--- /dev/null
+++ b/x11/xpra-html5/pkg-plist
@@ -0,0 +1,178 @@
+share/xpra/www/connect.html
+share/xpra/www/connect.html.br
+share/xpra/www/connect.html.gz
+share/xpra/www/css/bootstrap.css
+share/xpra/www/css/bootstrap.css.br
+share/xpra/www/css/bootstrap.css.gz
+share/xpra/www/css/bootstrap.css.map
+share/xpra/www/css/bootstrap.css.map.br
+share/xpra/www/css/bootstrap.css.map.gz
+share/xpra/www/css/client.css
+share/xpra/www/css/client.css.br
+share/xpra/www/css/client.css.gz
+share/xpra/www/css/icon.css
+share/xpra/www/css/icon.css.br
+share/xpra/www/css/icon.css.gz
+share/xpra/www/css/menu-skin.css
+share/xpra/www/css/menu-skin.css.br
+share/xpra/www/css/menu-skin.css.gz
+share/xpra/www/css/menu.css
+share/xpra/www/css/menu.css.br
+share/xpra/www/css/menu.css.gz
+share/xpra/www/css/signin.css
+share/xpra/www/css/signin.css.br
+share/xpra/www/css/signin.css.gz
+share/xpra/www/css/simple-keyboard.css
+share/xpra/www/css/simple-keyboard.css.br
+share/xpra/www/css/simple-keyboard.css.gz
+share/xpra/www/css/simple-keyboard.css.map
+share/xpra/www/css/simple-keyboard.css.map.br
+share/xpra/www/css/simple-keyboard.css.map.gz
+share/xpra/www/css/spinner.css
+share/xpra/www/css/spinner.css.br
+share/xpra/www/css/spinner.css.gz
+share/xpra/www/default-settings.txt
+share/xpra/www/default-settings.txt.br
+share/xpra/www/default-settings.txt.gz
+share/xpra/www/favicon.ico
+share/xpra/www/favicon.ico.br
+share/xpra/www/favicon.ico.gz
+share/xpra/www/favicon.png
+share/xpra/www/icons/close.png
+share/xpra/www/icons/default_cursor.png
+share/xpra/www/icons/empty.png
+share/xpra/www/icons/fullscreen.png
+share/xpra/www/icons/materialicons-regular.ttf
+share/xpra/www/icons/materialicons-regular.ttf.br
+share/xpra/www/icons/materialicons-regular.ttf.gz
+share/xpra/www/icons/materialicons-regular.woff
+share/xpra/www/icons/materialicons-regular.woff.br
+share/xpra/www/icons/materialicons-regular.woff.gz
+share/xpra/www/icons/materialicons-regular.woff2
+share/xpra/www/icons/materialicons-regular.woff2.br
+share/xpra/www/icons/materialicons-regular.woff2.gz
+share/xpra/www/icons/maximize.png
+share/xpra/www/icons/minimize.png
+share/xpra/www/icons/noicon.png
+share/xpra/www/icons/speaker-buffering.png
+share/xpra/www/icons/speaker-off.png
+share/xpra/www/icons/speaker.png
+share/xpra/www/icons/unfullscreen.png
+share/xpra/www/icons/xpra-logo.png
+share/xpra/www/index.html
+share/xpra/www/index.html.br
+share/xpra/www/index.html.gz
+share/xpra/www/js/Client.js
+share/xpra/www/js/Client.js.br
+share/xpra/www/js/Client.js.gz
+share/xpra/www/js/Keycodes.js
+share/xpra/www/js/Keycodes.js.br
+share/xpra/www/js/Keycodes.js.gz
+share/xpra/www/js/MediaSourceUtil.js
+share/xpra/www/js/MediaSourceUtil.js.br
+share/xpra/www/js/MediaSourceUtil.js.gz
+share/xpra/www/js/Menu-custom.js
+share/xpra/www/js/Menu-custom.js.br
+share/xpra/www/js/Menu-custom.js.gz
+share/xpra/www/js/Menu.js
+share/xpra/www/js/Menu.js.br
+share/xpra/www/js/Menu.js.gz
+share/xpra/www/js/Notifications.js
+share/xpra/www/js/Notifications.js.br
+share/xpra/www/js/Notifications.js.gz
+share/xpra/www/js/Protocol.js
+share/xpra/www/js/Protocol.js.br
+share/xpra/www/js/Protocol.js.gz
+share/xpra/www/js/Utilities.js
+share/xpra/www/js/Utilities.js.br
+share/xpra/www/js/Utilities.js.gz
+share/xpra/www/js/Window.js
+share/xpra/www/js/Window.js.br
+share/xpra/www/js/Window.js.gz
+share/xpra/www/js/lib/AudioContextMonkeyPatch.js
+share/xpra/www/js/lib/AudioContextMonkeyPatch.js.br
+share/xpra/www/js/lib/AudioContextMonkeyPatch.js.gz
+share/xpra/www/js/lib/FileSaver.js
+share/xpra/www/js/lib/FileSaver.js.br
+share/xpra/www/js/lib/FileSaver.js.gz
+share/xpra/www/js/lib/aurora/aac.js
+share/xpra/www/js/lib/aurora/aac.js.br
+share/xpra/www/js/lib/aurora/aac.js.gz
+share/xpra/www/js/lib/aurora/aac.js.map
+share/xpra/www/js/lib/aurora/aac.js.map.br
+share/xpra/www/js/lib/aurora/aac.js.map.gz
+share/xpra/www/js/lib/aurora/aurora-xpra.js
+share/xpra/www/js/lib/aurora/aurora-xpra.js.br
+share/xpra/www/js/lib/aurora/aurora-xpra.js.gz
+share/xpra/www/js/lib/aurora/aurora.js
+share/xpra/www/js/lib/aurora/aurora.js.br
+share/xpra/www/js/lib/aurora/aurora.js.gz
+share/xpra/www/js/lib/aurora/flac.js
+share/xpra/www/js/lib/aurora/flac.js.br
+share/xpra/www/js/lib/aurora/flac.js.gz
+share/xpra/www/js/lib/aurora/flac.js.map
+share/xpra/www/js/lib/aurora/flac.js.map.br
+share/xpra/www/js/lib/aurora/flac.js.map.gz
+share/xpra/www/js/lib/aurora/mp3.js
+share/xpra/www/js/lib/aurora/mp3.js.br
+share/xpra/www/js/lib/aurora/mp3.js.gz
+share/xpra/www/js/lib/aurora/mp3.js.map
+share/xpra/www/js/lib/aurora/mp3.js.map.br
+share/xpra/www/js/lib/aurora/mp3.js.map.gz
+share/xpra/www/js/lib/bencode.js
+share/xpra/www/js/lib/bencode.js.br
+share/xpra/www/js/lib/bencode.js.gz
+share/xpra/www/js/lib/broadway/AUTHORS
+share/xpra/www/js/lib/broadway/AUTHORS.br
+share/xpra/www/js/lib/broadway/AUTHORS.gz
+share/xpra/www/js/lib/broadway/Decoder.js
+share/xpra/www/js/lib/broadway/Decoder.js.br
+share/xpra/www/js/lib/broadway/Decoder.js.gz
+share/xpra/www/js/lib/broadway/LICENSE
+share/xpra/www/js/lib/broadway/LICENSE.br
+share/xpra/www/js/lib/broadway/LICENSE.gz
+share/xpra/www/js/lib/brotli_decode.js
+share/xpra/www/js/lib/brotli_decode.js.br
+share/xpra/www/js/lib/brotli_decode.js.gz
+share/xpra/www/js/lib/es6-shim.js
+share/xpra/www/js/lib/es6-shim.js.br
+share/xpra/www/js/lib/es6-shim.js.gz
+share/xpra/www/js/lib/forge.js
+share/xpra/www/js/lib/forge.js.br
+share/xpra/www/js/lib/forge.js.gz
+share/xpra/www/js/lib/jquery-ui.js
+share/xpra/www/js/lib/jquery-ui.js.br
+share/xpra/www/js/lib/jquery-ui.js.gz
+share/xpra/www/js/lib/jquery.ba-throttle-debounce.js
+share/xpra/www/js/lib/jquery.ba-throttle-debounce.js.br
+share/xpra/www/js/lib/jquery.ba-throttle-debounce.js.gz
+share/xpra/www/js/lib/jquery.js
+share/xpra/www/js/lib/jquery.js.br
+share/xpra/www/js/lib/jquery.js.gz
+share/xpra/www/js/lib/jsmpeg.js
+share/xpra/www/js/lib/jsmpeg.js.br
+share/xpra/www/js/lib/jsmpeg.js.gz
+share/xpra/www/js/lib/jszip.js
+share/xpra/www/js/lib/jszip.js.br
+share/xpra/www/js/lib/jszip.js.gz
+share/xpra/www/js/lib/lz4.js
+share/xpra/www/js/lib/lz4.js.br
+share/xpra/www/js/lib/lz4.js.gz
+share/xpra/www/js/lib/pyrencoder.js
+share/xpra/www/js/lib/pyrencoder.js.br
+share/xpra/www/js/lib/pyrencoder.js.gz
+share/xpra/www/js/lib/simple-keyboard.js
+share/xpra/www/js/lib/simple-keyboard.js.br
+share/xpra/www/js/lib/simple-keyboard.js.gz
+share/xpra/www/js/lib/simple-keyboard.js.map
+share/xpra/www/js/lib/simple-keyboard.js.map.br
+share/xpra/www/js/lib/simple-keyboard.js.map.gz
+share/xpra/www/js/lib/wsworker_check.js
+share/xpra/www/js/lib/wsworker_check.js.br
+share/xpra/www/js/lib/wsworker_check.js.gz
+share/xpra/www/js/lib/zlib.js
+share/xpra/www/js/lib/zlib.js.br
+share/xpra/www/js/lib/zlib.js.gz
+share/xpra/www/js/lib/zlib.pretty.js.map
+share/xpra/www/js/lib/zlib.pretty.js.map.br
+share/xpra/www/js/lib/zlib.pretty.js.map.gz