aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-02-10 16:14:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-02-10 16:14:51 +0000
commited3678eef0b85e878a8deef180c4dd192e2b9050 (patch)
tree491513c395900f723a09d50e0a1b2dd55779f7e8 /x11
parent1184a12e5f2b0672a670fc8d473c24601db9ace1 (diff)
downloadports-ed3678eef0b85e878a8deef180c4dd192e2b9050.tar.gz
ports-ed3678eef0b85e878a8deef180c4dd192e2b9050.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/gromit-mpx/Makefile28
-rw-r--r--x11/gromit-mpx/distinfo3
-rw-r--r--x11/gromit-mpx/pkg-descr27
-rw-r--r--x11/gromit-mpx/pkg-plist11
5 files changed, 70 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 960f01123276..1d61040a264f 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -90,6 +90,7 @@
SUBDIR += grabc
SUBDIR += grim
SUBDIR += gromit
+ SUBDIR += gromit-mpx
SUBDIR += gskrab
SUBDIR += gstreamer1-plugins-x
SUBDIR += gstreamer1-plugins-ximagesrc
diff --git a/x11/gromit-mpx/Makefile b/x11/gromit-mpx/Makefile
new file mode 100644
index 000000000000..ae2e4921ad0a
--- /dev/null
+++ b/x11/gromit-mpx/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= gromit-mpx
+DISTVERSION= 1.4
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= On-screen annotation tool
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libappindicator3.so:devel/libappindicator
+
+USES= cmake gnome pkgconfig xorg
+USE_CSTD= gnu99
+USE_GITHUB= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30
+USE_XORG= x11 xi
+GH_ACCOUNT= bk138
+LDFLAGS+= -Wl,--as-needed # atk, dbusmenu, pango
+
+post-patch:
+# Let @sample handle default files under etc/
+ @${REINPLACE_CMD} -e '/data.*cfg/s/)/ RENAME ${PORTNAME}.cfg.sample)/' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/x11/gromit-mpx/distinfo b/x11/gromit-mpx/distinfo
new file mode 100644
index 000000000000..1bb656840371
--- /dev/null
+++ b/x11/gromit-mpx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1607006933
+SHA256 (bk138-gromit-mpx-1.4_GH0.tar.gz) = 6cdce7a459a05c3ab1ec8747a5eadbfc9b4bbc74db4a305c2f6f83b3233f98c4
+SIZE (bk138-gromit-mpx-1.4_GH0.tar.gz) = 1858578
diff --git a/x11/gromit-mpx/pkg-descr b/x11/gromit-mpx/pkg-descr
new file mode 100644
index 000000000000..12519238488b
--- /dev/null
+++ b/x11/gromit-mpx/pkg-descr
@@ -0,0 +1,27 @@
+Gromit-MPX is an on-screen annotation tool that works with any Unix
+desktop environment under X11 as well as Wayland.
+
+Its main use is for making presentations of some application.
+Normally, you would have to move the mouse pointer around the point of
+interest until hopefully everybody noticed it. With Gromit-MPX, you
+can draw everywhere onto the screen, highlighting some button or area.
+
+Key features include:
+- [Desktop-independent] Gromit-MPX works with GNOME, KDE, XFCE, ...
+ under X11 as well as with a Wayland session.
+- [Hotkey-based] The fundamental philosophy is that Gromit-MPX does not
+ get into your way of doing things by sticking some UI widget on your
+ desktop, potentially obscuring more important contents. It does
+ provide a UI, but only in form of a tray icon.
+- [Configurable] While Gromit-MPX comes with a default config, you are
+ free to change key bindings as well as drawing tool configuration.
+- [Multi-Pointer] Under X11, it enables graphical annotations with
+ several pointers at once or a dedicated annotation device setup where
+ you can use a second pair of input devices to annotate while
+ simultaneously continuing to work normally with the first pair.
+- [Fast] Where available, Gromit-MPX makes use of Compositing. This
+ should be the case on any contemporary desktop environment
+ making use of the XCOMPOSITE extension under X11 and with
+ every Wayland-based session.
+
+WWW: https://github.com/bk138/gromit-mpx
diff --git a/x11/gromit-mpx/pkg-plist b/x11/gromit-mpx/pkg-plist
new file mode 100644
index 000000000000..be696945ba36
--- /dev/null
+++ b/x11/gromit-mpx/pkg-plist
@@ -0,0 +1,11 @@
+bin/gromit-mpx
+@sample %%ETCDIR%%/gromit-mpx.cfg.sample
+man/man1/gromit-mpx.1.gz
+share/applications/net.christianbeier.Gromit-MPX.desktop
+share/icons/hicolor/scalable/apps/gromit-mpx.svg
+share/icons/hicolor/scalable/apps/gromit-mpx_active.svg
+share/icons/hicolor/scalable/apps/net.christianbeier.Gromit-MPX.svg
+share/metainfo/net.christianbeier.Gromit-MPX.appdata.xml
+share/pixmaps/gromit-mpx.png
+share/pixmaps/gromit-mpx.xpm
+share/pixmaps/gromit-mpx_active.png