aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-10-11 22:40:52 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-10-11 22:40:52 +0000
commitf1f9fc88eabef77bc5199618caa97d4601bd9b90 (patch)
treeb5d4112667f8898ed3a5bfef5a7798c48f2cc500 /x11
parentbc8096c671948238fb043c1322f4ad36b3ab1b55 (diff)
downloadports-f1f9fc88eabef77bc5199618caa97d4601bd9b90.tar.gz
ports-f1f9fc88eabef77bc5199618caa97d4601bd9b90.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/gcursor/Makefile2
-rw-r--r--x11/gcursor/distinfo4
-rw-r--r--x11/gcursor/files/patch-src::gcursor.c50
-rw-r--r--x11/gcursor/pkg-plist1
4 files changed, 51 insertions, 6 deletions
diff --git a/x11/gcursor/Makefile b/x11/gcursor/Makefile
index c1d10d04c103..ad80aab8f2c4 100644
--- a/x11/gcursor/Makefile
+++ b/x11/gcursor/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gcursor
-PORTVERSION= 0.06
+PORTVERSION= 0.061
CATEGORIES= x11 gnome
MASTER_SITES= http://download.qballcow.nl/programs/gcursor/
diff --git a/x11/gcursor/distinfo b/x11/gcursor/distinfo
index 4830a3d3c0aa..77af092130a1 100644
--- a/x11/gcursor/distinfo
+++ b/x11/gcursor/distinfo
@@ -1,2 +1,2 @@
-MD5 (gcursor-0.06.tar.gz) = 80cb9f3da98b595d298731aafc6c1384
-SIZE (gcursor-0.06.tar.gz) = 142932
+MD5 (gcursor-0.061.tar.gz) = 233810996bc7f69879f8978c523ae723
+SIZE (gcursor-0.061.tar.gz) = 143719
diff --git a/x11/gcursor/files/patch-src::gcursor.c b/x11/gcursor/files/patch-src::gcursor.c
index 3ba59c95315e..e5ee235e98af 100644
--- a/x11/gcursor/files/patch-src::gcursor.c
+++ b/x11/gcursor/files/patch-src::gcursor.c
@@ -1,14 +1,58 @@
---- src/gcursor.c.orig Thu Apr 8 10:25:03 2004
-+++ src/gcursor.c Thu Apr 8 18:00:14 2004
-@@ -32,10 +32,7 @@
+--- src/gcursor.c.orig Mon Sep 20 14:34:20 2004
++++ src/gcursor.c Mon Sep 20 14:34:25 2004
+@@ -32,29 +32,21 @@
#warning move this into gconf
char *paths[] = {
- "/usr/share/cursors/xfree/",
- "/usr/X11R6/lib/X11/icons/",
+- "/usr/Xorg/lib/X11/icons/",
- "/usr/local/share/icons/",
- "/usr/share/icons/",
+ "%%X11BASE%%/lib/X11/icons/",
"%s/.icons/",
NULL
};
+
+ void open_theme_dir()
+ {
+- GError * error = NULL;
+- char * filename;
+-
+- filename = g_strdup_printf("file:///%s/.icons/", g_getenv("HOME"));
+- gnome_url_show(filename,&error);
+- g_free(filename);
++ gchar *path, *command;
+
+- if (error)
+- {
+- gnome_warning_dialog (error->message);
+- g_error_free (error);
+- }
++ path = g_strdup_printf ("%s/.icons", g_get_home_dir());
++ command = g_strdup_printf ("nautilus --no-desktop %s", path);
++
++ g_free (path);
++ g_spawn_command_line_async (command, NULL);
++ g_free (command);
+ }
+
+
+@@ -85,7 +77,7 @@
+ filename = g_shell_quote(gtk_file_selection_get_filename(GTK_FILE_SELECTION(fs)));
+ #endif
+
+- path = g_strdup_printf("file-roller --extract-to=%s/.icons/ %s", g_getenv("HOME"),
++ path = g_strdup_printf("file-roller --extract-to=%s/.icons/ %s", g_get_home_dir(),
+ filename);
+ g_free(filename);
+
+@@ -281,7 +273,7 @@
+
+ for (iterator = paths; *iterator; iterator++)
+ {
+- dirname = g_strdup_printf(*iterator, g_getenv("HOME"));
++ dirname = g_strdup_printf(*iterator, g_get_home_dir());
+ directory = g_dir_open(dirname, 0, NULL);
+
+ while(directory != NULL && (name = g_dir_read_name(directory)) != NULL)
diff --git a/x11/gcursor/pkg-plist b/x11/gcursor/pkg-plist
index fe322ffbb20d..c9a93e43b126 100644
--- a/x11/gcursor/pkg-plist
+++ b/x11/gcursor/pkg-plist
@@ -8,5 +8,6 @@ share/gnome/capplets/gcursor.desktop
share/gnome/gcursor/gcursor.glade
share/locale/de/LC_MESSAGES/gcursor.mo
share/locale/es/LC_MESSAGES/gcursor.mo
+share/locale/sv/LC_MESSAGES/gcursor.mo
@dirrm share/gnome/gcursor
%%PORTDOCS%%@dirrm %%DOCSDIR%%