aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-20 22:47:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-20 22:47:01 +0000
commitf500436b4788df10bbb5d36cff7c5a62268f8960 (patch)
treefbe58febe667041a22ff3750510ce9002d3fd477 /x11
parentdbee938e956e1b68c275f4f4e1c83583453b873d (diff)
downloadports-f500436b4788df10bbb5d36cff7c5a62268f8960.tar.gz
ports-f500436b4788df10bbb5d36cff7c5a62268f8960.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/swarp/Makefile36
-rw-r--r--x11/swarp/distinfo3
-rw-r--r--x11/swarp/pkg-descr6
4 files changed, 46 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index a83366634380..1769e56181f2 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -272,6 +272,7 @@
SUBDIR += smproxy
SUBDIR += stalonetray
SUBDIR += startup-notification
+ SUBDIR += swarp
SUBDIR += sxpc
SUBDIR += temperature.app
SUBDIR += terminal.app
diff --git a/x11/swarp/Makefile b/x11/swarp/Makefile
new file mode 100644
index 000000000000..c622a5e2d3b1
--- /dev/null
+++ b/x11/swarp/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: swarp
+# Date created: 2008-01-15
+# Whom: Daniel Roethlisberger <daniel@roe.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= swarp
+PORTVERSION= 0.1
+CATEGORIES= x11
+MASTER_SITES= http://www.suckless.org/download/ \
+ http://mirror.roe.ch/dist/${PORTNAME}/
+
+MAINTAINER= daniel@roe.ch
+COMMENT= X11 generic pointer warping utility
+
+USE_XLIB= yes
+
+MAKE_ARGS= LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -lX11" \
+ CFLAGS="${CFLAGS} -I${X11BASE}/include \
+ -DVERSION=\\\"${PORTVERSION}\\\"" \
+ LD=${CC}
+
+PLIST_FILES= bin/swarp
+PORTDOCS= README
+
+post-patch:
+ @${ECHO} -n > ${WRKSRC}/config.mk
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/swarp/distinfo b/x11/swarp/distinfo
new file mode 100644
index 000000000000..cd7a45094b79
--- /dev/null
+++ b/x11/swarp/distinfo
@@ -0,0 +1,3 @@
+MD5 (swarp-0.1.tar.gz) = b674dd2f33c45cbd789e4b6e09b7b55e
+SHA256 (swarp-0.1.tar.gz) = ef5730fe8ee00879cbec1e91e22a7f0f7817a63375d790d775f5b7427886d45f
+SIZE (swarp-0.1.tar.gz) = 2277
diff --git a/x11/swarp/pkg-descr b/x11/swarp/pkg-descr
new file mode 100644
index 000000000000..1eccfe44db32
--- /dev/null
+++ b/x11/swarp/pkg-descr
@@ -0,0 +1,6 @@
+Simple pointer warp is a generic pointer warping utility for X11.
+It allows you to place the pointer to arbitrary x/y coordinates,
+for instance from within scripts. It is especially useful in
+conjunction with scripted window managers such as wmii.
+
+WWW: http://www.suckless.org/wiki/tools/xlib