aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xfce4-whiskermenu-plugin/Makefile25
-rw-r--r--x11/xfce4-whiskermenu-plugin/distinfo2
-rw-r--r--x11/xfce4-whiskermenu-plugin/pkg-descr3
-rw-r--r--x11/xfce4-whiskermenu-plugin/pkg-plist45
5 files changed, 76 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 0fc240ef0846..524a6da4a4e1 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -367,6 +367,7 @@
SUBDIR += xfce4-taskmanager
SUBDIR += xfce4-terminal
SUBDIR += xfce4-verve-plugin
+ SUBDIR += xfce4-whiskermenu-plugin
SUBDIR += xfce4-wmdock-plugin
SUBDIR += xfce4-xfapplet-plugin
SUBDIR += xfd
diff --git a/x11/xfce4-whiskermenu-plugin/Makefile b/x11/xfce4-whiskermenu-plugin/Makefile
new file mode 100644
index 000000000000..925773a23689
--- /dev/null
+++ b/x11/xfce4-whiskermenu-plugin/Makefile
@@ -0,0 +1,25 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= xfce4-whiskermenu-plugin
+PORTVERSION= 1.1.1
+CATEGORIES= x11 xfce
+MASTER_SITES= http://gottcode.org/${PORTNAME}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Alternate menu for the Xfce Desktop
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_BZIP2= yes
+USES= pkgconfig cmake gettext
+USE_GNOME= gtk20
+USE_XFCE= configenv garcon libexo libmenu libutil panel
+INSTALLS_ICONS= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/x11/xfce4-whiskermenu-plugin/distinfo b/x11/xfce4-whiskermenu-plugin/distinfo
new file mode 100644
index 000000000000..31dedb214de7
--- /dev/null
+++ b/x11/xfce4-whiskermenu-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xfce4/xfce4-whiskermenu-plugin-1.1.1-src.tar.bz2) = cfb86e9604c58a4657149950bfb693600a364ce4d64e4100c72bda489385dead
+SIZE (xfce4/xfce4-whiskermenu-plugin-1.1.1-src.tar.bz2) = 91002
diff --git a/x11/xfce4-whiskermenu-plugin/pkg-descr b/x11/xfce4-whiskermenu-plugin/pkg-descr
new file mode 100644
index 000000000000..40865f6e7865
--- /dev/null
+++ b/x11/xfce4-whiskermenu-plugin/pkg-descr
@@ -0,0 +1,3 @@
+Whisker Menu is an alternate application launcher for the Xfce Desktop.
+
+WWW: http://gottcode.org/xfce4-whiskermenu-plugin/
diff --git a/x11/xfce4-whiskermenu-plugin/pkg-plist b/x11/xfce4-whiskermenu-plugin/pkg-plist
new file mode 100644
index 000000000000..72baf583d9f4
--- /dev/null
+++ b/x11/xfce4-whiskermenu-plugin/pkg-plist
@@ -0,0 +1,45 @@
+bin/xfce4-popup-whiskermenu
+lib/xfce4/panel/plugins/libwhiskermenu.so
+share/icons/hicolor/128x128/apps/xfce4-whiskermenu.png
+share/icons/hicolor/16x16/apps/xfce4-whiskermenu.png
+share/icons/hicolor/22x22/apps/xfce4-whiskermenu.png
+share/icons/hicolor/24x24/apps/xfce4-whiskermenu.png
+share/icons/hicolor/256x256/apps/xfce4-whiskermenu.png
+share/icons/hicolor/32x32/apps/xfce4-whiskermenu.png
+share/icons/hicolor/48x48/apps/xfce4-whiskermenu.png
+share/icons/hicolor/64x64/apps/xfce4-whiskermenu.png
+share/icons/hicolor/scalable/apps/xfce4-whiskermenu.svg
+share/locale/ar/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/bg/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/ca/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/da/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/de/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/el/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/en_GB/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/es/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/fr/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/he/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/hu/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/id/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/it/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/ja/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/kk/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/ms/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/nb/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/nl/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/pl/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/pt/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/pt_BR/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/ro/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/ru/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/sk/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/sv/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/tr/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/locale/vi/LC_MESSAGES/xfce4-whiskermenu-plugin.mo
+share/xfce4/panel/plugins/whiskermenu.desktop
+@dirrmtry share/xfce4/panel/plugins
+@dirrmtry share/xfce4/panel
+@dirrmtry share/xfce4
+@dirrmtry lib/xfce4/panel/plugins
+@dirrmtry lib/xfce4/panel
+@dirrmtry lib/xfce4