aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--finance/fava/Makefile3
-rw-r--r--japanese/font-myrica/Makefile3
-rw-r--r--japanese/font-myricam/Makefile3
-rw-r--r--java/icedtea-web/Makefile3
-rw-r--r--security/py-dfvfs/Makefile3
-rw-r--r--www/qutebrowser/Makefile3
6 files changed, 18 insertions, 0 deletions
diff --git a/finance/fava/Makefile b/finance/fava/Makefile
index 056719ae316d..f36024d2db5a 100644
--- a/finance/fava/Makefile
+++ b/finance/fava/Makefile
@@ -29,4 +29,7 @@ RUN_DEPENDS= beancount>=2.1.3:finance/beancount \
USES= python:3.5+ # same as finance/beancount
USE_PYTHON= autoplist distutils noflavors
+# Upstream archive contains files with UTF-8 names
+EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
+
.include <bsd.port.mk>
diff --git a/japanese/font-myrica/Makefile b/japanese/font-myrica/Makefile
index 57625c2e4ec1..1d33fd47eadb 100644
--- a/japanese/font-myrica/Makefile
+++ b/japanese/font-myrica/Makefile
@@ -23,6 +23,9 @@ SUB_FILES= pkg-install
WRKSRC= ${WRKDIR}/${DISTNAME}
PORTDOCS= LICENSE_M+.txt LICENSE_OFL.txt README.md
+# Upstream archive contains files with UTF-8 names
+EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
+
OPTIONS_DEFINE= DOCS
do-install:
diff --git a/japanese/font-myricam/Makefile b/japanese/font-myricam/Makefile
index ccf3f52bc0ec..e3aae4ec0a7b 100644
--- a/japanese/font-myricam/Makefile
+++ b/japanese/font-myricam/Makefile
@@ -23,6 +23,9 @@ SUB_FILES= pkg-install
WRKSRC= ${WRKDIR}/${DISTNAME}
PORTDOCS= LICENSE_M+.txt LICENSE_OFL.txt README.md
+# Upstream archive contains files with UTF-8 names
+EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
+
OPTIONS_DEFINE= DOCS
do-install:
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index 28f00a1aa6bf..257f43f902a9 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -49,6 +49,9 @@ CONFIGURE_SHELL= ${bash_CMD}
TEST_TARGET= check
+# Upstream archive contains files with UTF-8 names
+EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
+
OPTIONS_DEFINE= DOCS PLUGIN RHINO TAGSOUP
OPTIONS_DEFAULT=PLUGIN
OPTIONS_SUB= yes
diff --git a/security/py-dfvfs/Makefile b/security/py-dfvfs/Makefile
index bb01f0059b88..cb54d4a2a328 100644
--- a/security/py-dfvfs/Makefile
+++ b/security/py-dfvfs/Makefile
@@ -44,6 +44,9 @@ USE_PYTHON= distutils autoplist concurrent
NO_ARCH= yes
+# Upstream archive contains files with UTF-8 names
+EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
+
post-patch:
${REINPLACE_CMD} "s,share/doc/dfvfs,${DOCSDIR_REL}," ${WRKSRC}/setup.py
diff --git a/www/qutebrowser/Makefile b/www/qutebrowser/Makefile
index cd4fba26b328..1992156cb1b2 100644
--- a/www/qutebrowser/Makefile
+++ b/www/qutebrowser/Makefile
@@ -29,6 +29,9 @@ USE_PYTHON= distutils autoplist noflavors
NO_ARCH= yes
PLIST_FILES= share/applications/${PORTNAME}-${PYTHON_VER}.desktop
+# Upstream archive contains files with UTF-8 names
+EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
+
OPTIONS_MULTI= BACKEND
OPTIONS_MULTI_BACKEND= WEBKIT WEBENGINE
OPTIONS_DEFAULT= WEBKIT