aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING9
-rw-r--r--games/bsdgames/Makefile19
-rw-r--r--games/bsdgames/distinfo4
-rw-r--r--games/bsdgames/files/patch-battlestar_externs.h (renamed from games/bsdgames/files/patch-battlestar)11
-rw-r--r--games/bsdgames/files/patch-battlestar_fly.c11
-rw-r--r--games/bsdgames/files/patch-cribbage_instr.c (renamed from games/bsdgames/files/patch-dfly)14
-rw-r--r--games/bsdgames/files/patch-hack_hack.unix.c (renamed from games/bsdgames/files/patch-hack)28
-rw-r--r--games/bsdgames/files/patch-sail_pl_1.c14
-rw-r--r--games/bsdgames/pkg-plist75
9 files changed, 99 insertions, 86 deletions
diff --git a/UPDATING b/UPDATING
index e378850035ff..d5d537f3b1e7 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,15 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20140722
+ AFFECTS: users of games/bsdgames
+ AUTHOR: adamw@adamw.org
+
+ bsdgames now expects savegame data in /usr/local/var/games instead of
+ /var/games. To continue using your saved games,
+
+ cp -rp /var/games/* /usr/local/var/games
+
20140714:
AFFECTS: users of databases/db6
AUTHOR: mandree@FreeBSD.org
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
index 6b7b2de99363..9943a2b76548 100644
--- a/games/bsdgames/Makefile
+++ b/games/bsdgames/Makefile
@@ -2,22 +2,21 @@
# $FreeBSD$
PORTNAME= bsdgames
-PORTVERSION= 2.4
-PORTREVISION= 3
+PORTVERSION= 3.8.1
PORTEPOCH= 1
CATEGORIES= games
-# Fetched from http://gitweb.dragonflybsd.org/dragonfly.git/tree/v2.4.0:/games
+# Fetched from http://gitweb.dragonflybsd.org/dragonfly.git/tree/v${PORTVERSION}:/games
# Content is stable, but file timestamps differ. Bad gitweb, no cookie!
MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= uqs
+MASTER_SITE_SUBDIR= adamw
MAINTAINER= adamw@FreeBSD.org
COMMENT= Traditional BSD games taken from DragonFly BSD
CONFLICTS= hangman-*
-USES= tar:bzip2
-WRKSRC= ${WRKDIR}/dragonfly
+USES= tar:xz
+#WRKSRC= ${WRKDIR}/dragonfly
MAKE_ENV+= NO_WERROR=1
# contain /usr/share/games
@@ -65,17 +64,19 @@ post-patch:
${REINPLACE_CMD} -e 's/HIDEGAME/SGIDGAME/' \
${WRKSRC}/$${f}/Makefile; \
done
+ @${FIND} ${WRKSRC} -type f | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|/var/games/|${PREFIX}&|g'
pre-install:
.for d in atc larn quiz.db
@${MKDIR} ${STAGEDIR}${PREFIX}/share/games/$d
.endfor
.for d in atc battlestar hackdir/save larn phantasia
- @${MKDIR} ${STAGEDIR}/var/games/$d
+ @${MKDIR} ${STAGEDIR}${PREFIX}/var/games/$d
.endfor
post-install:
- @${TOUCH} ${STAGEDIR}/var/games/atc_score
- @${FIND} ${STAGEDIR}/var/games -type f -exec ${MV} {} {}.sample \;
+ @${TOUCH} ${STAGEDIR}${PREFIX}/var/games/atc_score
+ @${FIND} ${STAGEDIR}${PREFIX}/var/games -type f -exec ${MV} {} {}.sample \;
.include <bsd.port.mk>
diff --git a/games/bsdgames/distinfo b/games/bsdgames/distinfo
index 435241fd9a46..aab372bf2804 100644
--- a/games/bsdgames/distinfo
+++ b/games/bsdgames/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bsdgames-2.4.tar.bz2) = c89da5b3a63b3d5b4ecb9658a549a0ade114529d10890cd6cf0979a96a28ce19
-SIZE (bsdgames-2.4.tar.bz2) = 2011321
+SHA256 (bsdgames-3.8.1.tar.xz) = 573a1ae4201f911b33e0002e7f935b58b29175512f65af55eb333be9d714c7f7
+SIZE (bsdgames-3.8.1.tar.xz) = 1750464
diff --git a/games/bsdgames/files/patch-battlestar b/games/bsdgames/files/patch-battlestar_externs.h
index f2f85218cae0..c6bfa19de6b6 100644
--- a/games/bsdgames/files/patch-battlestar
+++ b/games/bsdgames/files/patch-battlestar_externs.h
@@ -1,14 +1,3 @@
-diff -Naur battlestar.orig/fly.c battlestar/fly.c
---- battlestar.orig/fly.c 2012-03-22 13:59:00.000000000 +0100
-+++ battlestar/fly.c 2012-03-22 13:59:09.000000000 +0100
-@@ -294,6 +294,7 @@
- signal(SIGALRM, SIG_DFL);
- mvcur(0,COLS-1,LINES-1,0);
- endwin();
-+ setlinebuf(stdout);
- signal(SIGTSTP, SIG_DFL);
- signal(SIGINT, oldsig);
- }
--- battlestar/externs.h.orig 2012-05-25 11:57:52.000000000 +0200
+++ battlestar/externs.h 2012-05-25 11:57:55.000000000 +0200
@@ -44,15 +44,18 @@
diff --git a/games/bsdgames/files/patch-battlestar_fly.c b/games/bsdgames/files/patch-battlestar_fly.c
new file mode 100644
index 000000000000..9cffa3f81bcf
--- /dev/null
+++ b/games/bsdgames/files/patch-battlestar_fly.c
@@ -0,0 +1,11 @@
+diff -Naur battlestar.orig/fly.c battlestar/fly.c
+--- battlestar.orig/fly.c 2012-03-22 13:59:00.000000000 +0100
++++ battlestar/fly.c 2012-03-22 13:59:09.000000000 +0100
+@@ -286,6 +286,7 @@
+ signal(SIGALRM, SIG_DFL);
+ mvcur(0,COLS-1,LINES-1,0);
+ endwin();
++ setlinebuf(stdout);
+ signal(SIGTSTP, SIG_DFL);
+ signal(SIGINT, oldsig);
+ }
diff --git a/games/bsdgames/files/patch-dfly b/games/bsdgames/files/patch-cribbage_instr.c
index f67f19f89f11..0c4b09851d2a 100644
--- a/games/bsdgames/files/patch-dfly
+++ b/games/bsdgames/files/patch-cribbage_instr.c
@@ -24,17 +24,3 @@
exit(1);
}
}
---- ./sail/pl_1.c
-+++ ./sail/pl_1.c
-@@ -122,7 +122,11 @@ choke(void)
- void
- child(void)
- {
-+#ifdef __DragonFly__
- union wait status;
-+#else
-+ int status;
-+#endif
- int pid;
-
- signal(SIGCHLD, SIG_IGN);
diff --git a/games/bsdgames/files/patch-hack b/games/bsdgames/files/patch-hack_hack.unix.c
index 7165fa62fdb9..39773be5ba9d 100644
--- a/games/bsdgames/files/patch-hack
+++ b/games/bsdgames/files/patch-hack_hack.unix.c
@@ -1,28 +1,28 @@
---- hack/hack.unix.c.orig 2009-09-24 10:46:30.000000000 +0200
-+++ hack/hack.unix.c 2009-11-04 18:49:58.645035610 +0100
-@@ -19,7 +19,9 @@
+--- hack/hack.unix.c.orig 2014-07-22 09:54:22.000000000 -0400
++++ hack/hack.unix.c 2014-07-22 10:20:43.000000000 -0400
+@@ -18,7 +18,9 @@
- #include <sys/types.h> /* for time_t and stat */
- #include <sys/stat.h>
-+#include <sys/param.h>
- #include <time.h>
-+#include <err.h>
+ #include <sys/types.h> /* for time_t and stat */
+ #include <sys/stat.h>
++#include <sys/param.h>
+ #include <time.h>
++#include <err.h>
- static struct tm *getlt(void);
- static bool veryold(int);
-@@ -95,13 +97,32 @@
+ static struct tm *getlt(void);
+ static bool veryold(int);
+@@ -94,13 +96,32 @@
void
gethdate(const char *name)
{
-/* old version - for people short of space */
--char *np;
+- char *np;
+ char *p, *np, *path;
+ char filename[MAXPATHLEN+1];
- name = "/usr/games/hide/hack";
-- if(stat(name, &hbuf))
+- if (stat(name, &hbuf))
- error("Cannot get status of %s.",
-- (np = rindex(name, '/')) ? np+1 : name);
+- (np = strrchr(name, '/')) ? np + 1 : name);
+ if (strchr(name, '/') != NULL || (p = getenv("PATH")) == NULL)
+ p = "";
+ np = path = strdup(p); /* Make a copy for strsep. */
diff --git a/games/bsdgames/files/patch-sail_pl_1.c b/games/bsdgames/files/patch-sail_pl_1.c
new file mode 100644
index 000000000000..c858f5e30bb4
--- /dev/null
+++ b/games/bsdgames/files/patch-sail_pl_1.c
@@ -0,0 +1,14 @@
+--- ./sail/pl_1.c
++++ ./sail/pl_1.c
+@@ -122,7 +122,11 @@ choke(void)
+ void
+ child(void)
+ {
++#ifdef __DragonFly__
+ union wait status;
++#else
++ int status;
++#endif
+ int pid;
+
+ signal(SIGCHLD, SIG_IGN);
diff --git a/games/bsdgames/pkg-plist b/games/bsdgames/pkg-plist
index 6f5a4ae730d8..b2d1a608d16d 100644
--- a/games/bsdgames/pkg-plist
+++ b/games/bsdgames/pkg-plist
@@ -106,44 +106,47 @@ share/games/quiz.db/ucc
share/games/cribbage.instr
share/games/fish.instr
share/games/wump.info
-@dirrm share/games/atc
-@dirrm share/games/larn
-@dirrm share/games/quiz.db
-@dirrm share/games
@group games
@mode 664
-@sample /var/games/hackdir/help.sample
-@sample /var/games/hackdir/hh.sample
-@sample /var/games/hackdir/data.sample
-@sample /var/games/hackdir/perm.sample
-@sample /var/games/hackdir/record.sample
-@sample /var/games/hackdir/rumors.sample
-@sample /var/games/larn/lscore12.0.sample
-@sample /var/games/larn/llog12.0.sample
-@sample /var/games/phantasia/monsters.sample
-@sample /var/games/phantasia/void.sample
-@sample /var/games/phantasia/characs.sample
-@sample /var/games/phantasia/gold.sample
-@sample /var/games/phantasia/lastdead.sample
-@sample /var/games/phantasia/mess.sample
-@sample /var/games/phantasia/motd.sample
-@sample /var/games/phantasia/scoreboard.sample
-@sample /var/games/atc_score.sample
-@sample /var/games/battlestar.log.sample
-@sample /var/games/cfscores.sample
-@sample /var/games/criblog.sample
-@sample /var/games/robots_roll.sample
-@sample /var/games/rogue.scores.sample
-@sample /var/games/saillog.sample
-@sample /var/games/snakerawscores.sample
-@sample /var/games/snake.log.sample
+@sample var/games/atc_score.sample
+@sample var/games/battlestar.log.sample
+@sample var/games/cfscores.sample
+@sample var/games/criblog.sample
+@sample var/games/hackdir/help.sample
+@sample var/games/hackdir/hh.sample
+@sample var/games/hackdir/data.sample
+@sample var/games/hackdir/perm.sample
+@sample var/games/hackdir/record.sample
+@sample var/games/hackdir/rumors.sample
+@sample var/games/larn/lscore12.0.sample
+@sample var/games/larn/llog12.0.sample
+@sample var/games/phantasia/monsters.sample
+@sample var/games/phantasia/void.sample
+@sample var/games/phantasia/characs.sample
+@sample var/games/phantasia/gold.sample
+@sample var/games/phantasia/lastdead.sample
+@sample var/games/phantasia/mess.sample
+@sample var/games/phantasia/motd.sample
+@sample var/games/phantasia/scoreboard.sample
+@sample var/games/robots_roll.sample
+@sample var/games/rogue.scores.sample
+@sample var/games/saillog.sample
+@sample var/games/snakerawscores.sample
+@sample var/games/snake.log.sample
@mode 0775
-@dirrmtry /var/games/phantasia
-@dirrmtry /var/games/larn
+@dirrmtry var/games/phantasia
+@dirrmtry var/games/larn
@mode 0770
-@dirrmtry /var/games/hackdir/save
+@dirrmtry var/games/hackdir/save
@mode 0775
-@dirrmtry /var/games/hackdir
-@dirrmtry /var/games/battlestar
-@dirrmtry /var/games/atc
-@dirrmtry /var/games
+@dirrmtry var/games/hackdir
+@dirrmtry var/games/battlestar
+@dirrmtry var/games/atc
+@dirrmtry var/games
+@mode
+@group
+@dirrmtry var
+@dirrm share/games/atc
+@dirrm share/games/larn
+@dirrm share/games/quiz.db
+@dirrm share/games