aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs2
-rw-r--r--UIDs2
-rw-r--r--UPDATING8
-rw-r--r--sysutils/nut-devel/Makefile8
-rw-r--r--sysutils/nut/Makefile8
5 files changed, 20 insertions, 8 deletions
diff --git a/GIDs b/GIDs
index 08e2ed3767a4..d101bd427a53 100644
--- a/GIDs
+++ b/GIDs
@@ -256,7 +256,7 @@ _sphinx:*:312:
_fastdfs:*:313:
promscale:*:314:
lavinmq:*:315:
-# free: 316
+nut:*:316:
# free: 317
# free: 318
# free: 319
diff --git a/UIDs b/UIDs
index 7a7aee1f9492..5057f56c9672 100644
--- a/UIDs
+++ b/UIDs
@@ -261,7 +261,7 @@ _sphinx:*:312:312::0:0:Sphinxsearch Owner:/nonexistent:/usr/sbin/nologin
_fastdfs:*:313:313::0:0:FastDFS Owner:/nonexistent:/usr/sbin/nologin
promscale:*:314:314::0:0:Promscale:/nonexistent:/usr/sbin/nologin
lavinmq:*:315:315::0:0:LavinMQ user:/nonexistent:/usr/sbin/nologin
-# free: 316
+nut:*:316:316::0:0:Network UPS Tools user:/nonexistent:/usr/sbin/nologin
# free: 317
# free: 318
# free: 319
diff --git a/UPDATING b/UPDATING
index 3fcbb66292c2..87d5e3e55ef1 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20230116:
+ AFFECTS: users of sysutils/nut and sysutils/nut-devel
+ AUTHOR: cy@freebsd.org
+
+ As of PR/268960 Network UPS Tools will now run under its own UID and GID
+ instead of uucp. Users who wish to continue using the uucp user and
+ group may add NUT_USER=uucp and NUT_GROUP=uucp to their make.conf.
+
20230111:
AFFECTS: users of sysutils/graylog
AUTHOR: dch@freebsd.org
diff --git a/sysutils/nut-devel/Makefile b/sysutils/nut-devel/Makefile
index 73c12f6dba39..9062aedab8f2 100644
--- a/sysutils/nut-devel/Makefile
+++ b/sysutils/nut-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= nut
PORTVERSION= ${NUT_COMMIT_DATE}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
PKGNAMESUFFIX= -devel
# MASTER_SITES= http://www.networkupstools.org/source/${PORTVERSION:R}/
@@ -28,8 +28,10 @@ GNU_CONFIGURE= yes
USES= autoreconf:build compiler:c11 gmake libtool pkgconfig python
USE_LDCONFIG= yes
-NUT_USER?= uucp
-NUT_GROUP?= uucp
+NUT_USER?= nut
+NUT_GROUP?= nut
+USERS= ${NUT_USER}
+GROUPS= ${NUT_GROUP}
STATEDIR?= /var/db/nut
PLIST_SUB+= NUT_USER=${NUT_USER}
PLIST_SUB+= NUT_GROUP=${NUT_GROUP}
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
index 7d3aecc8b8d4..5a23d86a286c 100644
--- a/sysutils/nut/Makefile
+++ b/sysutils/nut/Makefile
@@ -1,6 +1,6 @@
PORTNAME= nut
PORTVERSION= 2.8.0
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= sysutils
MASTER_SITES= http://www.networkupstools.org/source/${PORTVERSION:R}/
@@ -18,8 +18,10 @@ GNU_CONFIGURE= yes
USES= autoreconf:build compiler:c11 gmake libtool pkgconfig python:build
USE_LDCONFIG= yes
-NUT_USER?= uucp
-NUT_GROUP?= uucp
+NUT_USER?= nut
+NUT_GROUP?= nut
+USERS= ${NUT_USER}
+GROUPS= ${NUT_GROUP}
STATEDIR?= /var/db/nut
PLIST_SUB+= NUT_USER=${NUT_USER}
PLIST_SUB+= NUT_GROUP=${NUT_GROUP}