aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile4
-rw-r--r--devel/pear-Console_Getopt/Makefile38
-rw-r--r--devel/pear-Console_Getopt/distinfo1
-rw-r--r--devel/pear-Console_Getopt/pkg-comment1
-rw-r--r--devel/pear-Console_Getopt/pkg-descr4
-rw-r--r--devel/pear-Console_Getopt/pkg-plist3
-rw-r--r--devel/pear-PEAR/Makefile45
-rw-r--r--devel/pear-PEAR/distinfo1
-rw-r--r--devel/pear-PEAR/pkg-comment1
-rw-r--r--devel/pear-PEAR/pkg-descr4
-rw-r--r--devel/pear-PEAR/pkg-plist34
-rw-r--r--devel/pear-install/Makefile39
-rw-r--r--devel/pear-install/pkg-comment1
-rw-r--r--devel/pear-install/pkg-descr6
-rw-r--r--devel/pear-install/pkg-plist4
-rw-r--r--devel/pear/Makefile42
-rw-r--r--devel/pear/pkg-comment1
-rw-r--r--devel/pear/pkg-descr20
-rw-r--r--devel/pear/pkg-plist1
-rw-r--r--mail/Makefile1
-rw-r--r--mail/pear-Mail_Mime/Makefile39
-rw-r--r--mail/pear-Mail_Mime/distinfo1
-rw-r--r--mail/pear-Mail_Mime/pkg-comment1
-rw-r--r--mail/pear-Mail_Mime/pkg-descr3
-rw-r--r--mail/pear-Mail_Mime/pkg-plist5
-rw-r--r--net/Makefile2
-rw-r--r--net/pear-Net_Sieve/Makefile37
-rw-r--r--net/pear-Net_Sieve/distinfo1
-rw-r--r--net/pear-Net_Sieve/pkg-comment1
-rw-r--r--net/pear-Net_Sieve/pkg-descr6
-rw-r--r--net/pear-Net_Sieve/pkg-plist1
-rw-r--r--net/pear-Net_Socket/Makefile36
-rw-r--r--net/pear-Net_Socket/distinfo1
-rw-r--r--net/pear-Net_Socket/pkg-comment1
-rw-r--r--net/pear-Net_Socket/pkg-descr7
-rw-r--r--net/pear-Net_Socket/pkg-plist1
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/pear-File/Makefile37
-rw-r--r--sysutils/pear-File/distinfo1
-rw-r--r--sysutils/pear-File/pkg-comment1
-rw-r--r--sysutils/pear-File/pkg-descr5
-rw-r--r--sysutils/pear-File/pkg-plist5
-rw-r--r--sysutils/pear-Log/Makefile36
-rw-r--r--sysutils/pear-Log/distinfo1
-rw-r--r--sysutils/pear-Log/pkg-comment1
-rw-r--r--sysutils/pear-Log/pkg-descr6
-rw-r--r--sysutils/pear-Log/pkg-plist10
47 files changed, 499 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6dfc83f54e80..7e4e86c03a2d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -623,6 +623,10 @@
SUBDIR += pcre
SUBDIR += pcre++
SUBDIR += pcsc-lite
+ SUBDIR += pear
+ SUBDIR += pear-Console_Getopt
+ SUBDIR += pear-PEAR
+ SUBDIR += pear-install
SUBDIR += pedisassem
SUBDIR += perforce
SUBDIR += perltidy
diff --git a/devel/pear-Console_Getopt/Makefile b/devel/pear-Console_Getopt/Makefile
new file mode 100644
index 000000000000..59ae58dd8d56
--- /dev/null
+++ b/devel/pear-Console_Getopt/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: pear-Console_Getopt
+# Date created: 23 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Console_Getopt
+PORTVERSION= 1.0
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install \
+ ${LOCALBASE}/bin/php:${PORTSDIR}/lang/php4
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${MV} ${PEARDIR}/Console/Getopt.php ${PEARDIR}/Console/Getopt.php.dist
+ @${CP} -Rp ${WRKSRC}/Console/Getopt.php ${PEARDIR}/Console
+ @${CHOWN} -R root:wheel ${PEARDIR}/Console/Getopt.php
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Console_Getopt/distinfo b/devel/pear-Console_Getopt/distinfo
new file mode 100644
index 000000000000..d07b6da5dd75
--- /dev/null
+++ b/devel/pear-Console_Getopt/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Console_Getopt-1.0.tgz) = 0a80d98559c9c0d20f6128b5edcb9aac
diff --git a/devel/pear-Console_Getopt/pkg-comment b/devel/pear-Console_Getopt/pkg-comment
new file mode 100644
index 000000000000..9f6b1b2ff609
--- /dev/null
+++ b/devel/pear-Console_Getopt/pkg-comment
@@ -0,0 +1 @@
+PEAR command-line option parser
diff --git a/devel/pear-Console_Getopt/pkg-descr b/devel/pear-Console_Getopt/pkg-descr
new file mode 100644
index 000000000000..bdfd95f64fe2
--- /dev/null
+++ b/devel/pear-Console_Getopt/pkg-descr
@@ -0,0 +1,4 @@
+This is a PHP implementation of "getopt" supporting both short and long
+options.
+
+WWW: http://pear.php.net/manual/en/core.console.getopt.php
diff --git a/devel/pear-Console_Getopt/pkg-plist b/devel/pear-Console_Getopt/pkg-plist
new file mode 100644
index 000000000000..3887db705822
--- /dev/null
+++ b/devel/pear-Console_Getopt/pkg-plist
@@ -0,0 +1,3 @@
+@exec mv %D/lib/php/Console/Getopt.php %D/lib/php/Console/Getopt.php.dist
+%%PEARDIR%%/Console/Getopt.php
+@unexec mv %D/lib/php/Console/Getopt.php.dist %D/lib/php/Console/Getopt.php || true
diff --git a/devel/pear-PEAR/Makefile b/devel/pear-PEAR/Makefile
new file mode 100644
index 000000000000..b1bb6bede494
--- /dev/null
+++ b/devel/pear-PEAR/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: pear-PEAR
+# Date created: 22 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= PEAR
+PORTVERSION= 1.0.1
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1/b1/}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${MV} ${PEARDIR}/PEAR ${PEARDIR}/PEAR.dist
+ @${MV} ${PEARDIR}/PEAR.php ${PEARDIR}/PEAR.php.dist
+ @${MV} ${PEARDIR}/System.php ${PEARDIR}/System.php.dist
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+ @${CHOWN} -R root:wheel ${PEARDIR}/OS
+ @${CHOWN} -R root:wheel ${PEARDIR}/PEAR*
+ @${CHOWN} -R root:wheel ${PEARDIR}/System.php
+ @${CHOWN} -R root:wheel ${PEARDIR}/package.dtd
+ @${CHOWN} -R root:wheel ${PEARDIR}/scripts
+ @${CHOWN} -R root:wheel ${PEARDIR}/template.spec
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-PEAR/distinfo b/devel/pear-PEAR/distinfo
new file mode 100644
index 000000000000..fe522402bd58
--- /dev/null
+++ b/devel/pear-PEAR/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/PEAR-1.0b1.tgz) = 6109077247d825df343f766713e899de
diff --git a/devel/pear-PEAR/pkg-comment b/devel/pear-PEAR/pkg-comment
new file mode 100644
index 000000000000..bee5cc06093c
--- /dev/null
+++ b/devel/pear-PEAR/pkg-comment
@@ -0,0 +1 @@
+PEAR Base System
diff --git a/devel/pear-PEAR/pkg-descr b/devel/pear-PEAR/pkg-descr
new file mode 100644
index 000000000000..a74f3c8c6a11
--- /dev/null
+++ b/devel/pear-PEAR/pkg-descr
@@ -0,0 +1,4 @@
+PEAR Base System, with the PEAR base class and the PEAR_Error error handling
+mechanism.
+
+WWW: http://pear.php.net/manual/en/reference.php
diff --git a/devel/pear-PEAR/pkg-plist b/devel/pear-PEAR/pkg-plist
new file mode 100644
index 000000000000..9f99761be75d
--- /dev/null
+++ b/devel/pear-PEAR/pkg-plist
@@ -0,0 +1,34 @@
+%%PEARDIR%%/package.dtd
+%%PEARDIR%%/template.spec
+%%PEARDIR%%/PEAR.php
+%%PEARDIR%%/System.php
+%%PEARDIR%%/OS/Guess.php
+%%PEARDIR%%/PEAR/Autoloader.php
+%%PEARDIR%%/PEAR/Command.php
+%%PEARDIR%%/PEAR/Command/Auth.php
+%%PEARDIR%%/PEAR/Command/Build.php
+%%PEARDIR%%/PEAR/Command/Common.php
+%%PEARDIR%%/PEAR/Command/Config.php
+%%PEARDIR%%/PEAR/Command/Install.php
+%%PEARDIR%%/PEAR/Command/Package.php
+%%PEARDIR%%/PEAR/Command/Registry.php
+%%PEARDIR%%/PEAR/Command/Remote.php
+%%PEARDIR%%/PEAR/Common.php
+%%PEARDIR%%/PEAR/Config.php
+%%PEARDIR%%/PEAR/Dependency.php
+%%PEARDIR%%/PEAR/Frontend/CLI.php
+%%PEARDIR%%/PEAR/Builder.php
+%%PEARDIR%%/PEAR/Installer.php
+%%PEARDIR%%/PEAR/Packager.php
+%%PEARDIR%%/PEAR/Registry.php
+%%PEARDIR%%/PEAR/Remote.php
+%%PEARDIR%%/scripts/pear.in
+%%PEARDIR%%/scripts/pear.bat
+@dirrm %%PEARDIR%%/OS
+@dirrm %%PEARDIR%%/PEAR/Command
+@dirrm %%PEARDIR%%/PEAR/Frontend
+@dirrm %%PEARDIR%%/PEAR
+@dirrm %%PEARDIR%%/scripts
+@unexec mv %D/lib/php/PEAR.dist %D/lib/php/PEAR || true
+@unexec mv %D/lib/php/PEAR.php.dist %D/lib/php/PEAR.php || true
+@unexec mv %D/lib/php/System.php.dist %D/lib/php/System.php || true
diff --git a/devel/pear-install/Makefile b/devel/pear-install/Makefile
new file mode 100644
index 000000000000..c651a1bd0ccf
--- /dev/null
+++ b/devel/pear-install/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: pear-install
+# Date created: 21 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= pear-install
+PORTVERSION= ${PHP_VERSION}
+CATEGORIES= devel www
+MASTER_SITES= # empty
+DISTFILES= # none
+EXTRACT_ONLY= # empty
+
+MAINTAINER= thierry@pompo.net
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/php-config:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_VERSION!= ${LOCALBASE}/bin/php-config --version
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_VERSION= 4.2.3
+.endif
+LPHP_LIB= lib/php
+
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+
+do-install:
+ @${ECHO_MSG} "===> Backuping the original PEAR from mod_php4 into ${PEARDIR}.DIST_PHP ..."
+ @${MKDIR} ${PEARDIR}.DIST_PHP
+ @${CP} -Rp ${PEARDIR}/* ${PEARDIR}.DIST_PHP
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-install/pkg-comment b/devel/pear-install/pkg-comment
new file mode 100644
index 000000000000..b69ccf50f469
--- /dev/null
+++ b/devel/pear-install/pkg-comment
@@ -0,0 +1 @@
+Prepare the installation of the PEAR framework
diff --git a/devel/pear-install/pkg-descr b/devel/pear-install/pkg-descr
new file mode 100644
index 000000000000..c56e666d755d
--- /dev/null
+++ b/devel/pear-install/pkg-descr
@@ -0,0 +1,6 @@
+This port does not install anything, but it prepares the installation of
+new PEAR packages.
+
+It is required by every pear- package in the FreeBSD ports tree.
+
+WWW: http://pear.php.net/
diff --git a/devel/pear-install/pkg-plist b/devel/pear-install/pkg-plist
new file mode 100644
index 000000000000..ba8e0f102edb
--- /dev/null
+++ b/devel/pear-install/pkg-plist
@@ -0,0 +1,4 @@
+@exec rm -r %D/lib/php.DIST_PHP 2>/dev/null || true
+@exec cp -Rp %D/lib/php %D/lib/php.DIST_PHP
+@unexec rm -r %D/lib/php || true
+@unexec mv %D/lib/php.DIST_PHP %D/lib/php || true
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
new file mode 100644
index 000000000000..aa371d67c6ff
--- /dev/null
+++ b/devel/pear/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: pear
+# Date created: Sat Nov 10, 2001
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= pear
+PORTVERSION= ${PHP_VERSION}
+CATEGORIES= devel www
+MASTER_SITES= # empty
+DISTFILES= # none
+EXTRACT_ONLY= # empty
+
+MAINTAINER= thierry@pompo.net
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/php-config:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR \
+ ${PEARDIR}/Console/Getopt.php.dist:${PORTSDIR}/devel/pear-Console_Getopt \
+ ${PEARDIR}/File.php:${PORTSDIR}/sysutils/pear-File \
+ ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
+ ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime \
+ ${PEARDIR}/Net/Sieve.php:${PORTSDIR}/net/pear-Net_Sieve
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_VERSION!= ${LOCALBASE}/bin/php-config --version
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_VERSION= 4.2.3
+PHP_BASE= ${LOCALBASE}
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+
+do-install: # empty
+ ${DO_NADA}
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear/pkg-comment b/devel/pear/pkg-comment
new file mode 100644
index 000000000000..bccf091e076a
--- /dev/null
+++ b/devel/pear/pkg-comment
@@ -0,0 +1 @@
+A framework and distribution system for reusable PHP components
diff --git a/devel/pear/pkg-descr b/devel/pear/pkg-descr
new file mode 100644
index 000000000000..5e107e566a81
--- /dev/null
+++ b/devel/pear/pkg-descr
@@ -0,0 +1,20 @@
+PEAR is a code repository for PHP extensions and PHP library code
+inspired by TeX's CTAN and Perl's CPAN.
+
+The purpose of PEAR is:
+
+ * to provide a consistent means for library code authors to
+ share their code with other developers;
+
+ * to give the PHP community an infrastructure for sharing code;
+
+ * to define standards that help developers write portable and
+ reusable code;
+
+ * to provide tools for code maintenance and distribution.
+
+PEAR comes bundled with PHP4. However, since it is a rapidly evolving
+target, not everyone who has a workable version of PHP4 has a recent
+enough PEAR installation.
+
+WWW: http://pear.php.net/
diff --git a/devel/pear/pkg-plist b/devel/pear/pkg-plist
new file mode 100644
index 000000000000..549a621fec0c
--- /dev/null
+++ b/devel/pear/pkg-plist
@@ -0,0 +1 @@
+@comment this plist intentionally left empty
diff --git a/mail/Makefile b/mail/Makefile
index 5c72ca80e312..85dfe8b9897e 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -175,6 +175,7 @@
SUBDIR += pantomime
SUBDIR += pantomime-ssl
SUBDIR += pathalias
+ SUBDIR += pear-Mail_Mime
SUBDIR += perdition
SUBDIR += pflogsumm
SUBDIR += pgen
diff --git a/mail/pear-Mail_Mime/Makefile b/mail/pear-Mail_Mime/Makefile
new file mode 100644
index 000000000000..49f247ca087a
--- /dev/null
+++ b/mail/pear-Mail_Mime/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: pear-Mail_Mime
+# Date created: 24 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail_Mime
+PORTVERSION= 1.2.1
+CATEGORIES= mail www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Mail
+ @${CHOWN} -R root:wheel ${PEARDIR}/Mail/*
+.for BUGMODE in mimeDecode.php mimePart.php xmail.dtd xmail.xsl
+ @${CHMOD} a-x ${PEARDIR}/Mail/${BUGMODE}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/mail/pear-Mail_Mime/distinfo b/mail/pear-Mail_Mime/distinfo
new file mode 100644
index 000000000000..cd74af7ac488
--- /dev/null
+++ b/mail/pear-Mail_Mime/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Mail_Mime-1.2.1.tgz) = 667f631d9b128ef559bf97b9cd182c48
diff --git a/mail/pear-Mail_Mime/pkg-comment b/mail/pear-Mail_Mime/pkg-comment
new file mode 100644
index 000000000000..a94306bcfd13
--- /dev/null
+++ b/mail/pear-Mail_Mime/pkg-comment
@@ -0,0 +1 @@
+PEAR classes to create and decode MIME messages
diff --git a/mail/pear-Mail_Mime/pkg-descr b/mail/pear-Mail_Mime/pkg-descr
new file mode 100644
index 000000000000..e3dc657c9ddf
--- /dev/null
+++ b/mail/pear-Mail_Mime/pkg-descr
@@ -0,0 +1,3 @@
+PEAR classes to deal with creation and manipulation of MIME messages.
+
+WWW: http://pear.php.net/manual/en/core.mail.mime.php
diff --git a/mail/pear-Mail_Mime/pkg-plist b/mail/pear-Mail_Mime/pkg-plist
new file mode 100644
index 000000000000..9ece498454c6
--- /dev/null
+++ b/mail/pear-Mail_Mime/pkg-plist
@@ -0,0 +1,5 @@
+%%PEARDIR%%/Mail/mime.php
+%%PEARDIR%%/Mail/mimeDecode.php
+%%PEARDIR%%/Mail/mimePart.php
+%%PEARDIR%%/Mail/xmail.dtd
+%%PEARDIR%%/Mail/xmail.xsl
diff --git a/net/Makefile b/net/Makefile
index 1e2f49eb9bb1..e3744185d219 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -431,6 +431,8 @@
SUBDIR += pchar
SUBDIR += pcnfsd
SUBDIR += pdnsd
+ SUBDIR += pear-Net_Sieve
+ SUBDIR += pear-Net_Socket
SUBDIR += pen
SUBDIR += perldap
SUBDIR += pfinger
diff --git a/net/pear-Net_Sieve/Makefile b/net/pear-Net_Sieve/Makefile
new file mode 100644
index 000000000000..1639fa015605
--- /dev/null
+++ b/net/pear-Net_Sieve/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: pear-Net_Sieve
+# Date created: 25 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Sieve
+PORTVERSION= 0.8.1
+CATEGORIES= net www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Net
+ @${CHOWN} root:wheel ${PEARDIR}/Net/Sieve.php
+ @${CHMOD} a-x ${PEARDIR}/Net/Sieve.php
+
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_Sieve/distinfo b/net/pear-Net_Sieve/distinfo
new file mode 100644
index 000000000000..895a477858b8
--- /dev/null
+++ b/net/pear-Net_Sieve/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Net_Sieve-0.8.1.tgz) = bc43d7a9f00ba2e2b2cfbb7c02ce6488
diff --git a/net/pear-Net_Sieve/pkg-comment b/net/pear-Net_Sieve/pkg-comment
new file mode 100644
index 000000000000..a735df618709
--- /dev/null
+++ b/net/pear-Net_Sieve/pkg-comment
@@ -0,0 +1 @@
+PEAR class to handle talking to timsieved
diff --git a/net/pear-Net_Sieve/pkg-descr b/net/pear-Net_Sieve/pkg-descr
new file mode 100644
index 000000000000..e994efc7f20b
--- /dev/null
+++ b/net/pear-Net_Sieve/pkg-descr
@@ -0,0 +1,6 @@
+Net_Sieve is a PEAR class which handles talking to timsieved.
+
+Provides an API to talk to the timsieved server that comes with Cyrus
+IMAPd. Can be used to install, remove, mark active, etc. SIEVE scripts.
+
+WWW: http://pear.php.net/package-info.php?pacid=71
diff --git a/net/pear-Net_Sieve/pkg-plist b/net/pear-Net_Sieve/pkg-plist
new file mode 100644
index 000000000000..a1753da6c08f
--- /dev/null
+++ b/net/pear-Net_Sieve/pkg-plist
@@ -0,0 +1 @@
+%%PEARDIR%%/Net/Sieve.php
diff --git a/net/pear-Net_Socket/Makefile b/net/pear-Net_Socket/Makefile
new file mode 100644
index 000000000000..1d830b2cf1ad
--- /dev/null
+++ b/net/pear-Net_Socket/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: pear-Net_Socket
+# Date created: 24 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Socket
+PORTVERSION= 1.0.1
+CATEGORIES= net www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Net
+ @${CHOWN} -R root:wheel ${PEARDIR}/Net/Socket.php
+
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_Socket/distinfo b/net/pear-Net_Socket/distinfo
new file mode 100644
index 000000000000..9de37b25e65d
--- /dev/null
+++ b/net/pear-Net_Socket/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Net_Socket-1.0.1.tgz) = f2b5f199a8586b855a549c2dccfbbd81
diff --git a/net/pear-Net_Socket/pkg-comment b/net/pear-Net_Socket/pkg-comment
new file mode 100644
index 000000000000..39f8c882c6c6
--- /dev/null
+++ b/net/pear-Net_Socket/pkg-comment
@@ -0,0 +1 @@
+PEAR Network Socket Interface
diff --git a/net/pear-Net_Socket/pkg-descr b/net/pear-Net_Socket/pkg-descr
new file mode 100644
index 000000000000..9bca37de98af
--- /dev/null
+++ b/net/pear-Net_Socket/pkg-descr
@@ -0,0 +1,7 @@
+Net_Socket is a PEAR class interface to TCP sockets.
+
+It provides blocking and non-blocking operation, with different reading
+and writing modes (byte-wise, block-wise, line-wise and special formats
+like network byte-order ip addresses).
+
+WWW: http://pear.php.net/manual/en/core.networking.net_socket.php
diff --git a/net/pear-Net_Socket/pkg-plist b/net/pear-Net_Socket/pkg-plist
new file mode 100644
index 000000000000..2426b9ad72eb
--- /dev/null
+++ b/net/pear-Net_Socket/pkg-plist
@@ -0,0 +1 @@
+%%PEARDIR%%/Net/Socket.php
diff --git a/sysutils/Makefile b/sysutils/Makefile
index cac0b402c8ca..d58ec080c9fa 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -159,6 +159,8 @@
SUBDIR += p5-User
SUBDIR += paicc
SUBDIR += pdumpfs
+ SUBDIR += pear-File
+ SUBDIR += pear-Log
SUBDIR += penv
SUBDIR += perf
SUBDIR += personality
diff --git a/sysutils/pear-File/Makefile b/sysutils/pear-File/Makefile
new file mode 100644
index 000000000000..8ccf5e68bbff
--- /dev/null
+++ b/sysutils/pear-File/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: pear-File
+# Date created: 24 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= File
+PORTVERSION= 1.0.2
+CATEGORIES= sysutils www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+ @${CHOWN} -R root:wheel ${PEARDIR}/${PORTNAME}*
+ @${CHOWN} -R root:wheel ${PEARDIR}/tests
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/pear-File/distinfo b/sysutils/pear-File/distinfo
new file mode 100644
index 000000000000..b1b3bc9496ba
--- /dev/null
+++ b/sysutils/pear-File/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/File-1.0.2.tgz) = 4ce1d2880cafcbf4a84e4adc2374a30b
diff --git a/sysutils/pear-File/pkg-comment b/sysutils/pear-File/pkg-comment
new file mode 100644
index 000000000000..7d2b91c53b5b
--- /dev/null
+++ b/sysutils/pear-File/pkg-comment
@@ -0,0 +1 @@
+PEAR common file and directory routines
diff --git a/sysutils/pear-File/pkg-descr b/sysutils/pear-File/pkg-descr
new file mode 100644
index 000000000000..7dbaaff3f463
--- /dev/null
+++ b/sysutils/pear-File/pkg-descr
@@ -0,0 +1,5 @@
+PEAR classes providing easy access to read/write to files along with
+some common routines to deal with paths. Also provides interface for
+handling CSV files.
+
+WWW: http://pear.php.net/manual/en/packages.file.php
diff --git a/sysutils/pear-File/pkg-plist b/sysutils/pear-File/pkg-plist
new file mode 100644
index 000000000000..af92a14289f3
--- /dev/null
+++ b/sysutils/pear-File/pkg-plist
@@ -0,0 +1,5 @@
+%%PEARDIR%%/File/CSV.php
+%%PEARDIR%%/File.php
+%%PEARDIR%%/tests/parser.php
+%%PEARDIR%%/tests/test.csv
+@dirrm %%PEARDIR%%/tests
diff --git a/sysutils/pear-Log/Makefile b/sysutils/pear-Log/Makefile
new file mode 100644
index 000000000000..3398734c2fe6
--- /dev/null
+++ b/sysutils/pear-Log/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: pear-Log
+# Date created: 22 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log
+PORTVERSION= 1.5
+CATEGORIES= sysutils www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+ @${CHOWN} -R root:wheel ${PEARDIR}/${PORTNAME}*
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/pear-Log/distinfo b/sysutils/pear-Log/distinfo
new file mode 100644
index 000000000000..3849df423b84
--- /dev/null
+++ b/sysutils/pear-Log/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Log-1.5.tgz) = 30421577a99e0837c0235abb89578697
diff --git a/sysutils/pear-Log/pkg-comment b/sysutils/pear-Log/pkg-comment
new file mode 100644
index 000000000000..625e42b202c1
--- /dev/null
+++ b/sysutils/pear-Log/pkg-comment
@@ -0,0 +1 @@
+PEAR logging utilities
diff --git a/sysutils/pear-Log/pkg-descr b/sysutils/pear-Log/pkg-descr
new file mode 100644
index 000000000000..d15b0ddefb82
--- /dev/null
+++ b/sysutils/pear-Log/pkg-descr
@@ -0,0 +1,6 @@
+PEAR Log framework providing an abstracted logging system.
+
+It supports logging to console, file, syslog, SQL, mail, and mcal targets.
+It also provides a subject - observer mechanism.
+
+WWW: http://pear.php.net/manual/en/packages.log.php
diff --git a/sysutils/pear-Log/pkg-plist b/sysutils/pear-Log/pkg-plist
new file mode 100644
index 000000000000..51c492c0b71a
--- /dev/null
+++ b/sysutils/pear-Log/pkg-plist
@@ -0,0 +1,10 @@
+%%PEARDIR%%/Log/composite.php
+%%PEARDIR%%/Log/console.php
+%%PEARDIR%%/Log/file.php
+%%PEARDIR%%/Log/mail.php
+%%PEARDIR%%/Log/mcal.php
+%%PEARDIR%%/Log/observer.php
+%%PEARDIR%%/Log/sql.php
+%%PEARDIR%%/Log/syslog.php
+%%PEARDIR%%/Log.php
+@dirrm %%PEARDIR%%/Log