aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/py-libconcord/Makefile3
-rw-r--r--databases/py-swift/Makefile3
-rw-r--r--devel/py-AddOns/Makefile3
-rw-r--r--devel/py-BytecodeAssembler/Makefile3
-rw-r--r--devel/py-delfick_error/Makefile3
-rw-r--r--devel/py-fusefs/Makefile3
-rw-r--r--devel/py-gobject/Makefile3
-rw-r--r--devel/py-pygdbmi/Makefile3
-rw-r--r--devel/py-repoze.who-testutil/Makefile3
-rw-r--r--devel/py-riak_pb/Makefile3
-rw-r--r--devel/py-utils/Makefile3
-rw-r--r--devel/pythk/Makefile3
-rw-r--r--mail/py-spambayes/Makefile3
-rw-r--r--math/py-numeric/Makefile3
-rw-r--r--math/py-scientific/Makefile3
-rw-r--r--net/py-libfte/Makefile3
-rw-r--r--net/py-suds/Makefile3
-rw-r--r--net/pynids/Makefile3
-rw-r--r--news/py-sabyenc/Makefile3
-rw-r--r--security/py-obfsproxy-tor/Makefile3
-rw-r--r--textproc/py-hypua2jamo/Makefile3
-rw-r--r--www/py-pylons/Makefile3
-rw-r--r--www/py-qpy/Makefile3
23 files changed, 69 insertions, 0 deletions
diff --git a/comms/py-libconcord/Makefile b/comms/py-libconcord/Makefile
index 49189d617e4d..d43a2e46ac6a 100644
--- a/comms/py-libconcord/Makefile
+++ b/comms/py-libconcord/Makefile
@@ -14,6 +14,9 @@ COMMENT= Python bindings for Logitech Harmony library
LICENSE= GPLv2
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
LIB_DEPENDS= libconcord.so:comms/libconcord
USE_LDCONFIG= yes
diff --git a/databases/py-swift/Makefile b/databases/py-swift/Makefile
index faf950f46b97..ef76433de067 100644
--- a/databases/py-swift/Makefile
+++ b/databases/py-swift/Makefile
@@ -14,6 +14,9 @@ COMMENT= Highly available, distributed, eventually consistent object/blob store
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0.5.21:devel/py-pbr@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/py-AddOns/Makefile b/devel/py-AddOns/Makefile
index ac8828b0d74d..85c648b70437 100644
--- a/devel/py-AddOns/Makefile
+++ b/devel/py-AddOns/Makefile
@@ -12,6 +12,9 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wenheping@gmail.com
COMMENT= Dynamically extend other objects with AddOns
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}DecoratorTools>=1.7:devel/py-decoratortools@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/py-BytecodeAssembler/Makefile b/devel/py-BytecodeAssembler/Makefile
index 38863a717d44..49a8ec547d8e 100644
--- a/devel/py-BytecodeAssembler/Makefile
+++ b/devel/py-BytecodeAssembler/Makefile
@@ -10,6 +10,9 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Generate Python code objects by "assembling" bytecode
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}DecoratorTools>=1.7:devel/py-decoratortools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}SymbolType>0:devel/py-SymbolType@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/py-delfick_error/Makefile b/devel/py-delfick_error/Makefile
index dd7c7b6d02c1..8f411fdede00 100644
--- a/devel/py-delfick_error/Makefile
+++ b/devel/py-delfick_error/Makefile
@@ -10,6 +10,9 @@ COMMENT= Customized exception class
LICENSE= MIT
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}total-ordering>0:devel/py-total-ordering@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
diff --git a/devel/py-fusefs/Makefile b/devel/py-fusefs/Makefile
index 8ab72447aa12..c906987fd295 100644
--- a/devel/py-fusefs/Makefile
+++ b/devel/py-fusefs/Makefile
@@ -15,6 +15,9 @@ COMMENT= FUSE Python bindings
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}fusepy # fuse.py
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/devel/py-gobject/Makefile b/devel/py-gobject/Makefile
index 4e0bd1a75fa9..b4957c81c8a2 100644
--- a/devel/py-gobject/Makefile
+++ b/devel/py-gobject/Makefile
@@ -16,6 +16,9 @@ COMMENT= Python bindings for GObject
LICENSE= LGPL21
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pycairo.pc:graphics/py-cairo@${PY_FLAVOR}
LIB_DEPENDS+= libffi.so:devel/libffi
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pycairo.pc:graphics/py-cairo@${PY_FLAVOR}
diff --git a/devel/py-pygdbmi/Makefile b/devel/py-pygdbmi/Makefile
index cb18ea516fba..ff121ad19497 100644
--- a/devel/py-pygdbmi/Makefile
+++ b/devel/py-pygdbmi/Makefile
@@ -11,6 +11,9 @@ COMMENT= Parse gdb machine interface (mi) string output
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
USE_GITHUB= yes
GH_ACCOUNT= cs01
USES= python:2.7
diff --git a/devel/py-repoze.who-testutil/Makefile b/devel/py-repoze.who-testutil/Makefile
index 639c613f3173..801b995210aa 100644
--- a/devel/py-repoze.who-testutil/Makefile
+++ b/devel/py-repoze.who-testutil/Makefile
@@ -14,6 +14,9 @@ COMMENT= Test utilities for repoze.who-powered applications
LICENSE= BSD4CLAUSE
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}repoze.who>=1.0.15:devel/py-repoze.who@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pastedeploy>=1.3.3:www/py-pastedeploy@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/py-riak_pb/Makefile b/devel/py-riak_pb/Makefile
index ff45829e2c97..e9e37fd86976 100644
--- a/devel/py-riak_pb/Makefile
+++ b/devel/py-riak_pb/Makefile
@@ -12,6 +12,9 @@ COMMENT= Riak Protocol Buffers Messages
LICENSE= APACHE20
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}protobuf>=2.4.1:devel/py-protobuf@${PY_FLAVOR}
USES= python:2.7
diff --git a/devel/py-utils/Makefile b/devel/py-utils/Makefile
index 877e6de50e15..2bb5628aaf3e 100644
--- a/devel/py-utils/Makefile
+++ b/devel/py-utils/Makefile
@@ -14,6 +14,9 @@ COMMENT= General utility modules that simplify common programming in Python
USES= python:2.7 zip
USE_PYTHON= distutils autoplist
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
PORTDOCS= *
diff --git a/devel/pythk/Makefile b/devel/pythk/Makefile
index 0b83942e438d..07cab1d342d0 100644
--- a/devel/pythk/Makefile
+++ b/devel/pythk/Makefile
@@ -13,6 +13,9 @@ COMMENT= Collection of Python functions
LICENSE= BSD2CLAUSE
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
USES= python:2.7
USE_PYTHON= distutils autoplist
diff --git a/mail/py-spambayes/Makefile b/mail/py-spambayes/Makefile
index 679f13f4001b..e64818557ca9 100644
--- a/mail/py-spambayes/Makefile
+++ b/mail/py-spambayes/Makefile
@@ -12,6 +12,9 @@ COMMENT= Bayesian anti-spam filter written in Python
LICENSE= PSFL
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:databases/py-bsddb@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dns>=2.0:dns/py-dns@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lockfile>=0.2:devel/py-lockfile@${PY_FLAVOR}
diff --git a/math/py-numeric/Makefile b/math/py-numeric/Makefile
index 8a72d2e0b1bd..55058131ff37 100644
--- a/math/py-numeric/Makefile
+++ b/math/py-numeric/Makefile
@@ -15,6 +15,9 @@ EXTRACT_ONLY= Numeric-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Numeric Extension to Python
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
USES= python:2.7
USE_PYTHON= distutils autoplist
diff --git a/math/py-scientific/Makefile b/math/py-scientific/Makefile
index 4c6237f0a97a..dd398cb6c2b2 100644
--- a/math/py-scientific/Makefile
+++ b/math/py-scientific/Makefile
@@ -12,6 +12,9 @@ DISTNAME= ScientificPython-${PORTVERSION}
MAINTAINER= fmysh@iijmio-mail.jp
COMMENT= Collection of Python modules for scientific computing
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libnetcdf.so:science/netcdf
RUN_DEPENDS= ${PYNUMPY}
diff --git a/net/py-libfte/Makefile b/net/py-libfte/Makefile
index dd1e6d69c8ec..a3a808d78b00 100644
--- a/net/py-libfte/Makefile
+++ b/net/py-libfte/Makefile
@@ -12,6 +12,9 @@ COMMENT= Format-Transforming Encryption Library/Toolkit
LICENSE= APACHE20
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
BUILD_DEPENDS= regex2dfa:textproc/regex2dfa \
${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6.1:security/py-pycrypto@${PY_FLAVOR}
LIB_DEPENDS= libgmp.so:math/gmp
diff --git a/net/py-suds/Makefile b/net/py-suds/Makefile
index 850d3f0e3fd6..df3dcdc36c67 100644
--- a/net/py-suds/Makefile
+++ b/net/py-suds/Makefile
@@ -13,6 +13,9 @@ COMMENT= SOAP implementation
LICENSE= LGPL3
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}suds-jurko-*
USES= python:2.7
diff --git a/net/pynids/Makefile b/net/pynids/Makefile
index 139def672ddd..bfd430db33db 100644
--- a/net/pynids/Makefile
+++ b/net/pynids/Makefile
@@ -12,6 +12,9 @@ DIST_SUBDIR= python
MAINTAINER= corsmith@gmail.com
COMMENT= Python interface to libnids
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
LIB_DEPENDS= libnet.so:net/libnet
USES= gnome pkgconfig python:2.7
diff --git a/news/py-sabyenc/Makefile b/news/py-sabyenc/Makefile
index 69d0ab827e8d..b60bd7c58579 100644
--- a/news/py-sabyenc/Makefile
+++ b/news/py-sabyenc/Makefile
@@ -12,6 +12,9 @@ COMMENT= Python yEnc package optimized for use within SABnzbd
LICENSE= LGPL3
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
USES= python:2.7
USE_PYTHON= autoplist distutils
diff --git a/security/py-obfsproxy-tor/Makefile b/security/py-obfsproxy-tor/Makefile
index cab60d656951..7b3f56ffecf0 100644
--- a/security/py-obfsproxy-tor/Makefile
+++ b/security/py-obfsproxy-tor/Makefile
@@ -16,6 +16,9 @@ COMMENT= Pluggable transport proxy
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyptlib>=0.0.5:security/py-pyptlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pycrypto>=2.1:security/py-pycrypto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR} \
diff --git a/textproc/py-hypua2jamo/Makefile b/textproc/py-hypua2jamo/Makefile
index 250241035aaa..4063f58688f0 100644
--- a/textproc/py-hypua2jamo/Makefile
+++ b/textproc/py-hypua2jamo/Makefile
@@ -10,6 +10,9 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= zi@FreeBSD.org
COMMENT= Convert Hanyang-PUA code to unicode Hangul Jamo
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
USES= python:2.7
USE_PYTHON= distutils autoplist
diff --git a/www/py-pylons/Makefile b/www/py-pylons/Makefile
index a585b0ea4401..f2fb8105ccf0 100644
--- a/www/py-pylons/Makefile
+++ b/www/py-pylons/Makefile
@@ -14,6 +14,9 @@ COMMENT= Python based web framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MarkupSafe>=0.15:textproc/py-MarkupSafe@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Paste>=1.7.5.1:www/py-paste@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pastedeploy>=1.5.0:www/py-pastedeploy@${PY_FLAVOR} \
diff --git a/www/py-qpy/Makefile b/www/py-qpy/Makefile
index f2a88255779c..04c5b69c1cfe 100644
--- a/www/py-qpy/Makefile
+++ b/www/py-qpy/Makefile
@@ -12,6 +12,9 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Generating safely-quoted html text from python code
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-12
+
OPTIONS_DEFINE= DOCS
USE_PYTHON= autoplist distutils