aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/ipv6calc/Makefile4
-rw-r--r--net-mgmt/ipv6calc/distinfo6
-rw-r--r--net-mgmt/ipv6calc/files/patch-databases_lib_libipv6calc__db__wrapper.c21
3 files changed, 6 insertions, 25 deletions
diff --git a/net-mgmt/ipv6calc/Makefile b/net-mgmt/ipv6calc/Makefile
index 3d8c9ebd8ca7..e28eea5653a2 100644
--- a/net-mgmt/ipv6calc/Makefile
+++ b/net-mgmt/ipv6calc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ipv6calc
-PORTVERSION= 3.0.1
+PORTVERSION= 3.0.2
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/
@@ -12,6 +12,8 @@ COMMENT= Convert, change, and calculate with IPv6 addresses
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= bash>0:shells/bash
+
USES= gmake perl5 shebangfix ssl
GNU_CONFIGURE= yes
diff --git a/net-mgmt/ipv6calc/distinfo b/net-mgmt/ipv6calc/distinfo
index 82f20f98963d..7917ebed996e 100644
--- a/net-mgmt/ipv6calc/distinfo
+++ b/net-mgmt/ipv6calc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1610734327
-SHA256 (ipv6calc-3.0.1.tar.gz) = 28b8e724a984af853877fa672e7622faba6888d4f1006940b4a0f8fef5e2dad0
-SIZE (ipv6calc-3.0.1.tar.gz) = 1607162
+TIMESTAMP = 1610834230
+SHA256 (ipv6calc-3.0.2.tar.gz) = 509e5456ed76e143b05adece1180fe78f09f4b8526e0c3cbf0c9f0188207b160
+SIZE (ipv6calc-3.0.2.tar.gz) = 1608453
diff --git a/net-mgmt/ipv6calc/files/patch-databases_lib_libipv6calc__db__wrapper.c b/net-mgmt/ipv6calc/files/patch-databases_lib_libipv6calc__db__wrapper.c
deleted file mode 100644
index c7f5c563ef71..000000000000
--- a/net-mgmt/ipv6calc/files/patch-databases_lib_libipv6calc__db__wrapper.c
+++ /dev/null
@@ -1,21 +0,0 @@
-# https://github.com/pbiering/ipv6calc/commit/6c89a416d5c8979058d9ae4a8b80c7732982c396
---- databases/lib/libipv6calc_db_wrapper.c.orig 2021-01-13 06:59:44 UTC
-+++ databases/lib/libipv6calc_db_wrapper.c
-@@ -2327,10 +2327,17 @@ int libipv6calc_db_wrapper_registry_num_by_ipv6addr(co
- DEBUGPRINT_WA(DEBUG_libipv6calc_db_wrapper, "Called: addr=%08x%08x%08x%08x", ipv6addr_getdword(ipv6addrp, 0), ipv6addr_getdword(ipv6addrp, 1), ipv6addr_getdword(ipv6addrp, 2), ipv6addr_getdword(ipv6addrp, 3));
-
- if ((cache_lu_ipv6addr_valid == 1)
-+#ifdef __KAME__ // FreeBSD misses s6_addr8/16/32 in non-kernel include, also union has different name in glibc (__in6_u vs. __u6_addr) :-(
-+ && (&cache_lu_ipv6addr.in6_addr.__u6_addr.__u6_addr32[0] == &ipv6addrp->in6_addr.__u6_addr.__u6_addr32[0])
-+ && (&cache_lu_ipv6addr.in6_addr.__u6_addr.__u6_addr32[1] == &ipv6addrp->in6_addr.__u6_addr.__u6_addr32[1])
-+ && (&cache_lu_ipv6addr.in6_addr.__u6_addr.__u6_addr32[2] == &ipv6addrp->in6_addr.__u6_addr.__u6_addr32[2])
-+ && (&cache_lu_ipv6addr.in6_addr.__u6_addr.__u6_addr32[3] == &ipv6addrp->in6_addr.__u6_addr.__u6_addr32[3])
-+#else
- && (&cache_lu_ipv6addr.in6_addr.s6_addr32[0] == &ipv6addrp->in6_addr.s6_addr32[0])
- && (&cache_lu_ipv6addr.in6_addr.s6_addr32[1] == &ipv6addrp->in6_addr.s6_addr32[1])
- && (&cache_lu_ipv6addr.in6_addr.s6_addr32[2] == &ipv6addrp->in6_addr.s6_addr32[2])
- && (&cache_lu_ipv6addr.in6_addr.s6_addr32[3] == &ipv6addrp->in6_addr.s6_addr32[3])
-+#endif
- ) {
- retval= cache_lu_ipv6addr_registry_num;
- cache_hit = 1;