aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/click/Makefile95
-rw-r--r--net/click/distinfo1
-rw-r--r--net/click/pkg-comment1
-rw-r--r--net/click/pkg-descr21
-rw-r--r--net/click/pkg-plist101
6 files changed, 220 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 1b982ff9c317..3c1645f4d39c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -38,6 +38,7 @@
SUBDIR += cisco_conf
SUBDIR += ciscoconf
SUBDIR += citrix_ica
+ SUBDIR += click
SUBDIR += clog
SUBDIR += clusterit
SUBDIR += cnet
diff --git a/net/click/Makefile b/net/click/Makefile
new file mode 100644
index 000000000000..e369c9963a7e
--- /dev/null
+++ b/net/click/Makefile
@@ -0,0 +1,95 @@
+# New ports collection makefile for: click
+# Date created: 27 June 2001
+# Whom: gnn
+#
+# $FreeBSD$
+#
+
+PORTNAME= click
+PORTVERSION= 1.2.1
+CATEGORIES= net
+MASTER_SITES= http://www.pdos.lcs.mit.edu/click/
+
+MAINTAINER= gnn@neville-neil.com
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MANCOMPRESSED= no
+MAN1= click.1 click-align.1 click-combine.1 click-devirtualize.1 \
+ click-fastclassifier.1 click-flatten.1 click-install.1 \
+ click-mkmindriver.1 click-uncombine.1 click-undead.1 \
+ click-uninstall.1 click-xform.1
+MAN5= click.5
+MAN7= elementdoc.7
+MAN8= click.o.8
+MANN= FTPPortMapper.n ARPFaker.n ARPQuerier.n ARPResponder.n \
+ EnsureEther.n EtherEncap.n EtherMirror.n HostEtherFilter.n \
+ CheckICMPHeader.n ICMPError.n ICMPPingResponder.n ICMPPingRewriter.n \
+ ICMPRewriter.n ICMPSendPings.n CheckIPHeader.n CheckIPHeader2.n \
+ DecIPTTL.n FixIPSrc.n GetIPAddress.n IPAddrRewriter.n IPClassifier.n \
+ IPEncap.n IPFilter.n IPFragmenter.n IPGWOptions.n IPInputCombo.n \
+ IPMirror.n IPOutputCombo.n IPPrint.n IPRateMonitor.n \
+ IPRewriterPatterns.n LookupIPRoute.n LookupIPRoute2.n \
+ LookupIPRouteLinux.n MarkIPCE.n MarkIPHeader.n RIPSend.n \
+ RoundRobinIPMapper.n SetIPAddress.n SetIPChecksum.n SetIPDSCP.n \
+ SetRandIPAddress.n StoreIPAddress.n StripIPHeader.n UnstripIPHeader.n \
+ AddressInfo.n Align.n AlignmentInfo.n AverageCounter.n \
+ BandwidthMeter.n BandwidthShaper.n Burster.n BandwidthRatedSplitter.n \
+ BandwidthRatedUnqueue.n CheckCRC32.n CheckLength.n CheckPaint.n \
+ Classifier.n CompareBlock.n Counter.n DelayShaper.n DelayUnqueue.n \
+ Discard.n DiscardNoFree.n DriverManager.n DropBroadcasts.n DRRSched.n \
+ Error.n FrontDropQueue.n HashDemux.n HashSwitch.n Idle.n \
+ InfiniteSource.n Meter.n MSQueue.n Null.n PushNull.n PullNull.n \
+ Null1.n Null2.n Null3.n Null4.n Null5.n Null6.n Null7.n Null8.n \
+ Paint.n PaintTee.n PeekHandlers.n PokeHandlers.n Print.n PrioSched.n \
+ ProbSplitter.n PullSwitch.n PullToPush.n Queue.n QuitWatcher.n \
+ RandomBitErrors.n RandomLossage.n RandomSource.n RatedSource.n \
+ RatedSplitter.n RatedUnqueue.n RED.n RoundRobinSched.n \
+ RoundRobinSwitch.n ScheduleInfo.n SetCRC32.n SetTimestamp.n Shaper.n \
+ SpinlockAcquire.n SpinlockInfo.n SpinlockRelease.n StaticPullSwitch.n \
+ StaticSwitch.n StrideSched.n StrideSwitch.n Strip.n Suppressor.n \
+ Switch.n Tee.n PullTee.n TimedSink.n TimedSource.n Unqueue.n \
+ Unqueue2.n Unstrip.n CheckTCPHeader.n CheckUDPHeader.n \
+ DynamicUDPIPEncap.n IPRewriter.n SetTCPChecksum.n TCPRewriter.n \
+ UDPIPEncap.n ChatterSocket.n ControlSocket.n FromBPF.n FromDevice.u.n \
+ FromDump.n KernelTap.n KernelHandlerProxy.n PrintOld.n ToBPF.n \
+ ToDevice.u.n ToDump.n elements.n
+
+CONFDIR= ${PREFIX}/etc/click/conf
+
+post-install:
+ @strip ${PREFIX}/bin/click
+ @strip ${PREFIX}/bin/click-align
+ @strip ${PREFIX}/bin/click-check
+ @strip ${PREFIX}/bin/click-combine
+ @strip ${PREFIX}/bin/click-uncombine
+ @strip ${PREFIX}/bin/click-devirtualize
+ @strip ${PREFIX}/bin/click-fastclassifier
+ @strip ${PREFIX}/bin/click-flatten
+ @strip ${PREFIX}/bin/click-mkmindriver
+ @strip ${PREFIX}/bin/click-undead
+ @strip ${PREFIX}/bin/click-xform
+ @${MKDIR} ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/fake-iprouter.click ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/ip.clickpat ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/ip6ndadvertiser.click ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/ip6ndsolicitor.click ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/kernel.clickpat ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/mazu-nat.click ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/test-device.click ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/test-tap.click ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/test.click ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/test2.click ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/test3.click ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/udpgen.click ${CONFDIR}
+ @echo
+ @echo "----------------------------------------------------"
+ @echo "Install complete, to try it out do the following:"
+ @echo "cd ${PREFIX}/etc/click/conf"
+ @echo "click test.click"
+ @echo "You should see some output. Now go read the papers and manual."
+ @echo "----------------------------------------------------"
+ @echo
+
+.include <bsd.port.mk>
diff --git a/net/click/distinfo b/net/click/distinfo
new file mode 100644
index 000000000000..d32556d63131
--- /dev/null
+++ b/net/click/distinfo
@@ -0,0 +1 @@
+MD5 (click-1.2.1.tar.gz) = 7dcdec4eb21c3e742787a92c404ac54c
diff --git a/net/click/pkg-comment b/net/click/pkg-comment
new file mode 100644
index 000000000000..d0981e5d1b11
--- /dev/null
+++ b/net/click/pkg-comment
@@ -0,0 +1 @@
+The Click Modular Router
diff --git a/net/click/pkg-descr b/net/click/pkg-descr
new file mode 100644
index 000000000000..2b307f0be1d2
--- /dev/null
+++ b/net/click/pkg-descr
@@ -0,0 +1,21 @@
+This is the port of the Click Modular Router.
+
+From the web page:
+
+Click is a new modular software router for PCs developed by MIT
+LCS's Parallel and Distributed Operating Systems group. Click
+routers are flexible, configurable, and easy to understand at a
+high level. They're also pretty fast (for software routers running
+on commodity hardware); on a 700 MHz Pentium III, a Click IP router
+can handle up to 435,000 64-byte packets a second.
+
+WWW: http://www.pdos.lcs.mit.edu/click/
+
+This port of click runs only as a user mode process on FreeBSD.
+Kernel implementations run on Linux. There is a move afoot to
+port this code tot the FreeBSD kernel as well. See the mailing
+list (available via the web page) for more information.
+
+George V. Neville-Neil
+
+gnn@neville-neil.com
diff --git a/net/click/pkg-plist b/net/click/pkg-plist
new file mode 100644
index 000000000000..6696c8013932
--- /dev/null
+++ b/net/click/pkg-plist
@@ -0,0 +1,101 @@
+bin/click
+bin/click-align
+bin/click-check
+bin/click-combine
+bin/click-uncombine
+bin/click-devirtualize
+bin/click-fastclassifier
+bin/click-flatten
+bin/click-mkmindriver
+bin/click-undead
+bin/click-xform
+bin/click-buildtool
+bin/click-compile
+bin/click-mkelemmap
+bin/click-elem2man
+include/click/elementt.hh
+include/click/lexert.hh
+include/click/processingt.hh
+include/click/routert.hh
+include/click/toolutils.hh
+include/click/archive.hh
+include/click/atomic.hh
+include/click/bighashmap.cc
+include/click/bighashmap.hh
+include/click/bighashmap_arena.hh
+include/click/bitvector.hh
+include/click/click_ether.h
+include/click/click_icmp.h
+include/click/click_icmp6.h
+include/click/click_ip.h
+include/click/click_ip6.h
+include/click/click_tcp.h
+include/click/click_udp.h
+include/click/clp.h
+include/click/config.h
+include/click/confparse.hh
+include/click/crc32.h
+include/click/cxxprotect.h
+include/click/cxxunprotect.h
+include/click/element.hh
+include/click/elemfilter.hh
+include/click/error.hh
+include/click/etheraddress.hh
+include/click/ewma.cc
+include/click/ewma.hh
+include/click/gaprate.hh
+include/click/glue.hh
+include/click/hashmap.cc
+include/click/hashmap.hh
+include/click/integers.hh
+include/click/ip6address.hh
+include/click/ip6flowid.hh
+include/click/ip6table.hh
+include/click/ipaddress.hh
+include/click/ipaddressset.hh
+include/click/ipflowid.hh
+include/click/iptable.hh
+include/click/iptable2.hh
+include/click/lexer.hh
+include/click/llrpc.h
+include/click/package.hh
+include/click/packet.hh
+include/click/packet_anno.hh
+include/click/pathvars.h
+include/click/perfctr.hh
+include/click/radix.hh
+include/click/router.hh
+include/click/routerthread.hh
+include/click/skbmgr.hh
+include/click/straccum.hh
+include/click/string.hh
+include/click/subvector.hh
+include/click/sync.hh
+include/click/task.hh
+include/click/timer.hh
+include/click/userutils.hh
+include/click/variableenv.hh
+include/click/vector.cc
+include/click/vector.hh
+include/clicktool/elementt.hh
+include/clicktool/lexert.hh
+include/clicktool/processingt.hh
+include/clicktool/routert.hh
+include/clicktool/toolutils.hh
+@unexec install-info --delete %D/info/click.info %D/info/dir
+info/click.info
+info/click.info-1
+info/click.info-2
+info/click.info-3
+info/click.info-4
+info/click.info-5
+@exec install-info --section="Click Modular Router" --entry="* click: (click). Click Modular Router" %D/info/click.info %D/info/dir
+@unexec rm -rf %D/etc/click
+lib/libclick.a
+lib/libclicktool.a
+share/click/elementmap
+share/click/srcdir
+share/click/src
+@dirrm include/click
+@dirrm include/clicktool
+@dirrm share/click